Bug 9107 - hid-input.c lacks key codes for microsoft presenter mouse 8000 in presentation mode
hid-input.c lacks key codes for microsoft presenter mouse 8000 in presentatio...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-01 09:59 UTC by Alan Campbell
Modified: 2012-05-17 14:45 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: No


Attachments

Description Alan Campbell 2007-10-01 09:59:34 UTC
Most recent kernel where this bug did not occur: None
Distribution:ubuntu7.04
Hardware Environment:microsoft wireless notebook presenter mouse 8000
Software Environment:
Problem Description:
presentation mode buttons don't work due to missing mapping in hid-input.c

Problem Fix:
add following mapping in case HID_UP_MSVENDOR in hid-input.c


                case HID_UP_MSVENDOR:
                        switch (usage->hid & HID_USAGE) {
                                case 0x000: goto ignore;
                                case 0xfd08: map_key_clear(KEY_PAGEDOWN);       break;
                                case 0xfd09: map_key_clear(KEY_PAGEUP);         break;
                                case 0xfd0b: map_key_clear(KEY_PLAYPAUSE);      break;
                                default:    goto ignore;
                        }
                        break;



Steps to reproduce:

Note You need to log in before you can comment on or make changes to this bug.