Bug 9079 - NETDEV WATCHDOG: eth0: transmit timed out
NETDEV WATCHDOG: eth0: transmit timed out
Status: REJECTED INSUFFICIENT_DATA
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Francois Romieu
:
Depends on:
Blocks: 9056
  Show dependency treegraph
 
Reported: 2007-09-26 14:30 UTC by Rafael J. Wysocki
Modified: 2008-09-29 09:53 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.23-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-09-26 14:30:32 UTC
References      : http://lkml.org/lkml/2007/8/13/737
Submitter       : Karl Meyer <adhocrocker@gmail.com>
Handled-By      : Francois Romieu <romieu@fr.zoreil.com>
Comment 1 Rolf Eike Beer 2007-09-27 06:38:53 UTC
I see the same problems here with this card (builtin in Toshiba Satellite A110-178). S2disk and wakeup is enough to cure it. First time I noticed it was on August 10th (which was sometime between -rc2 and -rc3).

05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller (rev 01)
        Subsystem: Toshiba America Info Systems Unknown device ff00
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 220
        Region 0: I/O ports at 4000 [size=256]
        Region 2: Memory at da000000 (64-bit, non-prefetchable) [size=4K]
        [virtual] Expansion ROM at d4000000 [disabled] [size=64K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1+,D2+,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME+
        Capabilities: [48] Vital Product Data
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/1 Enable+
                Address: 00000000fee0100c  Data: 41e9
        Capabilities: [60] Express Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, ExtTag+
                Device: Latency L0s <1us, L1 unlimited
                Device: AtnBtn+ AtnInd+ PwrInd+
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                Device: MaxPayload 128 bytes, MaxReadReq 128 bytes
                Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s, Port 0
                Link: Latency L0s unlimited, L1 unlimited
                Link: ASPM Disabled RCB 64 bytes CommClk+ ExtSynch-
                Link: Speed 2.5Gb/s, Width x1
        Capabilities: [84] Vendor Specific Information
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [12c] Virtual Channel
        Capabilities: [148] Device Serial Number nn-nn-nn-nn-nn-nn-nn-nn
        Capabilities: [154] Power Budgeting
Comment 2 Francois Romieu 2007-10-04 15:30:29 UTC
The 8101 and the 8168 are different enough for the problem to be different
for each adapter.

Rolf, did 2.6.23-rc1 work correctly ?

-- 
Ueimor
Comment 3 Alan 2008-09-23 03:06:17 UTC
No response in over 9 months, closing
Comment 4 Rolf Eike Beer 2008-09-23 04:36:01 UTC
Sorry, this one got lost. No idea, it's an older kernel. Bug is still present in 2.6.26.
Comment 5 Francois Romieu 2008-09-23 14:20:05 UTC
Rolf, is it still present in 2.6.27-rc6 + 
http://userweb.kernel.org/~romieu/r8169/2.6.27-rc6/20080913-r8169-test.patch

-- 
Ueimor
Comment 6 Rolf Eike Beer 2008-09-26 04:20:42 UTC
I have tried with 2.6.27-rc7-git a "svn up ~/repos/KDE" which is a (sparse) SVN checkout of KDE SVN root. This was an absolutely reliable way to cause that timeout. It _was_, it works now.
Comment 7 Rolf Eike Beer 2008-09-29 09:53:54 UTC
Here it is again:

WARNING: at /home/eike/repos/linux-2.6/net/sched/sch_generic.c:219 dev_watchdog+0xfb/0x17d()
NETDEV WATCHDOG: eth0 (r8169): transmit timed out
Modules linked in: iptable_filter ip_tables ip6table_filter ip6_tables x_tables ipv6 af_packet snd_pcm_oss snd_mixer_oss snd_seq snd_seq_device cpufreq_conservative cpufr
eq_ondemand cpufreq_userspace cpufreq_powersave acpi_cpufreq speedstep_lib freq_table fuse twofish twofish_common cbc dm_crypt nls_utf8 ntfs ext3 jbd loop omnibook mmc_bl
ock arc4 ecb crypto_blkcipher pcmcia iwl3945 video backlight sdhci_pci sdhci intel_agp snd_hda_intel rfkill yenta_socket ohci1394 output rsrc_nonstatic container ac agpga
rt battery mmc_core ieee1394 pcmcia_core mac80211 snd_pcm button snd_timer snd i2c_i801 iTCO_wdt serio_raw soundcore i2c_core cfg80211 joydev sr_mod r8169 snd_page_alloc
cdrom sg usbhid sd_mod ehci_hcd uhci_hcd usbcore dm_snapshot edd dm_mod fan ata_piix libata scsi_mod dock thermal processor
Pid: 0, comm: swapper Not tainted 2.6.27-rc7-git #67
 [<c01201ce>] warn_slowpath+0x4b/0x6c
 [<c0255e4f>] ? __kfree_skb+0x63/0x66
 [<c0255e7b>] ? kfree_skb+0x29/0x2b
 [<c028b4cd>] ? arp_process+0x547/0x561
 [<c028b5c9>] ? arp_rcv+0xd8/0xeb
 [<c025a68a>] ? netif_receive_skb+0x1b1/0x1c8
 [<c01d54c6>] ? strlcpy+0x17/0x49
 [<c0265b11>] dev_watchdog+0xfb/0x17d
 [<c01281ea>] ? __mod_timer+0xc5/0xd0
 [<f8b1d8b2>] ? sta_info_cleanup+0x119/0x121 [mac80211]
 [<c02b3bfc>] ? _spin_unlock_irq+0x8/0xb
 [<c0127b34>] run_timer_softirq+0x13b/0x19b
 [<c0265a16>] ? dev_watchdog+0x0/0x17d
 [<c0265a16>] ? dev_watchdog+0x0/0x17d
 [<c012467d>] __do_softirq+0x70/0xd5
 [<c012460d>] ? __do_softirq+0x0/0xd5
 [<c0105862>] do_softirq+0x5c/0x92
 [<c014f090>] ? handle_edge_irq+0x0/0x109
 [<c012440f>] irq_exit+0x38/0x6d
 [<c01057ef>] do_IRQ+0xe7/0xfe
 [<c01042d7>] common_interrupt+0x23/0x28
 [<f8828134>] ? acpi_idle_enter_bm+0x2cc/0x34e [processor]
 [<c0247a29>] cpuidle_idle_call+0x59/0x89
 [<c01029fa>] cpu_idle+0xd1/0xf3
 [<c02a6d86>] rest_init+0x4e/0x50

Note You need to log in before you can comment on or make changes to this bug.