Bug 9065 - usb/serial/pl2303: support for BenQ Siemens Mobile Phone S81
usb/serial/pl2303: support for BenQ Siemens Mobile Phone S81
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2007-09-25 09:22 UTC by Rolf Leggewie
Modified: 2009-06-02 08:55 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.22-12-generic (latest gutsy)
Tree: Mainline
Regression: No


Attachments
Ausgabe von "lsusb -s 007 -v" (3.53 KB, text/plain)
2007-09-25 09:25 UTC, Rolf Leggewie
Details
patch for S81 mobile phone modelled after attachment 12517 (659 bytes, text/plain)
2008-09-26 04:38 UTC, Rolf Leggewie
Details
Test patch (1.37 KB, text/plain)
2009-03-25 15:28 UTC, Alan
Details

Description Rolf Leggewie 2007-09-25 09:22:11 UTC
+++ This bug was initially created as a clone of Bug #8932 +++

Distribution: Ubuntu gutsy
Hardware Environment: BenQ Siemens Mobile Phone S81 connected via USB-cord
Problem Description: 
pl2303 already supports some Siemens Mobile Phones (SX1, X65, X75, ...), but support for S81 is missing.  It would be nice to have it supported.  Maybe bug 8932 can serve as a template.  Thank you for your hard work.
Comment 1 Rolf Leggewie 2007-09-25 09:25:23 UTC
Created attachment 12935 [details]
Ausgabe von "lsusb -s 007 -v"
Comment 2 Natalie Protasevich 2007-11-16 16:49:26 UTC
Rolf,
In the last patchset that Greg KH submitted for 2.6.23 there is one:
Andreas Loibl (1):
     usb: serial/pl2303: support for BenQ Siemens Mobile Phone EF81

And if this is for the bug that you are referring to, this should be it.

Have you tested with 2.6.23+?
Thanks.
Comment 3 Rolf Leggewie 2007-11-17 03:50:53 UTC
Natalie,

thank you for your comment.  I believe that the patchset you are referring to deals with bug 8932 but not this one (yet).
Comment 4 Alan 2008-09-24 03:58:43 UTC
Seems to all be merged
Comment 5 Rolf Leggewie 2008-09-26 04:38:05 UTC
Created attachment 18054 [details]
patch for S81 mobile phone modelled after attachment 12517 [details]

(In reply to comment #4)
> Seems to all be merged

Doesn't look like it is to me:

$ grep 81 drivers/usb/serial/pl2303.c
        { USB_DEVICE(SIEMENS_VENDOR_ID, SIEMENS_PRODUCT_ID_EF81) },

The EF81 has made it in and thus bug 8932 is indeed fixed.  I guess we need something similar to attachment 12517 [details] from that bug.  Please see the attachment from this comment which I assume should do the trick.
Comment 6 Alan 2008-09-26 04:55:18 UTC
Thanks for clarifying that the two phones have differing identifiers.

In order to get your patched merged can you either
- post a copy with a Signed-off-by: line to the linux-kernel@vger.kernel.org list (you don't need to be a subscriber)
- or if you'd prefer to do it via bugzilla just give me permission to add a signed-off-by: line for you to the patch and do the merging.

Thanks
Alan
Comment 7 Rolf Leggewie 2008-09-28 03:43:06 UTC
Thanks, Alan.

Unfortunately, apparently, that patch in itself is not sufficient.  With that patch applied, the kernel cannot be compiled.  It looks like that in the case of the EF81 there was already some information about it in pl2303.h.  There is notthing about the S81 in there and I believe that is why the compilation fails.  

Maybe somebody more experienced than me can take a look?
Comment 8 Alan 2009-03-25 15:27:34 UTC
Finally got time to glance at this please test the patch that follows
Comment 9 Alan 2009-03-25 15:28:04 UTC
Created attachment 20674 [details]
Test patch
Comment 10 Rolf Leggewie 2009-06-02 06:33:19 UTC
I apologize for the late response.  I believe the patch is working fine.

From syslog:
Jun  2 15:27:04 X24 kernel: [18496.590824] usb 1-1.1: new full speed USB device using uhci_hcd and address 4
Jun  2 15:27:04 X24 kernel: [18496.709050] usb 1-1.1: configuration #1 chosen from 1 choice
Jun  2 15:27:10 X24 kernel: [18502.239306] usbcore: registered new interface driver usbserial
Jun  2 15:27:10 X24 kernel: [18502.239339] USB Serial support registered for generic
Jun  2 15:27:10 X24 kernel: [18502.239406] usbcore: registered new interface driver usbserial_generic
Jun  2 15:27:10 X24 kernel: [18502.239410] usbserial: USB Serial Driver core
Jun  2 15:27:10 X24 kernel: [18502.299789] USB Serial support registered for pl2303
Jun  2 15:27:10 X24 kernel: [18502.299840] pl2303 1-1.1:1.0: pl2303 converter detected
Jun  2 15:27:10 X24 kernel: [18502.313345] usb 1-1.1: pl2303 converter now attached to ttyUSB0
Jun  2 15:27:10 X24 kernel: [18502.313382] pl2303 1-1.1:1.1: pl2303 converter detected
Jun  2 15:27:10 X24 kernel: [18502.325326] usb 1-1.1: pl2303 converter now attached to ttyUSB1
Jun  2 15:27:10 X24 kernel: [18502.325367] usbcore: registered new interface driver pl2303
Jun  2 15:27:10 X24 kernel: [18502.325373] pl2303: Prolific PL2303 USB to serial adaptor driver
Jun  2 15:27:12 X24 NetworkManager: <info>  (ttyUSB1): ignoring due to lack of mobile broadband capabilties 
Jun  2 15:27:12 X24 NetworkManager: <info>  (ttyUSB0): ignoring due to lack of mobile broadband capabilties 

The only thing I am not sure about are those last two lines.

I have not yet made any GSM connection or actually accessed the device apart from looking at syslog right after plugging the phone in via USB.
Comment 11 Rolf Leggewie 2009-06-02 06:35:48 UTC
I cannot acces the internal storage on the phone.  Is this something that should be driven by pl2303?  In that case, I would like to reopen this bug.
Comment 12 Alan 2009-06-02 08:55:38 UTC
That all looks in order

The last 2 are not the kernel but NetworkManager (part of some desktops) deciding your phone doesn't look like a 3G dongle and therefore doesn't need to be managed that way.

I have no idea how the internal storage is handled on this phone. I assume you would need a suitable application to talk syncml or whatever the phone speaks over the serial link for this purpose.

Note You need to log in before you can comment on or make changes to this bug.