Bug 9058 - cpu hotplug support broken in 2.6.23-rc3
cpu hotplug support broken in 2.6.23-rc3
Status: RESOLVED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 9056
  Show dependency treegraph
 
Reported: 2007-09-23 14:37 UTC by Rafael J. Wysocki
Modified: 2007-11-15 14:23 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.23-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2007-09-23 14:37:40 UTC
References      : http://lkml.org/lkml/2007/8/27/58
                  http://lkml.org/lkml/2007/9/3/65
Submitter       : Pavel Machek <pavel@ucw.cz>
Handled-By      : Thomas Gleixner <tglx@linutronix.de>
Comment 1 Rafael J. Wysocki 2007-09-23 14:45:10 UTC
Fixed by commit 5e41d0d60a534d2a5dc9772600a58f44c8d12506
Comment 2 Rafael J. Wysocki 2007-09-24 08:46:19 UTC
(In reply to comment #1)
> Fixed by commit 5e41d0d60a534d2a5dc9772600a58f44c8d12506

Commit:	5e41d0d60a534d2a5dc9772600a58f44c8d12506
Parent:	31d9b3938c0459e5e9755ce0a98ac1e24eeff972
Author:	Thomas Gleixner <tglx@linutronix.de>
AuthorDate: Sun, 16 Sep 2007 13:36:43 +0000 (15:36 +0200)
Committer: Thomas Gleixner <tglx@chaos.(none)>
CommitDate: Sun, 16 Sep 2007 13:36:43 +0000 (15:36 +0200)

clockevents: prevent stale tick update on offline cpu

"http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=5e41d0d60a534d2a5dc9772600a58f44c8d12506"
Comment 3 Rafael J. Wysocki 2007-10-02 12:49:46 UTC
Reopened because of: http://lkml.org/lkml/2007/10/2/104
Comment 4 Thomas Gleixner 2007-10-02 16:02:47 UTC
Hmm,

root@amd:/sys/devices/system/cpu/cpu1# echo 0 > online
root@amd:/sys/devices/system/cpu/cpu1# echo 0 > online
-bash: echo: write error: Device or resource busy

The second one fails. The cpu _IS_ already offline. otherwise the first one would not have come back. Thats the problem which was caused by the subtle clock events thinkos. The clock event bugs made the first one to be stuck for ever.
That's a different problem. Did this ever work ?

root@amd:/sys/devices/system/cpu/cpu1# echo 1 > online
-bash: echo: write error: Device or resource busy

This might be a follow up error caused by the second write.

I do not see how this should be connected to the clock events problems which we had before.

Pavel, does the following work ?

root@amd:/sys/devices/system/cpu/cpu1# echo 0 > online
root@amd:/sys/devices/system/cpu/cpu1# echo 1 > online

Is your double offline problem really a new one in .23 ?

Comment 5 Rafael J. Wysocki 2007-10-06 07:20:23 UTC
Pavel?
Comment 6 Pavel Machek 2007-11-15 14:23:59 UTC
(Sorry for delay)

Yes, repeated offlines/onlines seem to work now. echo 0, twice, is probably different issue. So I guess this is "CODE_FIX" now.

Note You need to log in before you can comment on or make changes to this bug.