Bug 9038 - kernel BUG when resuming from disk
kernel BUG when resuming from disk
Status: CLOSED INVALID
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2007-09-18 23:33 UTC by Cihan
Modified: 2007-09-19 13:50 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.22.6
Tree: Mainline
Regression: ---


Attachments

Description Cihan 2007-09-18 23:33:29 UTC
Most recent kernel where this bug did not occur: don't know
Distribution: Debian unstable
Hardware Environment: ASUS L2B Laptop
Software Environment: uswsusp 0.7
Problem Description:
After updating the uswsusp package from 0.6~cvs20070618-1 to 0.7-1 I cannot resume after suspending to disk. Kernel output is as follows:
<snip>
kernel BUG at kernel/power/snapshot.c:464!
invalid opcode: 0000 [#1]
Modules linked in: usbhid floppy ohci1394 ieee1394 8139too mii uhci_hcd usbcore thermal processor fan
CPU:    0
EIP:    0060:[<c01355e4>]    Not tainted VLI
EFLAGS: 00010246   (2.6.22.6 #1)
EIP is at memory_bm_find_bit+0x68/0x6c
eax: c03e4ee4   ebx: ef43df38   ecx: 00000000   edx: 9f000040
esi: ef43df3c   edi: b7ba5008   ebp: c03e4f20   esp: ef43df28
ds: 007b   es: 007b   fs: 0000  gs: 0033  ss: 0068
Process resume (pid: 1009, ti=ef43c000 task=ef6b6530 task.ti=ef43c000)
Stack: ef43df38 ef751000 c0135654 ef43df38 00000002 ef73b000 00000004 c013634e 
       dffbb400 c023e384 00001000 00000000 00000000 ef45a240 c03e4f20 b7ba5008 
       00001000 c01372c2 ef45a240 b7ba5008 c01372b1 c0154492 ef43dfa0 00000000 
Call Trace:
 [<c0135654>] memory_bm_set_bit+0x14/0x24
 [<c013634e>] snapshot_write_next+0x16b/0x53a
 [<c023e384>] tty_write+0x179/0x1b2
 [<c01372c2>] snapshot_write+0x11/0x47
 [<c01372b1>] snapshot_write+0x0/0x47
 [<c0154492>] vfs_write+0x87/0x118
 [<c0154970>] sys_write+0x41/0x6a
 [<c0103d0a>] syscall_call+0x7/0xb
 =======================
Code: 53 08 73 f5 89 59 10 89 d0 2b 43 04 89 c1 83 e1 1f 8b 54 24 0c 89 0a c1 e8 03 25 fc ff ff 1f 03 43 10 89 06 5b 5e c3 0f 0b eb fe <0f> 0b eb fe 53 83 ec 0c 8d 4c 24 08 8d 5c 24 04 89 1c 24 e8 80 
EIP: [<c01355e4>] memory_bm_find_bit+0x68/0x6c SS:ESP 0068:ef43df28
</snip>

Steps to reproduce:
Suspend to disk via s2disk. Power on.
Comment 1 Rafael J. Wysocki 2007-09-19 04:14:36 UTC
Is this 100% reproducible?
Comment 2 Cihan 2007-09-19 06:41:53 UTC
Yes, tried twice with same results.
Comment 3 Rafael J. Wysocki 2007-09-19 08:34:22 UTC
It looks like your resume binary has not been upgraded along with s2disk.

If you use an initrd, please make sure it has been regenerated with the new resume binary.  Also please check if the resume binary has been installed in the same place as with the previous version of the suspend package.
Comment 4 Cihan 2007-09-19 12:52:11 UTC
Thanks a lot. The reason was indeed that the update script did not take care of the initrd image.
Comment 5 Rafael J. Wysocki 2007-09-19 13:49:54 UTC
This is not a kernel bug, so I'm closing this entry with resolution "invalid".

Note You need to log in before you can comment on or make changes to this bug.