Bug 9032 - Cannot unload agpgart module
Cannot unload agpgart module
Status: REJECTED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: Video(AGP)
All Linux
: P1 normal
Assigned To: Dave Airlie
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-17 06:17 UTC by Martin Mokrejs
Modified: 2009-03-24 04:58 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.24
Tree: Mainline
Regression: ---


Attachments
cannot unload agpgart nor intel_agp (218.39 KB, image/jpeg)
2007-09-17 06:18 UTC, Martin Mokrejs
Details
forcing agpgart unload causes oops (478.99 KB, image/jpeg)
2007-09-17 06:20 UTC, Martin Mokrejs
Details
"ps -ef" and "lsof" outputs (23.37 KB, text/plain)
2008-03-04 00:56 UTC, Martin Mokrejs
Details
/proc/config from running kernel 2.6.24.2 (49.99 KB, text/plain)
2008-03-04 00:57 UTC, Martin Mokrejs
Details

Description Martin Mokrejs 2007-09-17 06:17:39 UTC
Most recent kernel where this bug did not occur: cannot say, I am trying to confirm whether bug #2913 still exists.

Distribution: Gentoo
Hardware Environment: ASUS L3C/S laptop, P4, Radeon 7500M
Software Environment: vanilla 2.6.22.6
Problem Description:

I went to singleuser mode, but my system picked up the modules so they got loaded and placed me into singleuser. I went to unload all the modules, in which I succeeded except two modules: agpgart and intel_agp. agpgart should be unused
but it claims it is being used. How can I find who is using it? I 

Steps to reproduce:
Comment 1 Martin Mokrejs 2007-09-17 06:18:20 UTC
Created attachment 12845 [details]
cannot unload agpgart nor intel_agp
Comment 2 Martin Mokrejs 2007-09-17 06:20:22 UTC
Created attachment 12846 [details]
forcing agpgart unload causes oops

BTW, my HW setup is normally detected as:

Linux agpgart interface v0.102 (c) Dave Jones
agpgart: Detected an Intel 845G Chipset.
agpgart: AGP aperture is 256M @ 0xe0000000
[drm] Initialized drm 1.1.0 20060810
[drm] Initialized radeon 1.27.0 20060524 on minor 0
...
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 4x mode
[drm] Setting GART location based on new memory map
[drm] writeback test succeeded in 2 usecs
Comment 3 Natalie Protasevich 2008-02-11 21:38:04 UTC
I think there were relevant fixes made by Dave Jones since.
Martin, have you tried using recent kernel, is the problem still there?
Comment 4 Natalie Protasevich 2008-03-03 20:50:01 UTC
Ping... I am tending to close this bug soon, so "silence is consent" :)
Comment 5 Martin Mokrejs 2008-03-04 00:54:32 UTC
I have unloaded all modules except these two by rmmod command:
Module                  Size  Used by
intel_agp              23316  1 
agpgart                31280  1 intel_agp
#

I tried to force removal of agpgart but it said something about temporarily disabling of the device/module but it remained in the module list and nothing got apparently logged by syslog. I had to force removal of intel_agp and only then I have succeeded in removing agpgart (without forcing). And, no kernel crash (2.6.24.2).
Comment 6 Martin Mokrejs 2008-03-04 00:56:15 UTC
Created attachment 15135 [details]
"ps -ef" and "lsof" outputs

I have no idea why I had to force unloading of intel_agp. I don't think it was opened.
Comment 7 Martin Mokrejs 2008-03-04 00:57:33 UTC
Created attachment 15136 [details]
/proc/config from running kernel 2.6.24.2
Comment 8 Alan 2009-03-24 04:58:38 UTC
Closing out old stale bugs. If this in error please re-open

Note You need to log in before you can comment on or make changes to this bug.