Bug 9008 - Asus laptop hangs on TFT/VGA video switch (Fn-F8) - Asus M6800Ne
Asus laptop hangs on TFT/VGA video switch (Fn-F8) - Asus M6800Ne
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2007-09-11 13:32 UTC by Nicolo' Chieffo
Modified: 2013-04-09 06:23 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.22 2.6.23
Tree: Mainline
Regression: ---


Attachments
nolapic.acpidump (118.64 KB, text/plain)
2007-09-12 01:40 UTC, Nicolo' Chieffo
Details
nolapic.interrupts (755 bytes, text/plain)
2007-09-12 01:41 UTC, Nicolo' Chieffo
Details
normal.acpidump (118.64 KB, text/plain)
2007-09-12 01:41 UTC, Nicolo' Chieffo
Details
normal.interrupts (730 bytes, text/plain)
2007-09-12 01:41 UTC, Nicolo' Chieffo
Details
nolapic./var/log/acpid (2.29 KB, text/plain)
2007-09-12 13:07 UTC, Nicolo' Chieffo
Details
nolapic.interrupts (724 bytes, text/plain)
2007-09-13 01:48 UTC, Nicolo' Chieffo
Details
normal.interrupts (724 bytes, text/plain)
2007-09-13 01:49 UTC, Nicolo' Chieffo
Details
dmesg -s64000 (26.49 KB, text/plain)
2008-01-07 06:55 UTC, Nicolo' Chieffo
Details

Description Nicolo' Chieffo 2007-09-11 13:32:32 UTC
Most recent kernel where this bug did not occur: 2.6.23-0.161.rc5.fc8 / 2.6.22-11
Distribution: fedora / ubuntu
Hardware Environment: asus laptop M6800Ne
Software Environment: fedora rawhide 8 and ubuntu gutsy
Problem Description:
when hitting fn-f8, the hotkey combination to switch the displays the system hangs (always). There is a fix that is to boot with the option "nolapic". In this case there is no hang, and the hotkey will produce an acpi event
Steps to reproduce:
press fn f8
Comment 1 Andrew Morton 2007-09-11 13:53:20 UTC
Could you please be more specific/accurate in identifying which kernels
do and do not have this bug?  The above info seems to be saying that
2.6.22 and 2.6.23 both have the bug, and they both do not have the bug.

Comment 2 Nicolo' Chieffo 2007-09-11 14:06:50 UTC
I am sorry. is it possible to edit the description? I didn't read well, sorry.. I'm using kernels since 2.6.15 but no kernel was ok. So:
Most recent kernel where this bug did not occur: none.
Comment 3 Zhang Rui 2007-09-11 23:07:32 UTC
Hmm,
1.please attach the acpidump output and the content of "/proc/interrupts" with and without "nolapic".
2.Please verify if this still happens in console mode.
3.are you sure it's an acpi event when press Fn+F8? Please kill acpid and "cat /proc/acpi/event" to see what will happen next when you press fn+f8.
Please "echo 0 > /proc/acpi/video/xxx/DOS" before you press fn+f8 and see 
if the system still hangs.
Comment 4 Nicolo' Chieffo 2007-09-12 01:40:50 UTC
Created attachment 12798 [details]
nolapic.acpidump
Comment 5 Nicolo' Chieffo 2007-09-12 01:41:15 UTC
Created attachment 12799 [details]
nolapic.interrupts
Comment 6 Nicolo' Chieffo 2007-09-12 01:41:38 UTC
Created attachment 12800 [details]
normal.acpidump
Comment 7 Nicolo' Chieffo 2007-09-12 01:41:58 UTC
Created attachment 12801 [details]
normal.interrupts
Comment 8 Nicolo' Chieffo 2007-09-12 01:43:01 UTC
1) the acpidump has no difference. the interrupt instead are different
2) it happens in console mode, even after 1 second after the boot
3) yes, it is an acpi event, as every other hotkey in my laptop: I see messages in /var/log/acpid when I press this hotkey. I didn't do the test of killing acpid

the hang happens even with the value 0.
Comment 9 Zhang Rui 2007-09-12 02:45:21 UTC
Hmm, the normal.interrupts seems to be incorrect.
Can you make a double check?
please attach the /var/log/acpid. :)

did you do these test with or without asus-laptop driver?
Comment 10 Nicolo' Chieffo 2007-09-12 03:39:51 UTC
should I attach /var/log/acpid with or without the "nolapic" option? should I presso the fn+f8 key before attaching it?

I'm using ubuntu 7.10, so I think that there is a module called asus_acpi
Comment 11 Nicolo' Chieffo 2007-09-12 13:07:42 UTC
Created attachment 12808 [details]
nolapic./var/log/acpid 

I pressed the hotkey lots of times before sending it
Comment 12 Nicolo' Chieffo 2007-09-12 13:09:25 UTC
What's wrong with normal.interrupts? what should I check?
The version of asus_acpi module is 0.30
Comment 13 Zhang Rui 2007-09-12 19:12:51 UTC
>What's wrong with normal.interrupts? 
it's the same as the nolapic one.

>I think that there is a module called asus_acpi
Does this still happen without asus_acpi/asus_laptop loaded?
Comment 14 Nicolo' Chieffo 2007-09-13 01:47:01 UTC
I will attach both normal and nolapic interrupts, taken from the recovery console (boot with "single" parameter)

yes, as I've already told you, it happens even before / is mounted!
Comment 15 Nicolo' Chieffo 2007-09-13 01:48:21 UTC
Created attachment 12812 [details]
nolapic.interrupts
Comment 16 Nicolo' Chieffo 2007-09-13 01:49:12 UTC
Created attachment 12813 [details]
normal.interrupts
Comment 17 Zhang Rui 2007-10-09 02:08:19 UTC
Hi,
Sorry for the delay.
The acpid log in comment #11 shows that asus_laptop is loaded.
Can you resend the acpid log without any asus drivers please?
Comment 18 Nicolo' Chieffo 2007-10-09 05:34:17 UTC
Maybe I didn't understand... the crash is independent from the asus module. It happens anyway.
do you still need the acpid without the asus module? if so:
should I boot with or without nolapic? should I press the hotkey before attaching the log file?
Comment 19 Nicolo' Chieffo 2007-10-09 05:40:59 UTC
this is how it looks without the asus module, after some minutes of work, and with the nolapic boot parameter. When I hit the hotkey nothing happens.

[Tue Oct  9 14:34:54 2007] exiting
[Tue Oct  9 14:35:54 2007] starting up
[Tue Oct  9 14:35:54 2007] 72 rules loaded
[Tue Oct  9 14:35:56 2007] client connected from 4639[107:114]
[Tue Oct  9 14:35:56 2007] 1 client rule loaded
[Tue Oct  9 14:35:59 2007] client connected from 4946[0:0]
[Tue Oct  9 14:35:59 2007] 1 client rule loaded
[Tue Oct  9 14:38:30 2007] received event "ac_adapter AC 00000080 00000001"
[Tue Oct  9 14:38:30 2007] notifying client 4639[107:114]
[Tue Oct  9 14:38:30 2007] notifying client 4946[0:0]
[Tue Oct  9 14:38:30 2007] executing action "/etc/acpi/power.sh"
[Tue Oct  9 14:38:30 2007] BEGIN HANDLER MESSAGES
[Tue Oct  9 14:38:30 2007] END HANDLER MESSAGES
[Tue Oct  9 14:38:30 2007] action exited with status 0
[Tue Oct  9 14:38:30 2007] completed event "ac_adapter AC 00000080 00000001"
[Tue Oct  9 14:38:30 2007] received event "battery BAT0 00000080 00000001"
[Tue Oct  9 14:38:30 2007] notifying client 4639[107:114]
[Tue Oct  9 14:38:30 2007] notifying client 4946[0:0]
[Tue Oct  9 14:38:30 2007] executing action "/etc/acpi/power.sh"
[Tue Oct  9 14:38:30 2007] BEGIN HANDLER MESSAGES
[Tue Oct  9 14:38:30 2007] END HANDLER MESSAGES
[Tue Oct  9 14:38:30 2007] action exited with status 0
[Tue Oct  9 14:38:30 2007] completed event "battery BAT0 00000080 00000001"
[Tue Oct  9 14:38:30 2007] received event "battery BAT1 00000080 00000000"
[Tue Oct  9 14:38:30 2007] notifying client 4639[107:114]
[Tue Oct  9 14:38:30 2007] notifying client 4946[0:0]
[Tue Oct  9 14:38:30 2007] executing action "/etc/acpi/power.sh"
[Tue Oct  9 14:38:30 2007] BEGIN HANDLER MESSAGES
[Tue Oct  9 14:38:30 2007] END HANDLER MESSAGES
[Tue Oct  9 14:38:30 2007] action exited with status 0
[Tue Oct  9 14:38:30 2007] completed event "battery BAT1 00000080 00000000"
Comment 20 Len Brown 2008-01-01 12:02:51 UTC
> When I hit the hotkey nothing happens.

So without the asus driver loaded, there is no hang?

> "nolapic". In this case there is no hang

and with the asus driver and "nolapic" there is no hang.
But does the video actually switch?

Is the acpi video driver loaded for these tests?

please attach the output from dmesg -s64000 for the failing kernel

as "nolapic" has no effect on interrupts (PIC-mode in both cases),
it is probably an interaction between SMM and use of the lapic
timer that is causing the hang.  Do you also see the hang
when you boot with "acpi=off" and press Fn-F8?  If yes,
one has to wonder why the LAPIC timer is enabled on this box.
Comment 21 Nicolo' Chieffo 2008-01-01 12:54:06 UTC
I can't answer to all your questions shortly, because I don't have the notebook with me now, sorry.

without the asus driver loaded the hang is present.
I have never tested if the video actually switches... Do you think that switching is a bios feature?
I'm quite sure that my tests were done with the video module loaded.

I remember that I read somewhere that my laptop does not have LAPIC support. And if I'm not wrong, there is a boot error message about lapic.
Comment 22 Nicolo' Chieffo 2008-01-07 06:54:39 UTC
Ok I'm here now.
I have a module named "video" loaded
with acpi=off the issue is still present!
Comment 23 Nicolo' Chieffo 2008-01-07 06:55:19 UTC
Created attachment 14327 [details]
dmesg -s64000
Comment 24 Zhang Rui 2008-03-23 23:58:35 UTC
well,
do you have a chance to reproduce the problem with the lastest git tree?
Comment 25 Zhang Rui 2008-04-29 01:10:24 UTC
Close this bug due to no response from the bug reporter.
Please re-open it if you have some questions.
Comment 26 Nicolo' Chieffo 2008-04-29 07:56:04 UTC
Sorry if I didn't answer... I tested it against 2.6.25-1 (fedora9 kernel). It still has this problem
Comment 27 Zhang Rui 2008-05-05 01:23:39 UTC
this laptop is quite similar to the one in bug #10510.
Is there any chance to get the system log between you pressing fn+f8 and the hang?
can this be fixed by a bios upgrade?

Matthias,
sorry to bother you but can you reproduce this problem on your laptop?
Comment 28 Matthias Bläsing 2008-05-05 02:24:58 UTC
I own the m6700ne (should only differ from 6800ne by the screen). I had the same problem - I don't know since when it does not occur anymore, but I just did a test with bios version 209Ae (I won't downgrade for a test!), kernel 2.6.25.1 (with radeon framebuffer console), radeon xorg drivers (git version) and can not reproduce it anymore.

The hanging behavour could be observerd running an older kernel and an older bios. Not sure though which component is responsible.
Comment 29 Zhang Rui 2008-05-11 19:45:14 UTC
Matthias,
thanks for testing. :)

nicol� chieffo,
please confirm that the problem disappears when using a later BIOS and kernel.
I will close this bug report if there is not response from you. :(
Comment 30 Zhang Rui 2008-05-12 00:45:24 UTC
well, close this bug and mark it as UNREPRODUCIBLE.
nicol� chieffo, please re-open it if you still have some problems. :)
Comment 31 Nicolo' Chieffo 2008-05-12 02:28:52 UTC
The problem is that there is no newer bios (the latest was made in 2005)... And as I've already told you I have tested linux 2.6.25 (fedora 9)
Comment 32 Nicolo' Chieffo 2008-05-12 02:30:12 UTC
Where did Matthias find the version 209?
Comment 33 Matthias Bläsing 2008-05-12 03:04:40 UTC
Ok - from the Asus Homepage you find the 2.07 and 2.08 versions. I think I got the 2.09 version also from the asus ftp servers, but the downloads now point to a http location, that does not offer directory listings.

I think the 2.09 version was never offically released, but got out somehow.

I placed the file here:

http://www.doppel-helix.eu/0209Ae.M6N.zip

(It won't be long there so grab it while its there)
Comment 34 Zhang Rui 2008-05-14 01:36:08 UTC
nicol� chieffo
can you confirm that BIOS 2.09 works for you?
Comment 35 Nicolo' Chieffo 2008-05-14 02:42:37 UTC
Well, I don't really know if the bios is also for my laptop, since the model names are different. What will happen if it does not work?
Comment 36 Matthias Bläsing 2008-05-14 05:01:53 UTC
The Bios is for the whole M6Ne series. As I said: The 6800 and 6700 series should only differ in their screens (the 6700 using a widescreen monitor). Another thing to note: the flash utility won't flash blindly. I accidently put the M6N bios file onto the flash disk and the utility told me it could not update, as the supplied bios would not match the current model.
Comment 37 Zhang Rui 2008-06-02 17:56:52 UTC
Close this bug as it's fixed by a BIOS upgrade.

Note You need to log in before you can comment on or make changes to this bug.