Bug 8951 - Suspend to RAM - Bug
Suspend to RAM - Bug
Status: CLOSED DUPLICATE of bug 6655
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2007-08-28 05:17 UTC by Matthias Wiora
Modified: 2009-04-02 04:47 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.22.4-65
Tree: Fedora
Regression: No


Attachments

Description Matthias Wiora 2007-08-28 05:17:59 UTC
Most recent kernel where this bug did not occur:
Distribution:
Hardware Environment: ASUS Z53T
Software Environment: Fedora Core 7 - Linux version 2.6.22.4-65.fc7 (kojibuilder@xenbuilder2.fedora.redhat.com) (gcc version 4.1.2 20070502 (Red Hat 4.1.2-12)) #1 SMP Tue Aug 21 22:36:56 EDT 2007

Problem Description: if I'm using the function "Suspend to RAM" in any Energy-Program (for example "KPowersave") the Computer goes Suspending to RAM, is waking up (when I hit a button) and everything is okay than. But the Laptop isn't able to log off the user after a "Suspend to RAM". Also the Logoff-Screen looks different. It's only possible to choose "Logout User", not like otherwise, Shutdown, Restart and so on.
The same problem consists with other kernel-versions.


Steps to reproduce: Choose in KLaptop or KPowersave "Suspend to RAM", wake up the PC and try to logout
Comment 1 Rafael J. Wysocki 2007-08-29 09:51:37 UTC
Hm, I'm not sure if that is a kernel problem.

What exactly do you mean by "the Laptop isn't able to log off the user"?
Comment 2 Matthias Wiora 2007-08-30 18:51:01 UTC
The Laptop is hanging on by logging of the user. Isn't restarting the x-server, as usually and doesn't react for any input (Strg + Alt + Backspace or something like this)

pmb µatthias
Comment 3 Rafael J. Wysocki 2007-08-31 07:17:45 UTC
Then, probably, the X gets confused by the suspend.  What video driver do you use?
Comment 4 Matthias Wiora 2007-08-31 10:43:00 UTC
Nvidia.Graphics 100.14.11-1.2.6.22.1_4
pmb µatthias
Comment 5 Rafael J. Wysocki 2007-08-31 15:03:20 UTC
Can you please try without it?
Comment 6 Matthias Wiora 2007-08-31 15:59:00 UTC
yes. i will and report
greetz matthias
Comment 7 Matthias Wiora 2007-09-27 15:20:47 UTC
/Edit
Kernel version 2.6.22.7-85 solved the Problem. Except of the Wireless card, everything works fine after suspend to ram =)
gruß µatthias
Comment 8 Matthias Wiora 2007-10-01 14:41:21 UTC
//EDIT2:
Problem not finished yet. A Process is hanging up while waking up from Sleep-Mode.
Everything works fine, except the Wireless-Adapter after an "Suspend-to-Ram" but the Restart doesn't work. It is closing all opened Services regularly. But at the End it shows "Rebooting System" and nothing happens --> Coldstart
Kernelversion: 2.6.22-9-91
Hardware: ASUS Z5305T

How to reproduce: Take your PC/Notebook in "Suspend-to-Ram"-Mode. Wake it up and restart the PC/Notebook.

Greet µatthew
Comment 9 Rafael J. Wysocki 2007-10-01 15:11:26 UTC
I think it's the same issue as in Bug #6655.

If this is the only (except for the wireless adapter) problem that you have with suspend, I'll mark this bug as a duplicate of Bug #6655.

Please confirm or deny.
Comment 10 Matthias Wiora 2007-10-01 23:30:50 UTC
Yes, it can be the same problem now. for first it was another.
greetz µatthias
Comment 11 Rafael J. Wysocki 2007-10-02 04:38:57 UTC

*** This bug has been marked as a duplicate of bug 6655 ***

Note You need to log in before you can comment on or make changes to this bug.