Bug 8932 - usb/serial/pl2303: support for BenQ Siemens Mobile Phone EF81
usb/serial/pl2303: support for BenQ Siemens Mobile Phone EF81
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2007-08-23 16:01 UTC by Andreas Loibl
Modified: 2008-02-10 22:39 UTC (History)
0 users

See Also:
Kernel Version: 2.6.22
Tree: Mainline
Regression: ---


Attachments
patch for pl2303 to support BenQ Siemens Mobile Phone EF81 (1.19 KB, patch)
2007-08-23 16:04 UTC, Andreas Loibl
Details | Diff

Description Andreas Loibl 2007-08-23 16:01:46 UTC
Distribution: Debian stable
Hardware Environment: BenQ Siemens Mobile Phone EF81 connected via USB-cord
Problem Description: 
pl2303 already supports some Siemens Mobile Phones (SX1, X65, X75, ...), but support for EF81 is missing, because its product ID is different from the others.

Bus 001 Device 002: ID 11f5:0005 Siemens AG (?)
  idVendor           0x11f5 Siemens AG (?)
  idProduct          0x0005
  iManufacturer           1 BenQ Siemens
  iProduct                2 BenQ Siemens Mobile Phone
Comment 1 Andreas Loibl 2007-08-23 16:04:42 UTC
Created attachment 12517 [details]
patch for pl2303 to support BenQ Siemens Mobile Phone EF81

using this patch you can access the phone, e.g. with scmxx:

# scmxx --device /dev/ttyUSB0 --info
Using "ANSI_X3.4-1968" as system character set.
Accessing device /dev/ttyUSB0...done
OK, a modem device is present.
Phone related information:
Vendor:       SIEMENS
Model:        EF81
(...)
Comment 2 Greg Kroah-Hartman 2007-08-23 16:11:43 UTC
On Thu, Aug 23, 2007 at 04:04:42PM -0700, bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=8932
> 
> 
> 
> 
> 
> ------- Comment #1 from andreas@andreas-loibl.de  2007-08-23 16:04 -------
> Created an attachment (id=12517)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=12517&action=view)
> patch for pl2303 to support BenQ Siemens Mobile Phone EF81

Can you just send this patch to me, as per the
Documentation/SubmittingPatches file so that I can apply it to the tree
properly?

thanks,

greg k-h

Comment 3 Natalie Protasevich 2008-02-10 22:39:08 UTC
Has been committed, closing the bug.

Note You need to log in before you can comment on or make changes to this bug.