Bug 8919 - Broken hotkeys on ASUS A6Km notebook with 2.6.23-rc3.
Broken hotkeys on ASUS A6Km notebook with 2.6.23-rc3.
Status: CLOSED DUPLICATE of bug 8909
Product: ACPI
Classification: Unclassified
Component: EC
All Linux
: P1 normal
Assigned To: Alexey Starikovskiy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-22 01:41 UTC by Paweł Szczekutowicz
Modified: 2008-10-17 21:31 UTC (History)
0 users

See Also:
Kernel Version: 2.6.23-rc3
Tree: Mainline
Regression: ---


Attachments
Try to make all ASUS notebooks work at once (4.35 KB, patch)
2007-08-22 13:43 UTC, Alexey Starikovskiy
Details | Diff

Description Paweł Szczekutowicz 2007-08-22 01:41:13 UTC
Most recent kernel where this bug did not occur: 2.6.23-rc2
Distribution: Gentoo
Hardware Environment: ASUS A6Km-Q017
Problem Description:

  Hotkeys like: mute, voluem up, volume down, monitor brightness up, monitor brightness down, monitor switch on/off, wireless on/off, sleep button are broken work with new drivers/acpi/ec.c. There is no acpi event from any of those. Also i can't switch monitor off using Fn+F7. Power button, battery, fan, processor and thermal works fine.

Steps to reproduce: always
Comment 1 Anonymous Emailer 2007-08-22 02:11:37 UTC
Reply-To: akpm@linux-foundation.org

On Wed, 22 Aug 2007 01:33:48 -0700 (PDT) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=8919
> 
>            Summary: Broken hotkeys on ASUS A6Km notebook with 2.6.23-rc3.
>            Product: ACPI
>            Version: 2.5
>      KernelVersion: 2.6.23-rc3
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Platform-Drivers
>         AssignedTo: acpi_platform-drivers@kernel-bugs.osdl.org
>         ReportedBy: szczekut@wit.edu.pl
> 
> 
> Most recent kernel where this bug did not occur: 2.6.23-rc2
> Distribution: Gentoo
> Hardware Environment: ASUS A6Km-Q017
> Problem Description:
> 
>   Hotkeys like: mute, voluem up, volume down, monitor brightness up, monitor
> brightness down, monitor switch on/off, wireless on/off, sleep button are
> broken work with new drivers/acpi/ec.c. There is no acpi event from any of
> those. Also i can't switch monitor off using Fn+F7. Power button, battery, fan,
> processor and thermal works fine.
> 
> Steps to reproduce: always
> 
> 

Michal, please track this as a post-2.6.22 regression, thanks.

Comment 2 Alexey Starikovskiy 2007-08-22 10:02:39 UTC
Could you please try patch from 8909?
Comment 3 Paweł Szczekutowicz 2007-08-22 10:17:20 UTC
With this one:
http://bugzilla.kernel.org/attachment.cgi?id=12477

i get this:
patching file drivers/acpi/ec.c
Hunk #2 succeeded at 652 with fuzz 1 (offset -13 lines).
Hunk #3 FAILED at 678.
Hunk #4 succeeded at 695 (offset -17 lines).
Hunk #5 succeeded at 713 (offset -17 lines).
Hunk #6 succeeded at 804 (offset -17 lines).
Hunk #7 succeeded at 852 (offset -17 lines).
1 out of 7 hunks FAILED -- saving rejects to file drivers/acpi/ec.c.rej
Comment 4 Alexey Starikovskiy 2007-08-22 13:43:23 UTC
Created attachment 12494 [details]
Try to make all ASUS notebooks work at once

strange... Please try this patch against Linus' latest tree.
Comment 5 Paweł Szczekutowicz 2007-08-22 23:29:11 UTC
It works fine again. Thank you.
Comment 6 Alexey Starikovskiy 2007-08-22 23:33:23 UTC
Thanks for testing!

*** This bug has been marked as a duplicate of bug 8909 ***

Note You need to log in before you can comment on or make changes to this bug.