Bug 8909 - hangs on boot
hangs on boot
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: EC
All Linux
: P1 normal
Assigned To: Alexey Starikovskiy
:
: 8919 (view as bug list)
Depends on:
Blocks: 9056
  Show dependency treegraph
 
Reported: 2007-08-19 19:25 UTC by Alex Hunsaker
Modified: 2008-10-17 21:31 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.23-rc3
Tree: Mainline
Regression: ---


Attachments
acpidump (83.37 KB, application/octet-stream)
2007-08-19 19:26 UTC, Alex Hunsaker
Details
dmesg (15.26 KB, application/octet-stream)
2007-08-19 19:27 UTC, Alex Hunsaker
Details
.config (37.95 KB, application/octet-stream)
2007-08-19 19:28 UTC, Alex Hunsaker
Details
dmesg (18.99 KB, application/octet-stream)
2007-08-19 19:55 UTC, Alex Hunsaker
Details
Make boot_ec fully operational (3.39 KB, patch)
2007-08-20 09:20 UTC, Alexey Starikovskiy
Details | Diff
reworked patch to not break 8709 again (4.43 KB, patch)
2007-08-21 14:38 UTC, Alexey Starikovskiy
Details | Diff

Description Alex Hunsaker 2007-08-19 19:25:19 UTC
Hangs on boot with:
ACPI: EC: GPE = 0x4, I/O: command/status = 0x66, data = 0x62
ACPI: Interpreter enabled
ACPI: (supports S0 S3)
ACPI: Using PIC for interrupt routing
ACIP: EC: GPE = 0x4, I/O: command/status = 0x66, data = 0x62

2.6.23-rc2 is ok
2.6.23-rc3 bad
2.6.23-rc3-latest (7c010de7506954e973abfab5c5999c5a97f7a73e) bad

git-bisect narrowed it down to:

7c010de7506954e973abfab5c5999c5a97f7a73e
ACPI: EC: Switch from boot_ec as soon as we find its desc in DSDT.
Alexey Starikovskiy [Fri, 3 Aug 2007 21:57:53 +0000 (17:57 -0400)]
Some ASUS laptops fail to use boot time EC
and need to eventually switch to one described in DSDT.

http://bugzilla.kernel.org/show_bug.cgi?id=8709

Signed-off-by: Alexey Starikovskiy <astarikovskiy@suse.de>
Signed-off-by: Len Brown <len.brown@intel.com>

Reverting the above commit fixes the problem.
Comment 1 Alex Hunsaker 2007-08-19 19:26:19 UTC
Created attachment 12447 [details]
acpidump
Comment 2 Alex Hunsaker 2007-08-19 19:27:58 UTC
Created attachment 12448 [details]
dmesg
Comment 3 Alex Hunsaker 2007-08-19 19:28:19 UTC
Created attachment 12449 [details]
.config
Comment 4 Alex Hunsaker 2007-08-19 19:29:09 UTC
This is on an Averatec 3200 laptop...
Comment 5 Alex Hunsaker 2007-08-19 19:55:31 UTC
Created attachment 12450 [details]
dmesg
Comment 6 Alexey Starikovskiy 2007-08-20 09:20:38 UTC
Created attachment 12460 [details]
Make boot_ec fully operational

Please check if the following patch helps
Comment 7 Alex Hunsaker 2007-08-20 18:48:05 UTC
Sure does, it boots again

Thanks!
Comment 8 Alexey Starikovskiy 2007-08-20 19:13:33 UTC
Thanks for testing!
Comment 9 Alexey Starikovskiy 2007-08-21 14:38:18 UTC
Created attachment 12477 [details]
reworked patch to not break 8709 again

Please test hopefully final version
Comment 10 Alex Hunsaker 2007-08-21 18:05:17 UTC
Still boots :)
Comment 11 Alexey Starikovskiy 2007-08-22 23:33:23 UTC
*** Bug 8919 has been marked as a duplicate of this bug. ***
Comment 12 Len Brown 2007-08-25 21:19:20 UTC
please confirm that this issue is not present in linux-2.6.23-rc3-git9
or later -- as the original patch to bug 8709 has been reverted from that release.
Comment 13 Alex Hunsaker 2007-08-25 23:45:52 UTC
-git9 (50c46637aa894f904e2fb39086a3d7732f68bd50) still boots
Comment 14 Len Brown 2007-09-05 16:58:14 UTC
Alex Hunsaker,
Thanks for verifying that this regression is gone before 2.6.23-rc4.
This bug is closed, but perhaps you can test the latest patch
in bug #8709 to help us make sure it doesn't come back?

thanks,
-Len

Note You need to log in before you can comment on or make changes to this bug.