Bug 8908 - 3ware 9650SE -8LPML not recognized by 3w-9xxx driver
3ware 9650SE -8LPML not recognized by 3w-9xxx driver
Status: REJECTED DOCUMENTED
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 high
Assigned To: scsi_drivers-other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-19 11:58 UTC by sven dmitrienko
Modified: 2008-02-12 11:32 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.22.1
Tree: Mainline
Regression: ---


Attachments

Description sven dmitrienko 2007-08-19 11:58:53 UTC
Most recent kernel where this bug did not occur:
Distribution: Debian Lenny/Sid
Hardware Environment: Intel Pentium D 820, Intel Mainboard with 955X Controller on board
Software Environment: Linux/Debian
Problem Description: The 3w-9xxx kernel driver for 3ware 9xxx SATA RAID Controller series did not recognize the 3ware 9650SE-8LPML SATA RAID Controller. I tryed also with original driver from 3ware itself, but this also didn't work, because of changes in module interface. If you need tester for this controller, i can do it for you.

Steps to reproduce: Get the mentioned card, install it in your compouter, and attach some sata hd's to it. Compile kernel with 3w-9xxx SATA RAID driver(SCSI section) and install it. Include HD's into your fstab.conf. Reboot and watch boot messages. You will see, that HD's, that are attached to the 3ware Controller are not found. After boot, put lspci into your linux console. lspci shows, here is an unrecognized 3ware Controller card.
Comment 1 Anonymous Emailer 2007-08-19 23:17:41 UTC
Reply-To: akpm@linux-foundation.org

On Sun, 19 Aug 2007 11:51:38 -0700 (PDT) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=8908
> 
>            Summary: 3ware 9650SE -8LPML not recognized by 3w-9xxx driver
>            Product: IO/Storage
>            Version: 2.5
>      KernelVersion: 2.6.20.1
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: high
>           Priority: P1
>          Component: Serial ATA
>         AssignedTo: jgarzik@pobox.com
>         ReportedBy: svedox@t-online.de
> 
> 
> Most recent kernel where this bug did not occur:
> Distribution: Debian Lenny/Sid
> Hardware Environment: Intel Pentium D 820, Intel Mainboard with 955X Controller
> on board
> Software Environment: Linux/Debian
> Problem Description: The 3w-9xxx kernel driver for 3ware 9xxx SATA RAID
> Controller series did not recognize the 3ware 9650SE-8LPML SATA RAID
> Controller. I tryed also with original driver from 3ware itself, but this also
> didn't work, because of changes in module interface. If you need tester for
> this controller, i can do it for you.
> 
> Steps to reproduce: Get the mentioned card, install it in your compouter, and
> attach some sata hd's to it. Compile kernel with 3w-9xxx SATA RAID driver(SCSI
> section) and install it. Include HD's into your fstab.conf. Reboot and watch
> boot messages. You will see, that HD's, that are attached to the 3ware
> Controller are not found. After boot, put lspci into your linux console. lspci
> shows, here is an unrecognized 3ware Controller card.
> 

Comment 2 sven dmitrienko 2007-08-20 04:36:32 UTC
It was kernel 2.6.22.1, not 2.6.20.1.
Comment 3 fmue 2007-12-15 12:17:46 UTC
have you tried to configure raid disks using the 9650-SE's bios tool, or the 3ware webtool ? Likely the 9650-SE doesn't export unconfigured disks, so they don't show up as SCSI drives to teh kernel. (a 9650SE-8LPML, firmware FE9X 3.06.00.003  	driver 2.26.02.008 works on my 2.6.21.5)
Comment 4 Natalie Protasevich 2008-02-12 10:32:14 UTC
Sven, can you provide the dmesg and lspci -v please? Basically, we need to know PCI/Vendor ID for your controller.
Comment 5 Natalie Protasevich 2008-02-12 10:49:19 UTC
(Reassigning to the scsi_drivers-other@kernel-bugs.osdl.org, instead of CC-ing)
Comment 6 Adam Radford 2008-02-12 11:30:34 UTC
The 9650SE (vendor:0x13c1, device id: 0x1004) controller series has been 
supported by the in-kernel 3w-9xxx driver since 2.6.19 kernel.

The user did not properly configure 'single disk' support through the 3ware
BIOS, tw_cli or 3dm2 tool.

Please close this bug.

-Adam Radford
Comment 7 Natalie Protasevich 2008-02-12 11:32:53 UTC
Thanks much, closing the bug.

Note You need to log in before you can comment on or make changes to this bug.