Bug 88811 - Kernel 3.18-rc5 rtl8821ae doesn't connect to WiFi 5G
Summary: Kernel 3.18-rc5 rtl8821ae doesn't connect to WiFi 5G
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-23 21:33 UTC by Valerio
Modified: 2014-11-25 16:16 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.18-rc5
Tree: Mainline
Regression: Yes


Attachments
Fix to allow 5G connection (1.49 KB, patch)
2014-11-23 22:29 UTC, Larry Finger
Details | Diff
Additional patch that is needed (1.30 KB, patch)
2014-11-25 00:18 UTC, Larry Finger
Details | Diff
attachment-18301-0.html (1.33 KB, text/html)
2014-11-25 09:42 UTC, Valerio
Details

Description Valerio 2014-11-23 21:33:52 UTC
Dear Developers,

I have tested kernel 3.18-rc5 with the intent to try the improvements done 
since the driver left the staging section, but with much surprise I found it 
can't see my WiFi-5G connection anymore: it can only connect to the standard 
2,4G signal.
The same driver used to work quite well since kernel 3.14.0 up to 3.17.4.
Best regards

Valerio
Comment 1 Larry Finger 2014-11-23 22:29:00 UTC
Created attachment 158641 [details]
Fix to allow 5G connection

If possible, please try this patch. It allows my RTL8821AE to connect to a 5G router.
Comment 2 Valerio 2014-11-24 05:08:59 UTC
At the moment I have tried your git repo, and the 5G is back.
I didn’t change the firmware because their md5sums are the same.
Do you need to test your patch above too? Do you need that it is applied to hw.c in the kernel or to the one in your git?
Comment 3 Larry Finger 2014-11-24 06:14:37 UTC
Yes, please test. It should be applied to the kernel source for the kernel(s) that are failing. It works for me, but I want to confirm that it fixes your problem as well.

The git repo is OK.
Comment 4 Valerio 2014-11-24 13:52:41 UTC
Since there is rc6, the patch was applied to the latest kernel, but to no avail, sorry. Do you want me to try on rc5? Do you want to test your git repo again with rc6?
Comment 5 Larry Finger 2014-11-25 00:18:20 UTC
Created attachment 158751 [details]
Additional patch that is needed

This second patch is also needed. It had been applied to my system, but apparently I never sent it upstream.

With both of the patches applied to a clean 3.18-rc6 source, I can connect to a 5G access point using the RTL8821AE.

Originally, I asked you to assign this bug to me. Unless you change the assignment now, I am not able to change the status.
Comment 6 Valerio 2014-11-25 09:42:36 UTC
Created attachment 158771 [details]
attachment-18301-0.html

Sorry for not assigning the bug to you, bur I'm not familiar with the
system used on bugzilla. I'm going to fix it ASAP. I will try your patches
later today, because now I am far from home.

Valerio
https://bugzilla.kernel.org/show_bug.cgi?id=88811

--- Comment #5 from Larry Finger <Larry.Finger@lwfinger.net> ---
Created attachment 158751 [details]
  --> https://bugzilla.kernel.org/attachment.cgi?id=158751&action=edit
Additional patch that is needed

This second patch is also needed. It had been applied to my system, but
apparently I never sent it upstream.

With both of the patches applied to a clean 3.18-rc6 source, I can connect
to a
5G access point using the RTL8821AE.

Originally, I asked you to assign this bug to me. Unless you change the
assignment now, I am not able to change the status.

--
You are receiving this mail because:
You reported the bug.
Comment 7 Valerio 2014-11-25 11:21:06 UTC
After applying the second patch you provided here, 5G is back again! Nice work

I'm unable to assign the bug to you, so if you really need it, you should explain how to do it.
Best regards


Valerio
Comment 8 Larry Finger 2014-11-25 15:57:07 UTC
I do not need to have it assigned to me; however, I am unable to change the status as I do not have the necessary privileges. That means the bug will remain with status NEW, rather than being resolved.

To the assignee: The necessary patches to fix this bug are being sent upstream today.
Comment 9 Valerio 2014-11-25 16:02:35 UTC
The fact is that when this bug has been opened, the system did something automatically and thus it has been assigned to drivers-network-wireless.
Anyhow, if the only thing you want it's to change status, I can do it for you.
Comment 10 John W. Linville 2014-11-25 16:16:44 UTC
FWIW, I think anyone can assign a bug to themselves.  The "take" link next to the Assigned To line in the header is for that.

Note You need to log in before you can comment on or make changes to this bug.