Bug 8872 - CONFIG_SCSI_WAIT_SCAN doesn't show in menuconfig
Summary: CONFIG_SCSI_WAIT_SCAN doesn't show in menuconfig
Status: RESOLVED DUPLICATE of bug 8763
Alias: None
Product: Other
Classification: Unclassified
Component: Configuration (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Roman Zippel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-09 19:25 UTC by virdiq
Modified: 2009-06-17 10:21 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.23-rc2
Tree: Mainline
Regression: No


Attachments
.config which will replicate this issue (36.75 KB, application/octet-stream)
2007-08-09 19:31 UTC, virdiq
Details

Description virdiq 2007-08-09 19:25:24 UTC
Most recent kernel where this bug did not occur: N/A
Distribution: Mainline Gentoo AMD64 (Vanilla Kernel Sources)
Hardware Environment: AMD64/SMP
Software Environment: gcc-4.1.2 & glibc-2.5 (Official stable Gentoo builds)



Problem Description:

menuconfig entry for CONFIG_SCSI_WAIT_SCAN is written to .config but does not show up in the configuration tree. Removing/unsetting this option manually from .config will result in Menuconfig writing it back to .config. Setting it to be built into the kernel will also result in menuconfig wanting to set it to =m (instead of =y as manually defined).

This configuration option is probably meant to show up under:
Device Drivers ---> SCSI Device Support ---> Some SCSI devices...(blah blah) --- CONFIG_SCSI_WAIT_SCAN

The same issue occurred in 2.6.23-rc1.

Also see this mailing list post:
http://lkml.org/lkml/2007/3/27/151

It describes a similar issue with CONFIG_SCSI_WAIT_SCAN (with no solution).



Steps to reproduce:

1) make menuconfig
2) /
3) CONFIG_SCSI_WAIT_SCAN
Comment 1 virdiq 2007-08-09 19:31:48 UTC
Created attachment 12340 [details]
.config which will replicate this issue
Comment 2 Andrew Morton 2007-08-09 19:34:17 UTC
This is deliberate.  Was discussed on linux-scsi a week or two ago.
Comment 3 virdiq 2007-08-09 19:48:51 UTC
Sorry, I missed it in my original search.

For reference, here is the thread I assume you are referring to:
http://groups.google.com/group/linux.kernel/browse_thread/thread/113b1353ec732a1/

Or at least it seems to discuss the issue in more depth.
Comment 4 Stefan Richter 2009-06-17 10:21:58 UTC

*** This bug has been marked as a duplicate of bug 8763 ***

Note You need to log in before you can comment on or make changes to this bug.