Bug 88181 - btrfs root fs corrupted and neither fsck nor zero log helps
Summary: btrfs root fs corrupted and neither fsck nor zero log helps
Status: RESOLVED DUPLICATE of bug 72151
Alias: None
Product: File System
Classification: Unclassified
Component: btrfs (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Josef Bacik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-13 22:33 UTC by dpisklov
Modified: 2014-11-15 15:14 UTC (History)
0 users

See Also:
Kernel Version: 3.16.3
Tree: Mainline
Regression: No


Attachments

Description dpisklov 2014-11-13 22:33:41 UTC
I had my laptop hanging and my wife simply pressed the power button to turn it off, now I can't boot as it fails with kernel panic.
My fs is btrfs on ssd with discard mount option.
The error I'm getting on kernel panic is:
BTRFS: failed to read log tree
BTRFS: open_ctree failed

As wiki page https://btrfs.wiki.kernel.org/index.php/Btrfs-zero-logsuggests, I tried to run btrfs-zero-log but it failed with:

Check tree block failed, want=49500766208, have=0
Check tree block failed, want=49500766208, have=0
Check tree block failed, want=49500766208, have=0
Check tree block failed, want=49500766208, have=0
Check tree block failed, want=49500766208, have=0
read block failed check_tree_block
Couldn't setup log root tree

Same wiki page suggests that I might need to patch btrfs if its prior to 3.15 but mine is 3.17, so I'm kinda stuck here... 

Also btrfs-image is not working either, with same messages, plus:
Open ctree failed
create failed (Success)

However I can see files via grub cli, so I guess it's not completely ruined...
Comment 1 dpisklov 2014-11-15 15:14:38 UTC

*** This bug has been marked as a duplicate of bug 72151 ***

Note You need to log in before you can comment on or make changes to this bug.