Bug 8792 - kernel incorrectly initialises mass storage component of HUAWEI E220
kernel incorrectly initialises mass storage component of HUAWEI E220
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: SCSI
All Linux
: P1 normal
Assigned To: io_scsi
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-22 17:21 UTC by Thoralf Dassler
Modified: 2009-03-23 10:04 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.22
Tree: Mainline
Regression: ---


Attachments

Description Thoralf Dassler 2007-07-22 17:21:42 UTC
Most recent kernel where this bug did not occur: vanilla 2.6.22
Distribution: Slackware 12.0
Hardware Environment: HUAWEI USB modem E220 on Intel 82801G (ICH7) USB2 EHCI; Intel 82801G (ICH7) PCI Express
Software Environment: SCSI
Problem Description: The HUAWEI USB modem includes a mass storage device to access the modem's built-in ROM. The kernel's SCSI environment (see relevant dmesg below) incorrectly initializes that mass storage device as a CDROM on /dev/sr1, which causes three known symptoms:

1) "/etc/rc.d/rc.hald start" removes /dev/sr1 until udev puts it back. This means that the modem gets initialized twice every time I boot Linux. Workarounds: (i) do not start hald, or (ii) attach the modem after hald has initialized.

2) k3b device scan also removes /dev/sr1 and if I am unlucky and have pppd already running, pppd gets terminated as well. Workaround: "chmod 000 /dev/sr1" or "chgrp root /dev/sr1" (Slackware udev initializes /dev/sr1 as group cdrom).

3) Warnings from module "option":
dmesg | grep -i option
option: Unknown symbol usb_serial_port_softint
option: Unknown symbol usb_serial_disconnect
option: Unknown symbol usb_serial_probe
option: Unknown symbol usb_serial_register
option: Unknown symbol usb_serial_deregister
option 3-1:1.0: GSM modem (1-port) converter detected
option 3-1:1.1: GSM modem (1-port) converter detected
usbcore: registered new interface driver option
drivers/usb/serial/option.c: USB Driver for GSM modems: v0.7.1

Other relevant information:
dmesg | grep -i scsi
SCSI subsystem initialized
scsi0 : ata_piix
scsi1 : ata_piix
scsi 0:0:0:0: Direct-Access     ATA      TOSHIBA MK1637GS DL03 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] Attached SCSI disk
scsi 1:0:0:0: CD-ROM            HL-DT-ST DVDRAM GSA-T20N  WT03 PQ: 0 ANSI: 5
sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
sr 1:0:0:0: Attached scsi CD-ROM sr0
scsi2 : SCSI emulation for USB Mass Storage devices
scsi 2:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
sr1: scsi3-mmc drive: 0x/0x caddy
sr 2:0:0:0: Attached scsi CD-ROM sr1

LUN scan shows HUAWEI as type "cdrom" again:
/etc/rc.d/rc.scanluns
Scanning all LUNs for additional hardware:  /sbin/rescan-scsi-bus -l
Host adapter 0 (ata_piix) found.
Host adapter 1 (ata_piix) found.
Host adapter 2 (usb-storage) found.
Scanning hosts  0 1 2 channels 0 for
 SCSI target IDs  0 1 2 3 4 5 6 7 , LUNs  0 1 2 3 4 5 6 7
Scanning for device 0 0 0 0 ...
OLD: Host: scsi0 Channel: 00 Id: 00 Lun: 00
      Vendor: ATA      Model: TOSHIBA MK1637GS Rev: DL03
      Type:   Direct-Access                    ANSI SCSI revision: 05
Scanning for device 1 0 0 0 ...
OLD: Host: scsi1 Channel: 00 Id: 00 Lun: 00
      Vendor: HL-DT-ST Model: DVDRAM GSA-T20N  Rev: WT03
      Type:   CD-ROM                           ANSI SCSI revision: 05
Scanning for device 2 0 0 0 ...
OLD: Host: scsi2 Channel: 00 Id: 00 Lun: 00
      Vendor: HUAWEI   Model: Mass Storage     Rev: 2.31
      Type:   CD-ROM                           ANSI SCSI revision: 02
0 new device(s) found.
0 device(s) removed.

Modules:
usb_storage            31812  0
usbserial              25320  4 option
soundcore               5792  1 snd
uhci_hcd               19404  0
ehci_hcd               26444  0

Steps to reproduce: reboot with modem connected
Comment 1 Thoralf Dassler 2007-07-22 17:25:16 UTC
Please ignore first line in the report:
Most recent kernel where this bug did not occur: vanilla 2.6.22
Comment 2 Anonymous Emailer 2007-07-22 23:24:02 UTC
Reply-To: akpm@linux-foundation.org

On Sun, 22 Jul 2007 17:16:13 -0700 (PDT) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=8792
> 
>            Summary: kernel incorrectly initialises mass storage component of
>                     HUAWEI E220
>            Product: IO/Storage
>            Version: 2.5
>      KernelVersion: 2.6.22
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: SCSI
>         AssignedTo: io_scsi@kernel-bugs.osdl.org
>         ReportedBy: thoralf.dassler@gmail.com
>                 CC: greg@kroah.com
> 
> 
> Most recent kernel where this bug did not occur: vanilla 2.6.22

I think this was supposed to be "not known"..  It is unclear.

> Distribution: Slackware 12.0
> Hardware Environment: HUAWEI USB modem E220 on Intel 82801G (ICH7) USB2 EHCI;
> Intel 82801G (ICH7) PCI Express
> Software Environment: SCSI
> Problem Description: The HUAWEI USB modem includes a mass storage device to
> access the modem's built-in ROM. The kernel's SCSI environment (see relevant
> dmesg below) incorrectly initializes that mass storage device as a CDROM on
> /dev/sr1, which causes three known symptoms:
> 
> 1) "/etc/rc.d/rc.hald start" removes /dev/sr1 until udev puts it back. This
> means that the modem gets initialized twice every time I boot Linux.
> Workarounds: (i) do not start hald, or (ii) attach the modem after hald has
> initialized.
> 
> 2) k3b device scan also removes /dev/sr1 and if I am unlucky and have pppd
> already running, pppd gets terminated as well. Workaround: "chmod 000 /dev/sr1"
> or "chgrp root /dev/sr1" (Slackware udev initializes /dev/sr1 as group cdrom).
> 
> 3) Warnings from module "option":
> dmesg | grep -i option
> option: Unknown symbol usb_serial_port_softint
> option: Unknown symbol usb_serial_disconnect
> option: Unknown symbol usb_serial_probe
> option: Unknown symbol usb_serial_register
> option: Unknown symbol usb_serial_deregister
> option 3-1:1.0: GSM modem (1-port) converter detected
> option 3-1:1.1: GSM modem (1-port) converter detected
> usbcore: registered new interface driver option
> drivers/usb/serial/option.c: USB Driver for GSM modems: v0.7.1
> 
> Other relevant information:
> dmesg | grep -i scsi
> SCSI subsystem initialized
> scsi0 : ata_piix
> scsi1 : ata_piix
> scsi 0:0:0:0: Direct-Access     ATA      TOSHIBA MK1637GS DL03 PQ: 0 ANSI: 5
> sd 0:0:0:0: [sda] Attached SCSI disk
> scsi 1:0:0:0: CD-ROM            HL-DT-ST DVDRAM GSA-T20N  WT03 PQ: 0 ANSI: 5
> sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
> sr 1:0:0:0: Attached scsi CD-ROM sr0
> scsi2 : SCSI emulation for USB Mass Storage devices
> scsi 2:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
> sr1: scsi3-mmc drive: 0x/0x caddy
> sr 2:0:0:0: Attached scsi CD-ROM sr1
> 
> LUN scan shows HUAWEI as type "cdrom" again:
> /etc/rc.d/rc.scanluns
> Scanning all LUNs for additional hardware:  /sbin/rescan-scsi-bus -l
> Host adapter 0 (ata_piix) found.
> Host adapter 1 (ata_piix) found.
> Host adapter 2 (usb-storage) found.
> Scanning hosts  0 1 2 channels 0 for
>  SCSI target IDs  0 1 2 3 4 5 6 7 , LUNs  0 1 2 3 4 5 6 7
> Scanning for device 0 0 0 0 ...
> OLD: Host: scsi0 Channel: 00 Id: 00 Lun: 00
>       Vendor: ATA      Model: TOSHIBA MK1637GS Rev: DL03
>       Type:   Direct-Access                    ANSI SCSI revision: 05
> Scanning for device 1 0 0 0 ...
> OLD: Host: scsi1 Channel: 00 Id: 00 Lun: 00
>       Vendor: HL-DT-ST Model: DVDRAM GSA-T20N  Rev: WT03
>       Type:   CD-ROM                           ANSI SCSI revision: 05
> Scanning for device 2 0 0 0 ...
> OLD: Host: scsi2 Channel: 00 Id: 00 Lun: 00
>       Vendor: HUAWEI   Model: Mass Storage     Rev: 2.31
>       Type:   CD-ROM                           ANSI SCSI revision: 02
> 0 new device(s) found.
> 0 device(s) removed.
> 
> Modules:
> usb_storage            31812  0
> usbserial              25320  4 option
> soundcore               5792  1 snd
> uhci_hcd               19404  0
> ehci_hcd               26444  0
> 
> Steps to reproduce: reboot with modem connected
> 
> 
> -- 
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug, or are watching someone who is.

Comment 3 Thoralf Dassler 2007-07-23 00:47:00 UTC
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
<pre wrap="">&gt; &gt; Most recent kernel where this bug did not occur: vanilla 2.6.22
</pre>
<pre wrap=""><!---->&gt; I think this was supposed to be "not known"..  It is unclear.
</pre>
Of cause, it is "not known". Sorry folks.<br>
<br>
Andrew Morton wrote:
<blockquote cite="mid:20070722231810.7a21705c.akpm@linux-foundation.org"
 type="cite">
  <pre wrap="">On Sun, 22 Jul 2007 17:16:13 -0700 (PDT) <a class="moz-txt-link-abbreviated" href="mailto:bugme-daemon@bugzilla.kernel.org">bugme-daemon@bugzilla.kernel.org</a> wrote:

  </pre>
  <blockquote type="cite">
    <pre wrap=""><a class="moz-txt-link-freetext" href="http://bugzilla.kernel.org/show_bug.cgi?id=8792">http://bugzilla.kernel.org/show_bug.cgi?id=8792</a>

           Summary: kernel incorrectly initialises mass storage component of
                    HUAWEI E220
           Product: IO/Storage
           Version: 2.5
     KernelVersion: 2.6.22
          Platform: All
        OS/Version: Linux
              Tree: Mainline
            Status: NEW
          Severity: normal
          Priority: P1
         Component: SCSI
        AssignedTo: <a class="moz-txt-link-abbreviated" href="mailto:io_scsi@kernel-bugs.osdl.org">io_scsi@kernel-bugs.osdl.org</a>
        ReportedBy: <a class="moz-txt-link-abbreviated" href="mailto:thoralf.dassler@gmail.com">thoralf.dassler@gmail.com</a>
                CC: <a class="moz-txt-link-abbreviated" href="mailto:greg@kroah.com">greg@kroah.com</a>


Most recent kernel where this bug did not occur: vanilla 2.6.22
    </pre>
  </blockquote>
  <pre wrap=""><!---->
I think this was supposed to be "not known"..  It is unclear.

  </pre>
  <blockquote type="cite">
    <pre wrap="">Distribution: Slackware 12.0
Hardware Environment: HUAWEI USB modem E220 on Intel 82801G (ICH7) USB2 EHCI;
Intel 82801G (ICH7) PCI Express
Software Environment: SCSI
Problem Description: The HUAWEI USB modem includes a mass storage device to
access the modem's built-in ROM. The kernel's SCSI environment (see relevant
dmesg below) incorrectly initializes that mass storage device as a CDROM on
/dev/sr1, which causes three known symptoms:

1) "/etc/rc.d/rc.hald start" removes /dev/sr1 until udev puts it back. This
means that the modem gets initialized twice every time I boot Linux.
Workarounds: (i) do not start hald, or (ii) attach the modem after hald has
initialized.

2) k3b device scan also removes /dev/sr1 and if I am unlucky and have pppd
already running, pppd gets terminated as well. Workaround: "chmod 000 /dev/sr1"
or "chgrp root /dev/sr1" (Slackware udev initializes /dev/sr1 as group cdrom).

3) Warnings from module "option":
dmesg | grep -i option
option: Unknown symbol usb_serial_port_softint
option: Unknown symbol usb_serial_disconnect
option: Unknown symbol usb_serial_probe
option: Unknown symbol usb_serial_register
option: Unknown symbol usb_serial_deregister
option 3-1:1.0: GSM modem (1-port) converter detected
option 3-1:1.1: GSM modem (1-port) converter detected
usbcore: registered new interface driver option
drivers/usb/serial/option.c: USB Driver for GSM modems: v0.7.1

Other relevant information:
dmesg | grep -i scsi
SCSI subsystem initialized
scsi0 : ata_piix
scsi1 : ata_piix
scsi 0:0:0:0: Direct-Access     ATA      TOSHIBA MK1637GS DL03 PQ: 0 ANSI: 5
sd 0:0:0:0: [sda] Attached SCSI disk
scsi 1:0:0:0: CD-ROM            HL-DT-ST DVDRAM GSA-T20N  WT03 PQ: 0 ANSI: 5
sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
sr 1:0:0:0: Attached scsi CD-ROM sr0
scsi2 : SCSI emulation for USB Mass Storage devices
scsi 2:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
sr1: scsi3-mmc drive: 0x/0x caddy
sr 2:0:0:0: Attached scsi CD-ROM sr1

LUN scan shows HUAWEI as type "cdrom" again:
/etc/rc.d/rc.scanluns
Scanning all LUNs for additional hardware:  /sbin/rescan-scsi-bus -l
Host adapter 0 (ata_piix) found.
Host adapter 1 (ata_piix) found.
Host adapter 2 (usb-storage) found.
Scanning hosts  0 1 2 channels 0 for
 SCSI target IDs  0 1 2 3 4 5 6 7 , LUNs  0 1 2 3 4 5 6 7
Scanning for device 0 0 0 0 ...
OLD: Host: scsi0 Channel: 00 Id: 00 Lun: 00
      Vendor: ATA      Model: TOSHIBA MK1637GS Rev: DL03
      Type:   Direct-Access                    ANSI SCSI revision: 05
Scanning for device 1 0 0 0 ...
OLD: Host: scsi1 Channel: 00 Id: 00 Lun: 00
      Vendor: HL-DT-ST Model: DVDRAM GSA-T20N  Rev: WT03
      Type:   CD-ROM                           ANSI SCSI revision: 05
Scanning for device 2 0 0 0 ...
OLD: Host: scsi2 Channel: 00 Id: 00 Lun: 00
      Vendor: HUAWEI   Model: Mass Storage     Rev: 2.31
      Type:   CD-ROM                           ANSI SCSI revision: 02
0 new device(s) found.
0 device(s) removed.

Modules:
usb_storage            31812  0
usbserial              25320  4 option
soundcore               5792  1 snd
uhci_hcd               19404  0
ehci_hcd               26444  0

Steps to reproduce: reboot with modem connected


-- 
Configure bugmail: <a class="moz-txt-link-freetext" href="http://bugzilla.kernel.org/userprefs.cgi?tab=email">http://bugzilla.kernel.org/userprefs.cgi?tab=email</a>
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.
    </pre>
  </blockquote>
  <pre wrap=""><!---->
  </pre>
</blockquote>
<br>
</body>
</html>


Note You need to log in before you can comment on or make changes to this bug.