Bug 8787 - S-ATA Connect/Disconnect - kernel hang
Summary: S-ATA Connect/Disconnect - kernel hang
Status: RESOLVED DUPLICATE of bug 8421
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Tejun Heo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-20 12:23 UTC by Sascha
Modified: 2007-08-09 06:45 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.21.6-slh-smp-1
Tree: Mainline
Regression: ---


Attachments

Description Sascha 2007-07-20 12:23:20 UTC
Most recent kernel where this bug did not occur: 2.6.20
Distribution: SIDUX
Hardware Environment: Asus/Gigabyte nForce4 Chipset
Software Environment: Debian SID
Problem Description:
connecting or disconnecting an s-ata harddrive freez the whole kernel, first all IRQ´s are blocked (no keyboard or mouse possible). the system/kde clock dots blinks for almost 10 sec and then also freez.
the only way out is a hard reset!

Steps to reproduce:
just connect or disconnect an unmounted s-ats harddrive to any s-ata channel. the problem should instandly appear.
PLEASE do a "sync" befor this action to sync the mounted filesystems because after this any unstored data will be lost.
the filesystem has to be checked after reboot due to an unclean reset.
Comment 1 Tejun Heo 2007-07-20 21:42:08 UTC
cc'ing Robert.
Comment 2 Robert Hancock 2007-07-20 22:36:07 UTC
2.6.22 has a change in sata_nv which may help with this, can you try it out?
Comment 3 Sascha 2007-07-21 07:49:40 UTC
I tried 2.6.22 in 32 and 64 bit mode (amd64 so.939, w/nforce4 chipset).

in 64 bit the s-ata connect and disconnect works without trouble.
in the most used 32 bit structure the kernel can now/again handle a plugged in s-ata harddrive but short after disconnecting the harddrive the kernel stocks again.

first the keyboard is unuseable and then the ps/2 mouse. some sec´s later the while system is dead, only the gfx card textmode cursor is still flashing.
no network (ssh) connection is possible and the only way out is still a hardreset.

is it right that in 2.6.22 even the p-ata (ide) drive is mapped to sdX?
hda is now sdb in my system. no problem since UUID but new to me.
and where is the ide dvd-recorder now? was /dev/hdc before and now I can not find it!
Comment 4 Robert Hancock 2007-07-21 09:50:28 UTC
Do you get any kernel messages output? Also, what kind of motherboard is this?

This seems similar to bug 8421.

As far as the libata PATA stuff, yes, the IDE drive will end up as /dev/sdX. CD/DVD drives will likely end up as either /dev/scdX or /dev/srX depending on distribution.
Comment 5 Tejun Heo 2007-08-08 21:11:07 UTC

*** This bug has been marked as a duplicate of bug 8421 ***
Comment 6 Sascha 2007-08-09 06:45:19 UTC
Yes this is the same Bug! I am using an Asus A8n-SLI, MSI K8n-Neo4-F, Gigabyte K8-NMF-9- All Boards have the problem with S-ATA hotplug/disconnecting.
The newest Bios version is present on all 3 boards.

Thanks for the P-ATA info, I found my DVD-Wirter again :)
I think we let this 8787 Bug die because there ia already another one and with much mor details.

Thanks again :)

Note You need to log in before you can comment on or make changes to this bug.