Bug 8782 - inotify could not detect process directory creation/deletion in procfs
inotify could not detect process directory creation/deletion in procfs
Status: REJECTED WILL_NOT_FIX
Product: File System
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Alexey Dobriyan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-19 09:03 UTC by Shijin Kong
Modified: 2009-03-08 05:02 UTC (History)
0 users

See Also:
Kernel Version: 2.6.18
Tree: Mainline
Regression: ---


Attachments

Description Shijin Kong 2007-07-19 09:03:29 UTC
Most recent kernel where this bug did not occur: none
Distribution: Fedora Core 6
Hardware Environment: i386 32bit PC
Software Environment: Default installation of FC6
Problem Description:

I could not detect some notification from inotify mechanism when adding watches to /proc file system, including IN_CREATE/IN_DELETE. I think the reason is that inotify is not built in /proc (loss of functions), although it's pretty useful. 

We start to develop some software based on that feature (if it could exist).

I found an old message to resolve this problem:
http://www.ussg.iu.edu/hypermail/linux/kernel/0602.2/1815.html

That patch was introduced soon after inotify was built into kernel 2.6.13. However the patch is not applied until now. I just suggest that inotify on /proc should be built in future kernel versions.

Thank.

-Shijin

Steps to reproduce:

Note You need to log in before you can comment on or make changes to this bug.