Bug 8779 - Method parse/execution failed [\_PR_.CPU2_PSS] AE_AML_PACKAGE_LIMIT - Asus f3jr
Summary: Method parse/execution failed [\_PR_.CPU2_PSS] AE_AML_PACKAGE_LIMIT - Asus f3jr
Status: CLOSED DUPLICATE of bug 8298
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Processor (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Venkatesh Pallipadi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-18 08:27 UTC by Claudio Melis
Modified: 2008-01-12 16:06 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.22
Tree: Mainline
Regression: ---


Attachments
acpidump output (163.38 KB, text/plain)
2007-07-26 01:06 UTC, Claudio Melis
Details
ASUS-F3JP Bios V208 DSDT and mesg & boot messages (214.66 KB, application/x-gzip)
2007-09-13 04:57 UTC, Martin
Details
dsdt f3jr new bios v204 (166.19 KB, application/octet-stream)
2007-12-01 08:15 UTC, Claudio Melis
Details

Description Claudio Melis 2007-07-18 08:27:07 UTC
Most recent kernel where this bug did not occur:

Distribution: sabayon

Hardware Environment: asus f3jr

Software Environment: dmesg error

Problem Description:


ACPI Error (psparse-0537):
 Method parse/execution failed [\_PR_.CPU1_PSS] (Node dfc17e78), AE_AML_PACKAGE_LIMIT
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU2_PSS] (Node f7f246d0), AE_AML_PACKAGE_LIMIT 

ACPI Warning (tbutils-0158): Incorrect checksum in table [SSDT] - 63, should be A6 [20070126]

N.B. there's a bios problem that MCFG area is not E820-reserved

Steps to reproduce: at boot time
Comment 1 Claudio Melis 2007-07-19 08:02:09 UTC
strange occurs. 
i have downgrade my asus BIOS to version 202 from 203. the psparse error disappear but the warning remains.
when i upgraded to 203 again the psparse error still disappeared.

I had found another error:

rtc_cmos: probe of 00:03 failed with error -16

I'm not able suspend my laptopo (S3 acpi state)
Comment 2 Len Brown 2007-07-25 19:07:17 UTC
please attach the output from acpidump
Comment 3 Len Brown 2007-07-25 19:08:08 UTC
BTW. it might be interesting to run acpidump with both versions of the BIOS.
Also, you may find some BIOS SETUP options have an effect both this error
and the output from acpidump.
Comment 4 Claudio Melis 2007-07-26 01:06:51 UTC
Created attachment 12151 [details]
acpidump output

this is my acpidump output. 
There's anothewr error:
APIC error on CPU1: 00(40)
Comment 5 Robert Moore 2007-09-10 14:51:59 UTC
There are no _PSS methods in the DSDT, probably in the SSDT. Unfortunately, this is dynamicaly loaded, it does not appear in the RSDT.
Comment 6 Martin 2007-09-13 04:51:34 UTC
Hi ... 
ACPI problems with ASUS F3Jp-AS017M ... some checksum and parse errors ... I have read something somewhere that there is NO _PSS and other methods :-( ... 

Is it possible to load it dynamical under Windows driver atk0100 to hit the linux users? 

attached my acpidump and error messages inside tar file ...

some error / warnings maybe fixed by manual loading DSDT via initrd

I'm using SuSE 10.2 with a modified 2.6.22.3-xx kernel from jengelh (THANKS)

Martin
Comment 7 Martin 2007-09-13 04:57:02 UTC
Created attachment 12817 [details]
ASUS-F3JP Bios V208 DSDT and mesg & boot messages
Comment 8 Fu Michael 2007-11-06 21:35:23 UTC

*** This bug has been marked as a duplicate of bug 8298 ***
Comment 9 Martin 2007-11-07 06:15:19 UTC
Hi 
now running SuSE 10.3 with kernel 2.6.22.9 getting all the same errors :-(

some errors maybe fixed with loading dsdt via initrd, but strange checksum and "... behind end of object" could not be fixed ... getting a little helpless :-(

Martin
Comment 10 Claudio Melis 2007-12-01 08:15:41 UTC
Created attachment 13810 [details]
dsdt f3jr new bios v204

acpidump of new f3jr bios v204 from asus
error still remains:

[   22.470513] ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU1._PSS] (Node ffff81007fc0ba60), AE_AML_PACKAGE_LIMIT
[   22.470828] ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU2._PSS] (Node ffff8100028ab140), AE_AML_PACKAGE_LIMIT

   17.163503] ACPI Warning (tbutils-0217): Incorrect checksum in table [SSDT] -  63, should be A6 [20070126]

uname -a

Linux mekka6tem 2.6.23-sabayon-r1 #1 SMP Tue Nov 20 13:03:07 UTC 2007 x86_64 Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz GenuineIntel GNU/Linux

Note You need to log in before you can comment on or make changes to this bug.