Bug 8762 - (patch queued) kernel trace dump, "IRQ handler type mismatch for IRQ x"
Summary: (patch queued) kernel trace dump, "IRQ handler type mismatch for IRQ x"
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: PCMCIA (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Alan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-15 12:38 UTC by paolo
Modified: 2008-10-16 06:23 UTC (History)
0 users

See Also:
Kernel Version: 2.6.22.1
Tree: Mainline
Regression: ---


Attachments

Description paolo 2007-07-15 12:38:18 UTC
Most recent kernel where this bug did not occur: 2.6.17.14 and 2.6.19.7
Distribution: Debian Sarge
Hardware Environment: pc
Software Environment: 
Problem Description: kernel trace dump/warnings

Steps to reproduce: load the pcmcia module(s)

hi,

I'm seeing the ktrace below when the pcmcia subsys gets activated and loads the orinoco_cs module. The wifi card seems to work fine though.

thx
--
paolo

Linux version 2.6.22.1-ss2.2.2.10.2-dm-ia-nb-p3.1 (root@gb) (gcc version 3.4.4 2
0050314 (prerelease) (Debian 3.4.3-13sarge1)) #1 PREEMPT Thu Jul 12 17:58:40 CES
T 2007
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 0000000017ff0000 (usable)
 BIOS-e820: 0000000017ff0000 - 0000000017ff8000 (ACPI data)
 BIOS-e820: 0000000017ff8000 - 0000000018000000 (ACPI NVS)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
Malformed early option 'acpi'
383MB LOWMEM available.
Entering add_active_range(0, 0, 98288) 0 entries of 256 used
Zone PFN ranges:
  DMA             0 ->     4096
  Normal       4096 ->    98288
early_node_map[1] active PFN ranges
    0:        0 ->    98288
On node 0 totalpages: 98288
  DMA zone: 32 pages used for memmap
  DMA zone: 0 pages reserved
  DMA zone: 4064 pages, LIFO batch:0
  Normal zone: 735 pages used for memmap
  Normal zone: 93457 pages, LIFO batch:31
DMI 2.3 present.
ACPI: RSDP 000FE030, 0014 (r0 Acer  )
ACPI: RSDT 17FF0000, 002C (r1 Acer   FALCON25        1 Acer        0)
ACPI: FACP 17FF0054, 0074 (r1 Acer   FALCON25        1 Acer        0)
ACPI: DSDT 17FF00CC, 43DE (r1   Acer FALCON25        1 MSFT  100000C)
ACPI: FACS 17FF8000, 0040
ACPI: BOOT 17FF002C, 0028 (r1 Acer   FALCON25        1 Acer        0)
ACPI: PM-Timer IO Port: 0xf108
Allocating PCI resources starting at 20000000 (gap: 18000000:e7ff0000)
Built 1 zonelists.  Total pages: 97521
Kernel command line: BOOT_IMAGE=linux ro root=301 idebus=66 acpi=noirq irqpoll a
cpi=on apm=off panic=60 panicblink=300 resume2=file:/dev/hda3:0x10050 resume=file:/dev/hda3:0x10050 1
ide_setup: idebus=66
Misrouted IRQ fixup and polling support enabled
This may significantly impact system performance
Local APIC disabled by BIOS -- you can enable it with "lapic"
mapped APIC to ffffd000 (01302000)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 8192 bytes)
Detected 596.897 MHz processor.
Console: colour VGA+ 80x34
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 385456k/393152k available (2385k kernel code, 7144k reserved, 787k data,
 220k init, 0k highmem)
virtual kernel memory layout:
    fixmap  : 0xfffb7000 - 0xfffff000   ( 288 kB)
    vmalloc : 0xd8800000 - 0xfffb5000   ( 631 MB)
    lowmem  : 0xc0000000 - 0xd7ff0000   ( 383 MB)
      .init : 0xc041c000 - 0xc0453000   ( 220 kB)
      .data : 0xc035473c - 0xc0419400   ( 787 kB)
      .text : 0xc0100000 - 0xc035473c   (2385 kB)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 1198.56 BogoMIPS (lpj=5992836)
Security Framework v1.0.0 initialized
Mount-cache hash table entries: 512
CPU: After generic identify, caps: 0383f9ff 00000000 00000000 00000000 00000000 
00000000 00000000
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
CPU: After all inits, caps: 0383f9ff 00000000 00000000 00000040 00000000 0000000
0 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
Compat vDSO mapped to ffffe000.
CPU: Intel Pentium III (Coppermine) stepping 03
Checking 'hlt' instruction... OK.
ACPI: Core revision 20070126
Parsing all Control Methods:
Table [DSDT](id 0001) - 474 Objects with 42 Devices 141 Methods 35 Regions
 tbxface-0587 [02] tb_load_namespace     : ACPI Tables successfully acquired
ACPI: setting ELCR to 0e00 (from 0c00)
evxfevnt-0091 [02] enable                : Transition to ACPI mode successful
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xf0200, last bus=1
PCI: Using configuration type 1
Setting up standard PCI resources
evgpeblk-0952 [04] ev_create_gpe_block   : GPE 00 to 3F [_GPE] 8 regs on int 0x9
evgpeblk-1048 [03] ev_initialize_gpe_bloc: Found 5 Wake, Enabled 4 Runtime GPEs 
in this block
Completing Region/Field/Buffer/Package initialization:..........................
..........................................................
Initialized 35/35 Regions 19/19 Fields 23/23 Buffers 7/14 Packages (483 nodes)
Initializing Device/Processor/Thermal objects by executing _INI methods:
Executed 0 _INI methods requiring 0 _STA executions (examined 46 objects)
ACPI: Interpreter enabled
ACPI: (supports S0 S1 S4 S5)
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
PCI: Firmware left 0000:00:0a.0 e100 interrupts enabled, disabling
PCI quirk: region f100-f13f claimed by ali7101 ACPI
PCI quirk: region f140-f15f claimed by ali7101 SMB
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnp: PnP ACPI: found 12 devices
ACPI: ACPI bus type pnp unregistered
PnPBIOS: Disabled by ACPI PNP
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
PCI: Probing PCI hardware
pci 0000:00:01.0: Error creating sysfs bridge symlink, continuing...
pci 0000:00:13.0: Error creating sysfs bridge symlink, continuing...
pci 0000:00:13.1: Error creating sysfs bridge symlink, continuing...
NetLabel: Initializing
NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default
pnp: 00:0b: ioport range 0xf100-0xf13f has been reserved
pnp: 00:0b: ioport range 0xf140-0xf15f has been reserved
pnp: 00:0b: ioport range 0x1060-0x106f has been reserved
pnp: 00:0b: ioport range 0x40b-0x40b has been reserved
pnp: 00:0b: iomem range 0xfffc0000-0xfffeffff has been reserved
pnp: 00:0b: iomem range 0x0-0x9ff could not be reserved
pnp: 00:0b: iomem range 0xf00-0xfff could not be reserved
pnp: 00:0b: iomem range 0xffff0000-0xffffffff could not be reserved
Time: tsc clocksource has been installed.
PCI: Bridge: 0000:00:01.0
  IO window: 8000-8fff
  MEM window: 80600000-820fffff
  PREFETCH window: disabled.
PCI: Bus 2, cardbus bridge: 0000:00:13.0
  IO window: 00001400-000014ff
  IO window: 00001800-000018ff
  PREFETCH window: 20000000-23ffffff
  MEM window: 24000000-27ffffff
PCI: Bus 6, cardbus bridge: 0000:00:13.1
  IO window: 00001c00-00001cff
  IO window: 00002000-000020ff
  PREFETCH window: 28000000-2bffffff
  MEM window: 2c000000-2fffffff
PCI: Setting latency timer of device 0000:00:01.0 to 64
PCI: Guessed IRQ 11 for device 0000:00:13.0
PCI: Sharing IRQ 11 with 0000:00:13.1
PCI: Guessed IRQ 11 for device 0000:00:13.1
PCI: Sharing IRQ 11 with 0000:00:13.0
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
TCP reno registered
Simple Boot Flag at 0x6e set to 0x1
io scheduler noop registered
io scheduler deadline registered (default)
Activating ISA DMA hang workarounds.
Boot video device is 0000:01:00.0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 66MHz system bus speed for PIO modes
Probing IDE interface ide0...
hda: IBM-DARA-206000, ATA DISK drive
Probing IDE interface ide1...
hdd: CRN-8241B, ATAPI CD/DVD-ROM drive
Probing IDE interface ide2...
Probing IDE interface ide3...
Probing IDE interface ide4...
Probing IDE interface ide5...
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 11733120 sectors (6007 MB) w/418KiB Cache, CHS=12416/15/63
hda: cache flushes not supported
 hda: hda1 hda2 hda3
usbmon: debugfs is not available
usbcore: registered new interface driver libusual
PNP: PS/2 Controller [PNP0303:KBC0,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com
TCP cubic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
NET: Registered protocol family 15
Using IPI Shortcut mode
input: AT Translated Set 2 keyboard as /class/input/input0
No storage allocator is currently active. Rechecking whether we can use one.
Suspend2 FileAllocator: Testing whether you can resume:
Suspend2: FileAllocator: File signature found.
Resuming enabled.
Suspend2: Resuming enabled.
Suspend2 2.2.10.2, with support for [checksumming], usm, compression, swap stora
ge, file storage, userui.
Suspend2: Checking whether there is an image to restore.
Suspend2: Image invalidated.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 220k freed
Write protecting the kernel text: 2388k
Write protecting the kernel read-only data: 622k
hdd: ATAPI 24X CD-ROM drive, 128kB Cache
Uniform CD-ROM driver Revision: 3.20
Linux agpgart interface v0.102 (c) Dave Jones
agpgart: Detected ALi M???? chipset
agpgart: AGP aperture is 64M @ 0xe0000000
ALI15X3: IDE controller at PCI slot 0000:00:10.0
ALI15X3: chipset revision 195
ALI15X3: not 100% native mode: will probe irqs later
ALI15X3: port 0x01f0 already claimed by ide0
ALI15X3: port 0x0170 already claimed by ide1
ALI15X3: neither IDE port enabled (BIOS)
e100: Intel(R) PRO/100 Network Driver, 3.5.17-k4-NAPI
e100: Copyright(c) 1999-2006 Intel Corporation
PCI: Guessed IRQ 10 for device 0000:00:0a.0
e100: eth0: e100_probe: addr 0x80100000, irq 10, MAC addr 00:00:E2:xx:xx:xx
Yenta: CardBus bridge found at 0000:00:13.0 [1025:1010]
Yenta O2: res at 0x94/0xD4: ea/00
Yenta O2: enabling read prefetch/write burst
input: PC Speaker as /class/input/input1
Yenta: ISA IRQ mask 0x04b8, PCI irq 11
Socket status: 30000410
Yenta: CardBus bridge found at 0000:00:13.1 [1025:1010]
Yenta: ISA IRQ mask 0x04b8, PCI irq 11
Socket status: 30000410
ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
PCI: Guessed IRQ 11 for device 0000:00:14.0
ohci_hcd 0000:00:14.0: OHCI Host Controller
ohci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 1
ohci_hcd 0000:00:14.0: irq 11, io mem 0x82400000
Synaptics Touchpad, model: 1, fw: 4.6, id: 0x925ea1, caps: 0x80471b/0x0
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
input: SynPS/2 Synaptics TouchPad as /class/input/input2
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
PCI: Guessed IRQ 10 for device 0000:00:06.0
Real Time Clock Driver v1.12ac
NET: Registered protocol family 23
pccard: PCMCIA card inserted into slot 0
00:07: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
usb 1-2: new low speed USB device using ohci_hcd and address 2
pccard: PCMCIA card inserted into slot 1
usb 1-2: configuration #1 chosen from 1 choice
parport_pc 00:09: reported by Plug and Play ACPI
parport0: PC-style at 0x378 (0x778), irq 7, dma 1 [PCSPP,TRISTATE,COMPAT,ECP,DMA
]
usbcore: registered new interface driver hiddev
input: Fujitsu Component Apple Optical USB Mouse as /class/input/input3
input: USB HID v1.10 Mouse [Fujitsu Component Apple Optical USB Mouse] on usb-00
00:00:14.0-2
usbcore: registered new interface driver usbhid
drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
EXT3 FS on hda1, internal journal
lp0: using parport0 (interrupt-driven).
Software Watchdog Timer: 0.07 initialized. soft_noboot=0 soft_margin=60 sec (now
ayout= 0)
ACPI: AC Adapter [AC] (on-line)
ACPI: Battery Slot [BAT0] (battery present)
input: Power Button (FF) as /class/input/input4
ACPI: Power Button (FF) [PWRF]
input: Sleep Button (CM) as /class/input/input5
ACPI: Sleep Button (CM) [SLPB]
input: Lid Switch as /class/input/input6
ACPI: Lid Switch [LID]
ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])
ACPI: Thermal Zone [THR2] (53 C)
Marking TSC unstable due to: possible TSC halt in C2.
Time: acpi_pm clocksource has been installed.
[drm] Initialized drm 1.1.0 20060810
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
Capability LSM initialized
Hangcheck: starting hangcheck timer 0.9.0 (tick is 180 seconds, margin is 60 sec
onds).
Hangcheck: Using get_cycles().
input: Acer hotkey driver as /class/input/input7
Acer Travelmate hotkey driver v0.5.34
IA-32 Microcode Update Driver: v1.14a <tigran@aivazian.fsnet.co.uk>
Clocksource tsc unstable (delta = -132312396 ns)
kjournald starting.  Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS on hda2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3-fs warning: maximal mount count reached, running e2fsck is recommended
EXT3 FS on hda3, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
pcmcia: Detected deprecated PCMCIA ioctl usage from process: discover.
pcmcia: This interface will soon be removed from the kernel; please expect break
age unless you upgrade to new tools.
pcmcia: see http://www.kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html for 
details.
cs: warning: no high memory space available!
cs: unable to map card memory!
cs: unable to map card memory!
cs: warning: no high memory space available!
cs: unable to map card memory!
cs: unable to map card memory!
setserial sets custom speed on ttyS0. This is deprecated.
orinoco 0.15 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@
gnu.org>, et al)
orinoco_cs 0.15 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <pros
ki@gnu.org>, et al)
cs: warning: no high memory space available!
cs: unable to map card memory!
cs: unable to map card memory!
cs: warning: no high memory space available!
cs: unable to map card memory!
cs: unable to map card memory!
cs: warning: no high memory space available!
cs: unable to map card memory!
cs: unable to map card memory!
cs: warning: no high memory space available!
cs: unable to map card memory!
cs: unable to map card memory!
cs: warning: no high memory space available!
cs: unable to map card memory!
cs: unable to map card memory!
cs: warning: no high memory space available!
cs: unable to map card memory!
cs: unable to map card memory!
pcmcia: Detected deprecated PCMCIA ioctl usage from process: cardmgr.
pcmcia: This interface will soon be removed from the kernel; please expect break
age unless you upgrade to new tools.
pcmcia: see http://www.kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html for 
details.
cs: IO port probe 0x100-0x4ff: excluding 0x200-0x207 0x220-0x22f 0x2f8-0x2ff 0x3
30-0x337 0x388-0x38f 0x480-0x48f 0x4d0-0x4d7
cs: IO port probe 0x100-0x4ff: excluding 0x200-0x207 0x220-0x22f 0x2f8-0x2ff 0x3
30-0x337 0x388-0x38f 0x480-0x48f 0x4d0-0x4d7
cs: IO port probe 0x800-0x8ff: clean.
cs: IO port probe 0x800-0x8ff: clean.
cs: IO port probe 0xc00-0xcff: clean.
cs: IO port probe 0xc00-0xcff: clean.
cs: IO port probe 0xa00-0xaff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
orinoco_cs 0.15 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <pros
ki@gnu.org>, et al)
pcmcia: registering new device pcmcia0.0
eth1: Hardware identity 0001:0001:0004:0002
eth1: Station identity  001f:0001:0007:001c
eth1: Firmware determined as Lucent/Agere 7.28
eth1: Ad-hoc demo mode supported
eth1: IEEE standard IBSS ad-hoc mode supported
eth1: WEP supported, 104-bit key
eth1: MAC address 00:02:2D:xx:xx:xx
eth1: Station name "HERMES I"
eth1: ready
eth1: orinoco_cs at 0.0, irq 5, io 0x0100-0x013f
cs: memory probe 0xa0000000-0xa0ffffff: excluding 0xa0000000-0xa00fffff
pcmcia: registering new device pcmcia1.0
IRQ handler type mismatch for IRQ 10
current handler: ALI 5451
 [<c01563d7>] setup_irq+0x1c7/0x210
 [<c0156660>] request_irq+0xb0/0x100
 [<d8a4b1a0>] test_action+0x0/0x10 [pcmcia]
 [<d8a4b2c5>] pcmcia_request_irq+0x115/0x210 [pcmcia]
 [<d89a66d8>] simple_config+0x1b8/0x360 [serial_cs]
 [<d88d18ef>] read_cis_cache+0x10f/0x180 [pcmcia_core]
 [<d88d2f0f>] parse_cftable_entry+0x22f/0x380 [pcmcia_core]
 [<d89a6cf4>] serial_config+0x154/0x210 [serial_cs]
 [<d8a485e0>] pcmcia_device_probe+0xd0/0x170 [pcmcia]
 [<c0284f3c>] really_probe+0x9c/0x150
 [<c0285042>] driver_probe_device+0x42/0x60
 [<c028417a>] bus_for_each_drv+0x3a/0x60
 [<c02850bb>] device_attach+0x4b/0x80
 [<c0285060>] __device_attach+0x0/0x10
 [<c028491d>] bus_rescan_devices_helper+0x1d/0x70
 [<c028408a>] bus_for_each_dev+0x3a/0x60
 [<c0284983>] bus_rescan_devices+0x13/0x20
 [<c0284900>] bus_rescan_devices_helper+0x0/0x70
 [<d8a4ba74>] bind_request+0x1f4/0x2e0 [pcmcia]
 [<d8a4c64a>] ds_ioctl+0x57a/0x690 [pcmcia]
 [<c0177465>] min_pages_to_free+0x15/0x30
 [<d8a4c0d0>] ds_ioctl+0x0/0x690 [pcmcia]
 [<c0186bac>] do_ioctl+0xac/0xd0
 [<c0186d4e>] vfs_ioctl+0x5e/0x1d0
 [<c0186f37>] sys_ioctl+0x77/0x90
 [<c01040ea>] syscall_call+0x7/0xb
 =======================
IRQ handler type mismatch for IRQ 5
current handler: pcmcia0.0
 [<c01563d7>] setup_irq+0x1c7/0x210
 [<c0156660>] request_irq+0xb0/0x100
 [<d8a4b1a0>] test_action+0x0/0x10 [pcmcia]
 [<d8a4b2c5>] pcmcia_request_irq+0x115/0x210 [pcmcia]
 [<d89a66d8>] simple_config+0x1b8/0x360 [serial_cs]
 [<d88d18ef>] read_cis_cache+0x10f/0x180 [pcmcia_core]
 [<d88d2f0f>] parse_cftable_entry+0x22f/0x380 [pcmcia_core]
 [<d89a6cf4>] serial_config+0x154/0x210 [serial_cs]
 [<d8a485e0>] pcmcia_device_probe+0xd0/0x170 [pcmcia]
 [<c0284f3c>] really_probe+0x9c/0x150
 [<c0285042>] driver_probe_device+0x42/0x60
 [<c028417a>] bus_for_each_drv+0x3a/0x60
 [<c02850bb>] device_attach+0x4b/0x80
 [<c0285060>] __device_attach+0x0/0x10
 [<c028491d>] bus_rescan_devices_helper+0x1d/0x70
 [<c028408a>] bus_for_each_dev+0x3a/0x60
 [<c0284983>] bus_rescan_devices+0x13/0x20
 [<c0284900>] bus_rescan_devices_helper+0x0/0x70
 [<d8a4ba74>] bind_request+0x1f4/0x2e0 [pcmcia]
 [<d8a4c64a>] ds_ioctl+0x57a/0x690 [pcmcia]
 [<c0177465>] min_pages_to_free+0x15/0x30
 [<d8a4c0d0>] ds_ioctl+0x0/0x690 [pcmcia]
 [<c0186bac>] do_ioctl+0xac/0xd0
 [<c0186d4e>] vfs_ioctl+0x5e/0x1d0
 [<c0186f37>] sys_ioctl+0x77/0x90
 [<c01040ea>] syscall_call+0x7/0xb
 =======================
IRQ handler type mismatch for IRQ 10
current handler: ALI 5451
 [<c01563d7>] setup_irq+0x1c7/0x210
 [<c0156660>] request_irq+0xb0/0x100
 [<d8a4b1a0>] test_action+0x0/0x10 [pcmcia]
 [<d8a4b2c5>] pcmcia_request_irq+0x115/0x210 [pcmcia]
 [<d89a66d8>] simple_config+0x1b8/0x360 [serial_cs]
 [<d88d18ef>] read_cis_cache+0x10f/0x180 [pcmcia_core]
 [<d88d2f0f>] parse_cftable_entry+0x22f/0x380 [pcmcia_core]
 [<d89a6cf4>] serial_config+0x154/0x210 [serial_cs]
 [<d8a485e0>] pcmcia_device_probe+0xd0/0x170 [pcmcia]
 [<c0284f3c>] really_probe+0x9c/0x150
 [<c0285042>] driver_probe_device+0x42/0x60
 [<c028417a>] bus_for_each_drv+0x3a/0x60
 [<c02850bb>] device_attach+0x4b/0x80
 [<c0285060>] __device_attach+0x0/0x10
 [<c028491d>] bus_rescan_devices_helper+0x1d/0x70
 [<c028408a>] bus_for_each_dev+0x3a/0x60
 [<c0284983>] bus_rescan_devices+0x13/0x20
 [<c0284900>] bus_rescan_devices_helper+0x0/0x70
 [<d8a4ba74>] bind_request+0x1f4/0x2e0 [pcmcia]
 [<d8a4c64a>] ds_ioctl+0x57a/0x690 [pcmcia]
 [<c0177465>] min_pages_to_free+0x15/0x30
 [<d8a4c0d0>] ds_ioctl+0x0/0x690 [pcmcia]
 [<c0186bac>] do_ioctl+0xac/0xd0
 [<c0186d4e>] vfs_ioctl+0x5e/0x1d0
 [<c0186f37>] sys_ioctl+0x77/0x90
 [<c01040ea>] syscall_call+0x7/0xb
 =======================
pcmcia: request for exclusive IRQ could not be fulfilled.
pcmcia: the driver needs updating to supported shared IRQ lines.
1.0: ttyS1 at I/O 0x3e8 (irq = 11) is a 16550A
eth1: New link status: Disconnected (0002)
eth1: New link status: Connected (0001)
Comment 1 Alan 2008-09-22 08:40:05 UTC
Patch done and fired at wireless maintainer.
Comment 2 Alan 2008-10-16 06:23:16 UTC
Merged into upstream git tree for 2.6.28

Note You need to log in before you can comment on or make changes to this bug.