Bug 8731 - Numlock light gets off after hibernation
Numlock light gets off after hibernation
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2007-07-10 07:12 UTC by Victor Porton
Modified: 2007-10-12 13:18 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.21.5
Tree: Mainline
Regression: ---


Attachments

Description Victor Porton 2007-07-10 07:12:45 UTC
Distribution: Debian
Hardware Environment: Celeron; PS/2 keyboard
Software Environment: hibernate script
Problem Description:

Before hibernating NumLock is on.

After resume numlock light on the keyboard is off. (But keyboard acts as if it
would be on.)

Workaround: press NumLock key twice.

Steps to reproduce:
1. Turn numlock on.
2. Hibernate.
3. Resume.
Comment 1 Dmitry Torokhov 2007-07-10 07:41:57 UTC
Does it work properly if you start hibernation while in text console as ooopsed to being in X?
Comment 2 Rafael J. Wysocki 2007-08-08 09:52:42 UTC
I can reproduce it on similar hardware.

If hibernation is started from a text (FB, to be precise) console, the keyboard works properly (ie. the numlock status is restored).
Comment 3 Rafael J. Wysocki 2007-10-06 08:29:25 UTC
So, are we going to do anything about it?
Comment 4 Dmitry Torokhov 2007-10-06 21:05:02 UTC
I need to finish moving LED handling into generic resume in input core. That will ensure that all keyboards work the same way. However X manages LED state outside of kernel and so we can't really do anything...
Comment 5 Dmitry Torokhov 2007-10-06 21:09:07 UTC
And X is very stupid - it does not properly restore LED state if you hit CapsLock and switch to a text console and back. I know that the kernel is working because LED state is restored properly if you switch between text VTs. 
Comment 6 Rafael J. Wysocki 2007-10-12 12:36:27 UTC
So, this is not a kernel bug, but an X problem.

I think we should close this entry, then.
Comment 7 Dmitry Torokhov 2007-10-12 13:13:20 UTC
I think the numlock restore still does not work for USB keyboards so closing it is premature.
Comment 8 Rafael J. Wysocki 2007-10-12 13:18:28 UTC
OK, sorry.  Should I reopen?

Note You need to log in before you can comment on or make changes to this bug.