Bug 8710 - VMWare Fusion-MPT SCSI drives no longer recognized
VMWare Fusion-MPT SCSI drives no longer recognized
Status: RESOLVED DUPLICATE of bug 8492
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-03 07:22 UTC by Frans Pop
Modified: 2007-07-05 16:36 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.21
Tree: Mainline
Regression: ---


Attachments

Description Frans Pop 2007-07-03 07:22:21 UTC
Most recent kernel where this bug did not occur: 2.6.20
Distribution: Debian
Hardware Environment: VMWare Workstation 5.5.4
Software Environment: Debian Sid
Problem Description: Emulated Fusion-MPT SCSI drives no are longer recognized

Steps to reproduce: Boot the system

This issue has earlier been reported in:
http://lkml.org/lkml/2007/3/23/312

The kernel still loads the driver, but the disks are not seen:
<snip from dmesg>
mptbase: Initiating ioc0 bringup
Uniform CD-ROM driver Revision: 3.20
ioc0: 53C1030: Capabilities={Initiator}
scsi0 : ioc0: LSI53C1030, FwRev=00000000h, Ports=1, MaxQ=128, IRQ=185
</snip>

This should be followed the following, but is not:
<missing bit displayed with earlier kernels>
  Vendor: VMware,   Model: VMware Virtual S  Rev: 1.0
  Type:   Direct-Access                      ANSI SCSI revision: 02
 target0:0:0: Beginning Domain Validation
 target0:0:0: Domain Validation skipping write tests
 target0:0:0: Ending Domain Validation
 target0:0:0: FAST-160 WIDE SCSI 320.0 MB/s DT IU RDSTRM RTI WRFLOW PCOMP (6.25 ns, offset 127)
SCSI device sda: 4194304 512-byte hdwr sectors (2147 MB)
</missing>

I have done a git-bisect and traced the issue to:
793955f549c710a1b0c18f823d5d710840747b15 is first bad commit
commit 793955f549c710a1b0c18f823d5d710840747b15
Author: Eric Moore <eric.moore@lsi.com>
Date:   Mon Jan 29 09:42:20 2007 -0700
    [SCSI] fusion - Greater than 255 target and lun support

I've verified that the issue is still present in 2.6.22-rc7

Cheers,
Frans Pop

P.S. Tried to add Eric's email as CC but bugzilla refused that.
Comment 1 Adrian Bunk 2007-07-05 16:36:26 UTC
Known bug in VMWare, fixed in VMWare Workstation 6.

*** This bug has been marked as a duplicate of bug 8492 ***

Note You need to log in before you can comment on or make changes to this bug.