Bug 8697 - nfs-root doesn't work with jumbo frames
Summary: nfs-root doesn't work with jumbo frames
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Networking
Classification: Unclassified
Component: IPV4 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Stephen Hemminger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-07-01 10:57 UTC by Mariusz Bialonczyk
Modified: 2014-12-15 17:06 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.21.1
Tree: Mainline
Regression: ---


Attachments
proposed fix (72 bytes, text/plain)
2007-07-01 11:04 UTC, Mariusz Bialonczyk
Details
BNX (broadcom) has issues (6.66 KB, image/png)
2009-04-15 00:41 UTC, Stefan de Konink
Details

Description Mariusz Bialonczyk 2007-07-01 10:57:30 UTC
Problem Description:
Using diskless workstation, which boot up from network and the root filesystem is mounted via NFS (nfsroot). With server's MTU set to 9000 client can load a kernel via tftpboot, but can not mount the root file system over NFS (nfs server not responding, still trying). I can mount server export via TCP but it is not the way i want. The only solution for me was to set kernel's initial MTU size. The problem was also described here:
http://www.ussg.iu.edu/hypermail/linux/kernel/0311.1/1055.html
On my website the problem is described and there's also my patch to kernel as a proposition for update:
http://manio.skyboo.net/nfsroot_jumbo/
Comment 1 Mariusz Bialonczyk 2007-07-01 11:04:09 UTC
Created attachment 11912 [details]
proposed fix
Comment 2 Andrew Morton 2007-07-01 11:48:57 UTC
Subject: Re: [Bugme-new]  New: nfs-root doesn't work with jumbo
 frames

please submit the patch via email as per
http://www.zip.com.au/~akpm/linux/patches/stuff/tpp.txt
to
Andrew Morton <akpm@linux-foundation.org>
netdev@vger.kernel.org
linux-kernel@vger.kernel.org

thanks.
Comment 3 Stephen Hemminger 2007-07-09 10:04:13 UTC
The patch looks fine and has been submitted. So let's mark this as resolved for now.
Comment 4 Chris Schanzle 2008-03-21 21:16:28 UTC
I have this problem, found this solution, and do not see the patch applied to 2.6.24.3 (current).
Comment 5 Roland Kletzing 2008-12-26 05:54:59 UTC
if this patch looks fine, why hasn`t it been merged then ?
Comment 6 Stefan de Konink 2009-04-15 00:41:25 UTC
Created attachment 20987 [details]
BNX (broadcom) has issues

I am using this driver on 2.6.29, with mtu of 9000 in a Dell 2950 with Broadcom drivers. The box gets fubar using it. I wonder if it is related to the other bugs known to this device.

http://mywiki.ncsa.uiuc.edu/wiki/Dell_PE1950_NIC_Firmware_Workaround
Comment 7 Michael Ole Olsen 2010-01-28 09:33:47 UTC
why hasn't this patch been merged?

nfsroot with jumbos would be very nice.

i cannot find any (ipmtu) MTU option in 2.6.30.1

NFS root fails here with jumbos, also the patch does not work for my setup with 9000 mtu on server.

first when i do ifconfig bond0 mtu 1500 the client boots
Comment 8 Michael Ole Olsen 2010-01-28 09:35:28 UTC
i tried patching both e1000.c and ipconfig.c individually without luck (net->mtu=9000;), it will only boot with 1500 MTU (and verified that jumbos are enabled on the switch)
Comment 9 Faisal Abu-Nimeh 2013-07-05 15:01:40 UTC
I found this patch extremely useful for PPC440 inside a virtex-5.
I used a similar patch to set the MTU on a 3.8.0 Kernel.

Obviously one cannot change the MTU on a nfsroot device. You would always get "STOP device first!!!" and if you try to ifconfig ethX down then the whole system would freeze because it can no longer access the nfs rootfs.

I can provide the patch to 3.8.0 if needed. 
Thanks Mariusz Bialonczyk!
Comment 10 Amit Kumar 2014-12-15 17:06:54 UTC
Dear All,

I believe I am running into this issue with: SL 2.6.32-431.17.1

I can happily boot my diskless nfs-root clients with default MTU 1500, from our NFS appliance(NetApp). The moment I change my MTU=9000 for my clients, it fails to boot and gets stuck after dracut mounting...


Any idea on how to check if this patch is applied to the version of the kernel I have, or any further tips on debugging this issue is greatly appreciated. 

I have been successful on changing my MTU on fly but the breaks the NFS-root and I start seeing tons of RPC hangs-&-time-out issues.

Please advise.
Thank you,
Amit

Note You need to log in before you can comment on or make changes to this bug.