Bug 8682 - BUG: at fs/inotify.c:172 set_dentry_child_flags()
BUG: at fs/inotify.c:172 set_dentry_child_flags()
Status: RESOLVED DUPLICATE of bug 7785
Product: File System
Classification: Unclassified
Component: ext3
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 04:46 UTC by Ralf Hildebrandt
Modified: 2007-06-30 16:48 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.21.5
Tree: Mainline
Regression: ---


Attachments

Description Ralf Hildebrandt 2007-06-27 04:46:53 UTC
Most recent kernel where this bug did not occur: 2.6.21.4
Distribution: Debian/testing
Hardware Environment: dual Intel(R) Xeon(TM) CPU 2.80GHz
Software Environment:
Problem Description:

dmesg emits:
[2124918.308441] tg3: eth0: Link is up at 1000 Mbps, full duplex.
[2124918.308526] tg3: eth0: Flow control is on for TX and on for RX.
[2373333.488796] BUG: at fs/inotify.c:172 set_dentry_child_flags()
[2373333.488865]  [<c107eb51>] set_dentry_child_flags+0xc4/0x14b
[2373333.488913]  [<c107ec2b>] remove_watch_no_event+0x53/0x5f
[2373333.488953]  [<c107ed2f>] inotify_remove_watch_locked+0x12/0x3e
[2373333.488996]  [<c105ac31>] vfs_write+0xe9/0x118
[2373333.489030]  [<c107f013>] inotify_rm_wd+0x60/0x8d
[2373333.489069]  [<c107f4cb>] sys_inotify_rm_watch+0x38/0x54
[2373333.489107]  [<c1003e02>] sysenter_past_esp+0x5f/0x85
[2373333.489144]  =======================

Steps to reproduce:
Comment 1 Adrian Bunk 2007-06-30 16:48:26 UTC

*** This bug has been marked as a duplicate of bug 7785 ***

Note You need to log in before you can comment on or make changes to this bug.