Bug 86311 - HDMI audio requires intel_iommu=igfx_off boot option on Haswell
Summary: HDMI audio requires intel_iommu=igfx_off boot option on Haswell
Status: RESOLVED DUPLICATE of bug 60769
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-15 11:31 UTC by Alexander E. Patrakov
Modified: 2014-10-23 15:06 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.10 - 3.17
Tree: Mainline
Regression: No


Attachments

Description Alexander E. Patrakov 2014-10-15 11:31:41 UTC
This is an intentional duplicate of Bug 60769, because the ALSA-specific part of that bug got fixed, all that is left is a bad interaction between i915 and iommu, and that requires a different person to handle. But I can't reassign bugs.

On all Haswell hardware, if you don't provide the intel_iommu=igfx_off option (and your distro defaults to intel_iommu=on), then attempts to output audio via HDMI will lead to undesired behaviour that is different between systems. On some systems, audio crackles, on others the audio stream immediately hangs.
Comment 1 Alexander E. Patrakov 2014-10-16 14:25:16 UTC
I chatted to Daniel Vetter, he says that it is wrong to assign it to the graphics driver. Please reassign to the IOMMU component.
Comment 2 Jani Nikula 2014-10-16 14:31:28 UTC
Dupe of bug 67321 and/or bug 86221?
Comment 3 Alexander E. Patrakov 2014-10-16 14:51:36 UTC
This bug, bug 67321, bug 60769 and bug 86221 are indeed the same.
Comment 4 Alan 2014-10-23 14:04:21 UTC

*** This bug has been marked as a duplicate of bug 60769 ***
Comment 5 Alexander E. Patrakov 2014-10-23 14:24:40 UTC
Alan, if you mark this as a dupe, then please also fix the component and the responsible person on bug 60769. My inability to fix this fields is the reason of creating a duplicate - if the "primary" bug is assigned to an ALSA person, there is absolutely no chance that an IOMMU person will look at it.
Comment 6 Alan 2014-10-23 15:06:35 UTC
The DMA/IOMMU person is on the CC of 60769 already (dwmw2@infradead.org)

Note You need to log in before you can comment on or make changes to this bug.