Bug 86221 - HDMI no sound output while intel IOMMU is enabled on Haswell-based board
Summary: HDMI no sound output while intel IOMMU is enabled on Haswell-based board
Status: RESOLVED DUPLICATE of bug 60769
Alias: None
Product: Drivers
Classification: Unclassified
Component: PCI (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: intel-gfx-bugs@lists.freedesktop.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-14 08:12 UTC by st.smartie
Modified: 2015-01-28 14:51 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.16.x 3.15.x 3.12.x
Tree: Fedora
Regression: No


Attachments
alsa info (16.28 KB, text/plain)
2014-10-14 08:12 UTC, st.smartie
Details
kernel config (140.36 KB, application/octet-stream)
2014-10-14 08:13 UTC, st.smartie
Details
full dmesg log (59.22 KB, text/plain)
2014-10-14 08:16 UTC, st.smartie
Details
ACPI table DMAR (5.13 KB, text/plain)
2014-10-14 08:16 UTC, st.smartie
Details
log of lspci (2.70 KB, text/x-log)
2014-10-14 09:37 UTC, st.smartie
Details

Description st.smartie 2014-10-14 08:12:58 UTC
Created attachment 153671 [details]
alsa info

There are no sound output from HDMI when intel IOMMU is enabled. assign intel_iommu=on,igfx_off is not a way for me since I am developing IGD virtualization.
I've discovered some symptoms: the execution of

aplay -D plughw:0,7 /usr/share/sounds/alsa/Front_Center.wav
aplay -D plughw:0,3 /usr/share/sounds/alsa/Front_Center.wav  

is never end unless you interrupt it. Actually it is not no sound output at all, you could hear few frames played from speaker, but the duration is very short (less then 0.1 second.)

Some logs are attached for your reference.
Comment 1 st.smartie 2014-10-14 08:13:57 UTC
Created attachment 153681 [details]
kernel config
Comment 2 st.smartie 2014-10-14 08:16:17 UTC
Created attachment 153691 [details]
full dmesg log
Comment 3 st.smartie 2014-10-14 08:16:53 UTC
Created attachment 153701 [details]
ACPI table DMAR
Comment 4 st.smartie 2014-10-14 09:37:55 UTC
Created attachment 153721 [details]
log of lspci
Comment 5 Takashi Iwai 2014-10-15 12:37:51 UTC
The problem is rather in iommu or graphics, not in the sound driver...
Let's reassign to the component.  Feel free to reassign to else if not appropriate.
Comment 6 henrywu 2014-10-16 04:47:39 UTC
(In reply to Takashi Iwai from comment #5)
> The problem is rather in iommu or graphics, not in the sound driver...
> Let's reassign to the component.  Feel free to reassign to else if not
> appropriate.

Thanks.

I am wondering if the IGD and HDA controller share a p2p bridge? that intel iommu is not aware of?

Just a wild guess, correct me if I am wrong.
Comment 7 Jani Nikula 2014-10-16 07:27:34 UTC
Possible dupe of bug 67321.
Comment 8 Jani Nikula 2015-01-28 14:51:37 UTC

*** This bug has been marked as a duplicate of bug 60769 ***

Note You need to log in before you can comment on or make changes to this bug.