Bug 8618 - FC6 > F7 update causes bt878 card to stop working
FC6 > F7 update causes bt878 card to stop working
Status: REJECTED INVALID
Product: v4l-dvb
Classification: Unclassified
Component: bt8xx
All Linux
: P1 normal
Assigned To: Mauro Carvalho Chehab
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-12 10:35 UTC by mjc
Modified: 2007-07-06 09:38 UTC (History)
0 users

See Also:
Kernel Version: 2.6.21-1.3194.fc7
Tree: Mainline
Regression: ---


Attachments

Description mjc 2007-06-12 10:35:32 UTC
Most recent kernel where this bug did not occur: 2.6.20-1.2925.fc6
Distribution: Fedora
Hardware Environment: i386 (HP DC7600)
Software Environment: Fedora, using motion video capture software (www.lavrsen.dk/twiki/bin/view/Motion/WebHome)

Problem Description: The Linux Media Labs LMLBT4M video capture card worked fine with kernel 2.6.20-1.2925.fc6. Upgrading to Fedora 7 caused it to stop working - it just returns a green screen. Keeping F7 but enabling the old 2.6.20-1.2925.fc6 kernel in grub.conf makes the card work again (can see the output of the attached analog camera).

Another user has reported similar trouble with a PV149 (bt878) card: http://sourceforge.net/mailarchive/forum.php?thread_name=466EA217.8030302%40avtechpulse.com&forum_name=motion-user

My modprobe.conf has:

alias char-major-81 videodev
alias char-major-81-0 bttv
alias char-major-81-64 bttv
options bttv card=118

Here is the log output for the good kernel:

Jun 12 11:52:51 karsh kernel: Linux version 2.6.20-1.2925.fc6 (brewbuilder@hs20-bc1-7.build.redhat.com) (gcc version 4.1.1 20070105 (Red Hat 4.1.1-51)) #1 SMP Sat Mar 10 19:15:16 EST 2007
...
Jun 12 11:52:53 karsh kernel: bttv: driver version 0.9.16 loaded
Jun 12 11:52:53 karsh kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Jun 12 11:52:53 karsh kernel: bttv: Bt8xx card found (0).
Jun 12 11:52:53 karsh kernel: ACPI: PCI Interrupt 0000:05:09.0[A] -> GSI 18 (level, low) -> IRQ 18
Jun 12 11:52:53 karsh kernel: bttv0: Bt878 (rev 17) at 0000:05:09.0, irq: 18, latency: 32, mmio: 0xe0a00000
Jun 12 11:52:53 karsh kernel: bttv0: using: LMLBT4 [card=118,insmod option]
Jun 12 11:52:53 karsh kernel: bttv0: using tuner=-1
Jun 12 11:52:53 karsh kernel: bttv0: i2c: checking for TDA9887 @ 0x86... not found
Jun 12 11:52:53 karsh kernel: bttv0: registered device video0
Jun 12 11:52:53 karsh kernel: bttv0: registered device vbi0
Jun 12 11:52:53 karsh kernel: bt878: AUDIO driver version 0.0.0 loaded
Jun 12 11:52:53 karsh kernel: bt878: Bt878 AUDIO function found (0).
Jun 12 11:52:53 karsh kernel: ACPI: PCI Interrupt 0000:05:09.1[A] -> GSI 18 (level, low) -> IRQ 18
Jun 12 11:52:53 karsh kernel: bt878_probe: card id=[0xffffffff], Unknown card.
Jun 12 11:52:53 karsh kernel: Exiting..
Jun 12 11:52:53 karsh kernel: ACPI: PCI interrupt for device 0000:05:09.1 disabled
Jun 12 11:52:53 karsh kernel: bt878: probe of 0000:05:09.1 failed with error -22
Jun 12 11:52:53 karsh kernel: loop: loaded (max 8 devices)


Here is the log output for the bad kernel (no obvious differences, really):

Jun 12 09:39:30 karsh kernel: Linux version 2.6.21-1.3194.fc7 (kojibuilder@xenbuilder4.fedora.phx.redhat.com) (gcc version 4.1.2 20070502 (Red Hat 4.1.2-12)) #1 SMP Wed May 23 22:35:01 EDT 2007 
...
Jun 12 09:39:31 karsh kernel: Linux video capture interface: v2.00
Jun 12 09:39:31 karsh kernel: ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 21 (level, low) -> IRQ 19
Jun 12 09:39:31 karsh kernel: bttv: driver version 0.9.17 loaded
Jun 12 09:39:31 karsh kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Jun 12 09:39:31 karsh kernel: bttv: Bt8xx card found (0).
Jun 12 09:39:31 karsh kernel: ACPI: PCI Interrupt 0000:05:09.0[A] -> GSI 18 (level, low) -> IRQ 18
Jun 12 09:39:31 karsh kernel: bttv0: Bt878 (rev 17) at 0000:05:09.0, irq: 18, latency: 32, mmio: 0xe0a00000
Jun 12 09:39:31 karsh kernel: bttv0: using: LMLBT4 [card=118,insmod option]
Jun 12 09:39:31 karsh kernel: bttv0: using tuner=-1
Jun 12 09:39:31 karsh kernel: bttv0: i2c: checking for TDA9887 @ 0x86... not found
Jun 12 09:39:31 karsh kernel: bttv0: registered device video0
Jun 12 09:39:31 karsh kernel: bttv0: registered device vbi0
Jun 12 09:39:31 karsh kernel: bt878: AUDIO driver version 0.0.0 loaded
Jun 12 09:39:31 karsh kernel: bt878: Bt878 AUDIO function found (0).
Jun 12 09:39:31 karsh kernel: ACPI: PCI Interrupt 0000:05:09.1[A] -> GSI 18 (level, low) -> IRQ 18
Jun 12 09:39:31 karsh kernel: bt878_probe: card id=[0xffffffff], Unknown card.
Jun 12 09:39:31 karsh kernel: Exiting..
Jun 12 09:39:31 karsh kernel: ACPI: PCI interrupt for device 0000:05:09.1 disabled
Jun 12 09:39:31 karsh kernel: bt878: probe of 0000:05:09.1 failed with error -22
Jun 12 09:39:31 karsh kernel: loop: loaded (max 8 devices)

- Mike
Comment 1 Mauro Carvalho Chehab 2007-06-22 13:12:12 UTC
This line is very weird:

bt878_probe: card id=[0xffffffff], Unknown card.

Maybe your eeprom were damaged somehow.

Anyway, the better is if you can do a bissection, identifying what patch broke it.

For doing this, the better is to retrieve the last v4l-dvb tree., available at:
    http://linuxtv.org/hg/v4l-dvb

To retrieve the tree, you will need to have installed 'mercurial' (available at
selenic.com/mercurial), and do:
    hg clone http://linuxtv.org/hg/v4l-dvb

At the tree's README.patches, on chapter 8, there are some instructions on how
to do the bissection.
Comment 2 mjc 2007-06-26 10:25:21 UTC
Thanks for the instructions. I will try bisecting sometime next week.

- Mike
Comment 3 mjc 2007-07-06 09:09:46 UTC
I compiled v4l-dvb rev 5829 on my Fedora 7 2.6.21-1.3228.fc7 system, and everything works fine now.

The stock v4l-dvb associated with 2.6.21-1.3228.fc7 did not work. 

How do I tell what v4l-dvb rev is associated with the fc7 kernel?

- Mike
Comment 4 mjc 2007-07-06 09:38:15 UTC
Never mind. Any 5xxx rev seems to work fine. Looks like it is strictly a Fedora problem. Closing this bug.

- Mike

Note You need to log in before you can comment on or make changes to this bug.