Bug 8598 - Asus M6N: no battery information in > 2.6.20
Asus M6N: no battery information in > 2.6.20
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: EC
i386 Linux
: P2 normal
Assigned To: Alexey Starikovskiy
:
: 8477 8493 8504 8744 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 05:05 UTC by Mikhail Gusarov
Modified: 2008-10-17 21:35 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.22-rc4
Tree: Mainline
Regression: ---


Attachments
dmesg of (working) 2.6.20 (20.77 KB, text/plain)
2007-06-08 05:06 UTC, Mikhail Gusarov
Details
dmesg of (non-working) 2.6.22-rc4 (20.11 KB, text/plain)
2007-06-08 05:18 UTC, Mikhail Gusarov
Details
dmesg of (non-working) 2.6.22-rc4 (20.11 KB, text/plain)
2007-06-08 05:18 UTC, Mikhail Gusarov
Details
acpidump output (118.58 KB, text/plain)
2007-06-08 05:37 UTC, Mikhail Gusarov
Details
lspci -vv (9.77 KB, text/plain)
2007-06-08 05:45 UTC, Mikhail Gusarov
Details
.config from 2.6.20 (75.00 KB, text/plain)
2007-06-08 06:09 UTC, Mikhail Gusarov
Details
.config from 2.6.22-rc4 (78.57 KB, text/plain)
2007-06-08 06:22 UTC, Mikhail Gusarov
Details
Try to find EC in DSDT if ECDT lookup fails (1.67 KB, patch)
2007-06-10 07:17 UTC, Alexey Starikovskiy
Details | Diff
patch vs 2.6.23-rc1-git (3.47 KB, patch)
2007-08-03 15:06 UTC, Len Brown
Details | Diff
Do early init only for fake _INI being present (1.29 KB, patch)
2007-10-30 13:22 UTC, Alexey Starikovskiy
Details | Diff
fixed patch (1.29 KB, patch)
2007-11-02 13:11 UTC, Alexey Starikovskiy
Details | Diff

Description Mikhail Gusarov 2007-06-08 05:05:23 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20
Distribution: Debian
Hardware Environment: Asus M6N notebook
Problem Description:

Main battery status/information is not reported: in 2.6.20 there were two 
directories in /proc/acpi/battery: BAT0 and BAT1 (second properly reported as 
missing, seems to be slot for extension battery), in 2.6.22-rc3 and rc4 there 
is only BAT1.

.configs, dmesgs and acpidump output are attached.
Comment 1 Mikhail Gusarov 2007-06-08 05:06:59 UTC
Created attachment 11707 [details]
dmesg of (working) 2.6.20
Comment 2 Mikhail Gusarov 2007-06-08 05:18:27 UTC
Created attachment 11708 [details]
dmesg of (non-working) 2.6.22-rc4
Comment 3 Mikhail Gusarov 2007-06-08 05:18:47 UTC
Created attachment 11709 [details]
dmesg of (non-working) 2.6.22-rc4
Comment 4 Mikhail Gusarov 2007-06-08 05:37:36 UTC
Created attachment 11711 [details]
acpidump output
Comment 5 Mikhail Gusarov 2007-06-08 05:45:14 UTC
Created attachment 11712 [details]
lspci -vv
Comment 6 Mikhail Gusarov 2007-06-08 06:09:36 UTC
Created attachment 11713 [details]
.config from 2.6.20
Comment 7 Mikhail Gusarov 2007-06-08 06:22:05 UTC
Created attachment 11714 [details]
.config from 2.6.22-rc4
Comment 8 Mikhail Gusarov 2007-06-08 06:24:06 UTC
Comment on attachment 11709 [details]
dmesg of (non-working) 2.6.22-rc4

dup
Comment 9 Alexey Starikovskiy 2007-06-10 07:17:08 UTC
Created attachment 11724 [details]
Try to find EC in DSDT if ECDT lookup fails

Please try this patch.
Comment 10 Alexey Starikovskiy 2007-06-10 07:27:06 UTC
*** Bug 8504 has been marked as a duplicate of this bug. ***
Comment 11 Matthias Bläsing 2007-06-10 09:32:24 UTC
I'm the reportet auf the duplicate (Bug 8504) - an writing this from
2.6.22-rc4-git3. To make it short: My Battery is there and it boots *great, thanks*
Comment 12 Mikhail Gusarov 2007-06-11 02:55:45 UTC
Provided patch fixes the regression on my M6N.
Comment 13 Mikhail Gusarov 2007-07-08 23:52:49 UTC
This bugfix did not go to the 2.6.22. WTF???
Comment 14 Alexey Starikovskiy 2007-07-11 20:53:16 UTC
*** Bug 8709 has been marked as a duplicate of this bug. ***
Comment 15 Alexey Starikovskiy 2007-07-18 02:10:14 UTC
*** Bug 8477 has been marked as a duplicate of this bug. ***
Comment 16 Alexey Starikovskiy 2007-07-18 12:00:47 UTC
*** Bug 8744 has been marked as a duplicate of this bug. ***
Comment 17 Len Brown 2007-08-03 15:06:37 UTC
Created attachment 12242 [details]
patch vs 2.6.23-rc1-git

this refreshed patch from Alexey is in acpi-test
Comment 18 Len Brown 2007-08-20 13:31:42 UTC
cd8c93a4e04dce8f00d1ef3a476aac8bd65ae40b
shipped in 2.6.23-rc3
closed.
Comment 19 Fu Michael 2007-10-10 01:03:27 UTC
*** Bug 8493 has been marked as a duplicate of this bug. ***
Comment 20 Alexey Starikovskiy 2007-10-30 13:22:55 UTC
Created attachment 13355 [details]
Do early init only for fake _INI being present

Previous patch causes too many problems for other machines. Try limit early inits to only EC with _INI method. Please test that it does not cause regressions for you.
Comment 21 Thomas Schwarzgruber 2007-11-02 12:45:26 UTC
Applied patch to 2.6.24-rc1-g5307cc1a and Battery 0 is not shown again:

bash-3.00$ dmesg | grep ACPI
ACPI: AC Adapter [AC] (off-line)
ACPI: Battery Slot [BAT1] (battery absent)
[..]
Comment 22 Alexey Starikovskiy 2007-11-02 13:11:20 UTC
Created attachment 13385 [details]
fixed patch

Sorry, there was typo in previous patch. Could you please test this one?
Comment 23 Thomas Schwarzgruber 2007-11-05 01:38:54 UTC
That one works for me.
Comment 24 Mikhail Gusarov 2007-11-05 14:17:38 UTC
Works for me too.
Comment 25 Len Brown 2007-11-18 22:48:34 UTC
27792f3af1f67057fc17e4bd3b28d0ce8fe1d15c
(ACPI: EC: Don't init EC early if it has no _INI)
applied to acpi test branch
Comment 26 Len Brown 2008-06-13 20:30:09 UTC
shipped in 2.6.24-rc4 -- closed

commit 5870a8cd23181703cc76f88f630372f8602c7648
Author: Alexey Starikovskiy <astarikovskiy@suse.de>
Date:   Thu Nov 15 21:52:47 2007 +0300

    ACPI: EC: Don't init EC early if it has no _INI
    
    Option to init EC early inserted to handle #8598 ASUS problem,
    introduced several others.
    
    EC driver in this particular case has fake _INI method, not present on
    other machines, which don't need or break from this workaround, so lets use
    its presence as a flag for early init.
    
    http://bugzilla.kernel.org/show_bug.cgi?id=9262
    http://bugzilla.kernel.org/show_bug.cgi?id=8598
    https://bugzilla.novell.com/show_bug.cgi?id=334806
    
    Signed-off-by: Alexey Starikovskiy <astarikovskiy@suse.de>
    Signed-off-by: Len Brown <len.brown@intel.com>

Note You need to log in before you can comment on or make changes to this bug.