Bug 85931 - Acer Aspire E5-511 ACPI problems
Summary: Acer Aspire E5-511 ACPI problems
Status: CLOSED CODE_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Aaron Lu
URL:
Keywords:
Depends on: 101271
Blocks:
  Show dependency tree
 
Reported: 2014-10-09 00:43 UTC by Ant
Modified: 2016-08-10 15:43 UTC (History)
20 users (show)

See Also:
Kernel Version: 3.17
Tree: Mainline
Regression: No


Attachments
lspci.txt (6.77 KB, text/plain)
2014-10-09 00:43 UTC, Ant
Details
dmidecode.txt (8.24 KB, text/plain)
2014-10-09 00:44 UTC, Ant
Details
result of 'sudo acpidump' (332.27 KB, application/octet-stream)
2014-10-09 00:44 UTC, Ant
Details
dmesg | grep acpi (1.21 KB, text/plain)
2014-10-09 00:49 UTC, Ant
Details
dsdt.dsl file from acpi dump (496.67 KB, text/x-dsl)
2014-10-09 01:05 UTC, Ant
Details
full dmesg after booting (pnpacpi=off) (49.72 KB, text/plain)
2014-10-13 20:33 UTC, Ant
Details
acpi_devices_hid.txt (4.29 KB, text/plain)
2014-10-13 20:33 UTC, Ant
Details
acpi_drivers_list.txt (693 bytes, text/plain)
2014-10-13 20:34 UTC, Ant
Details
dmesg with patched 3.17.0 kernel (50.68 KB, text/plain)
2014-10-13 20:35 UTC, Ant
Details
dmesg using kernel 3.14.21 (50.16 KB, text/plain)
2014-10-13 20:35 UTC, Ant
Details
dmesg from fresh EFI ubuntu 14.04LTS install (59.36 KB, text/plain)
2014-11-23 20:33 UTC, Ant
Details
Logs after system hangs Kernel 4.3 (3.05 KB, text/plain)
2016-01-01 21:32 UTC, Erlington Espinoza Cardoza
Details
Logs after system hangs Kernel 4.3.3 (790 bytes, text/plain)
2016-01-01 21:33 UTC, Erlington Espinoza Cardoza
Details
attachment-15067-0.html (1.12 KB, text/html)
2016-03-16 01:52 UTC, Erlington Espinoza Cardoza
Details

Description Ant 2014-10-09 00:43:34 UTC
Created attachment 152971 [details]
lspci.txt

Greetings! New laptop and suffers a few ACPI issues on linux.

OS: Ubuntu 14.10 64bit

Current kernel: 3.17.0-031700-generic #201410060605 SMP Mon Oct 6 10:07:09 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux  (from ubuntu mainline) (also running ubuntu 14.10's latest default based on 3.16.3 ("3.16.0.21.22")

Laptop: Acer Aspire E5-511, with latest BIOS (v1.03)

To be attached: 
lspci.txt
dmidecode.txt
result of 'sudo acpidump'

Booting is very temperamental, and i can't get it to hibernate/suspend without becoming totally non-responsive to get the /var/log/kern.log.0 file.
However, these are the results of debugging boot parameters:

acpi=off           boots but with fans constantly going
acpi=ht            boots, fan behaves itself
pci=noacpi         doesn't boot, hangs on garbled text
acpi=noirq         boots but then hangs on plymouth splash
pnpacpi=off        boots and behaves itself reasonably (currently using this)
noapic xor nolapic neither boot

/proc/acpi/fan and /proc/acpi/thermal_zone/*/trip_points via 'cat' are both empty.

Recurring error messages printed:
dw_dmac INTL9C60:00: invalid resource  (for anything with the power button?)

and the following with the latter acpi debugging parameters:
"SCI (ACPI GSI 9) not registered"  and
"i2c_designware 80860F41:02 failure requesting irq 34"
"i2c_designware 80860F41:05 failure requesting irq 37"
Comment 1 Ant 2014-10-09 00:44:06 UTC
Created attachment 152981 [details]
dmidecode.txt
Comment 2 Ant 2014-10-09 00:44:41 UTC
Created attachment 152991 [details]
result of 'sudo acpidump'
Comment 3 Ant 2014-10-09 00:49:36 UTC
Created attachment 153001 [details]
dmesg | grep acpi
Comment 4 Ant 2014-10-09 01:05:51 UTC
Created attachment 153011 [details]
dsdt.dsl file from acpi dump

using instructions from 
http://alexhungdmz.blogspot.co.uk/2012/05/how-to-dump-acpi-tables-in-ubuntu.html

just incase
Comment 5 Zhang Rui 2014-10-13 02:04:41 UTC
(In reply to untaintableangel from comment #0)
> pnpacpi=off        boots and behaves itself reasonably (currently using this)

what do you get if you boot without any of these boot option?


> 
> /proc/acpi/fan and /proc/acpi/thermal_zone/*/trip_points via 'cat' are both
> empty.
> 
there is no active thermal control on your machine.
BTW, /proc/acpi/fan and /proc/acpi/thermal_zone are both removed years ago, and I don't know why you can still use it with 3.17 kernel.

> Recurring error messages printed:
> dw_dmac INTL9C60:00: invalid resource  (for anything with the power button?)
> 
please attach the full dmesg output with those error messages.

> and the following with the latter acpi debugging parameters:
> "SCI (ACPI GSI 9) not registered"  and
> "i2c_designware 80860F41:02 failure requesting irq 34"
> "i2c_designware 80860F41:05 failure requesting irq 37"

please apply the patch at https://bugzilla.kernel.org/show_bug.cgi?id=84381#c9 and see if it helps.
Comment 6 Ant 2014-10-13 20:32:39 UTC
Thanks for your time,

Trying to boot without any of the parameters gives the same results as
pci=noacpi, noapic and nolapic: just garbled text and then it freezes and won't respond to anything at all, so there's no choice but to just switch it off.
Full dmesg attached after booting (dmesg_full_pnpacpi=off.txt)

also for completeness, i've attached the results of 

ls /sys/bus/acpi/drivers/*/ 
and 
/sys/bus/acpi/devices/*/hid

Having seen a couple of messages suggesting this might be a regression from 3.15+, i also tried the latest 3.14 (3.14.21) from ubuntu's kernelmainline as well as building a custom 3.17 with the patch you linked to.

Results: Some success with patched 3.17.0 kernel! Can actually boot without any of the parameters set now, but still some errors/warnings recorded. (See dmesg_after_patched_kernel.txt)

3.14.21 also boots with no parameters set AND there's no warnings/errors (e.g. nothing related to dw_dmac) at boot. (See dmesg_with_3.14_kernel.txt)

Unfortunately neither kernel seems to completely fix the issue 100%, as it still won't power off properly at shutdown?
I think we're close to narrowing down the issue(s) though!
Comment 7 Ant 2014-10-13 20:33:18 UTC
Created attachment 153571 [details]
full dmesg after booting (pnpacpi=off)
Comment 8 Ant 2014-10-13 20:33:55 UTC
Created attachment 153581 [details]
acpi_devices_hid.txt
Comment 9 Ant 2014-10-13 20:34:26 UTC
Created attachment 153591 [details]
acpi_drivers_list.txt
Comment 10 Ant 2014-10-13 20:35:02 UTC
Created attachment 153601 [details]
dmesg with patched 3.17.0 kernel
Comment 11 Ant 2014-10-13 20:35:32 UTC
Created attachment 153611 [details]
dmesg using kernel 3.14.21
Comment 12 Ant 2014-10-13 20:56:09 UTC
Yes, just to clarify, the system will halt but not poweroff at shutdown. 

Currently having a look at bug reports like (https://bugzilla.kernel.org/show_bug.cgi?id=56931) implicated by this in dmesg logs:

pci 0000:00:1d.0: EHCI: BIOS handoff failed (BIOS bug?) 01010001
Comment 13 Ant 2014-11-23 20:31:19 UTC
Phew!  It's been a long time since i last updated this report, and a lot of testing has happened but everything is at long last fixed.

First of all, i think i should say what an absolute mess the UEFI/Boot settings are in. I discovered that all these acpi problems, errors for the keyboard, hiccups with ehci not behaving and most importantly: the backlight not working despite reconfiguring it and the machine not powering off properly were all caused as a result of a faulty EFI install of ubuntu 14.10 and _i think_ some systemd-logind bug or at the least inherent to a package in ubuntu 14.10 rather than kernel-side. 

When i gave up with 14.10 yesterday and installed 14.04 LTS, there isn't a single problem to be found anywhere; the difference in stability is astounding.

That patch you mentioned for me to try, according to that bug report, was ported upsteam into 3.18rc3 and i've been trying every kernel (both mainline debug and custom made with ehci support disabled etc) during the 3.18 cycle with varying amounts of success but never solving the power problems fully.

I looked into the UEFI settings and found a player in this crime - tried installing ubuntu in legacy and met with exactly all the same problems in this bug report, then tried manually creating EFI partition and switching back to UEFI (which caused LOTS of grey hairs!) which eventually worked but then didn't solve the problems anyway (black screen and random hangs at random unless modesetting was disabled) and there seemed to be underlying systemd errors. Booting successfully was like a 1 in 5 chance.

You'll notice that before in this bug report, i manually set systemd to take over with "init=/lib/systemd/systemd" as this has proven effective and harmless before with 14.04 installations - however, in ubuntu 14.10 by default the system has a bizarre mix of inits with systemd not-quite-in-charge-100% and i suspect it wasn't getting information from a daemon or understanding something. (I wish i hadn't just lost my last dmesg in that reinstall.)

Since october, i've tried a kernel from just about every main version 3.12-3.18rc5 and still met with teething pains over UEFI/Legacy boot and something else (bootloader related?). I'm quite fed up with how easy it is to upset it and will be sticking with ubuntu trusty on my friend's laptop for the foreseeable future.

In short: 
installing ubuntu 14.10 + booting grub-pc (legacy) -> all these acpi problems and needed that patch now in 3.18rc3 just to boot; instability and won't poweroff
installing ubuntu 14.10 + booting grub-efi (EFI) -> ehci behaves itself but the screen is still fickle, if not more, so and loves to keep going black
install ubuntu 14.04 + booting grub-efi (EFI) -> no problems at all, even powers off at shutdown
Comment 14 Ant 2014-11-23 20:33:05 UTC
Created attachment 158631 [details]
dmesg from fresh EFI ubuntu 14.04LTS install

In spite of there still being an entry:

acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM

all is well!
Comment 15 Xing Zhengjun 2014-11-24 02:44:52 UTC
From your test result, it related with ubuntu 14.10 rather than kernel-side.
Have you try other Linux OS (except ubuntu)?

If it is only related with ubuntu 14.10 , maybe you can try ubuntu 14.04LTS with the latest version kernel.
Comment 16 Xing Zhengjun 2015-02-09 06:17:27 UTC
ping...
Comment 17 Zhang Rui 2015-02-15 08:47:52 UTC
bug closed as there is no response from the bug reporter.
please feel free to re-open it if you can provide the information requested.
Comment 18 phartatmisassa 2015-05-12 23:02:19 UTC
Kernel 3.16.30 and 3.16.37

I have been struggling with the same issues, I have switched from Debian 7 to Ubuntu 14.04 to 14.10 to Snappy and back to 14.04.2.

I don't even know where to start, I am not a kernel developer, but it is starting to seem like Microsoft took over recently, or least started "helping" too much.

I just managed to install 14.04.2 by using acpi=no during boot from the disk. At one point while 15 was installed I could only boot into the system in recovery mode and then pop out of that to get a semi functional desktop. I read about the acpi=no thing, tried it, and suddenly I could boot up 100% and shutdown without getting stuck at a black screen and a spinning fan. It reminds me of pulling the cartridge out of a nintendo and trying to keep playing.

So now I am on Windows, because that's the only thing working round here (never in a million years thought I'd say that). I finished installing 14.04.2, it started up fine, I was stoked, then I updated and upgraded it, then rebooted. The damn thing hung and fans started spinning again without a full power down. So I had to press and hold the power button. Next I turned it back on (feel like I am tearing up my PC), and hit f12 and selected ubuntu and grub initiated, then it went to black screen and fans started spinning. Now I can't boot back into Linux anymore, not even with acpi=no.

What info do you need? I will try to get it by booting into rescue mode or trying to boot from dvd. But the last three attempts to boot with acpi=no failed with black screen and spinning fans.
Comment 19 Roman Kurbatov 2015-07-07 22:11:51 UTC
Just installed 14.04.2 64-bit, same note (Acer e5-551). Same error.

dw_dmac INTL9C60:00: invalid resource

"SCI (ACPI GSI 9) not registered"  and
"i2c_designware 80860F41:02 failure requesting irq 34"
"i2c_designware 80860F41:05 failure requesting irq 37"

i2c errors disappeared after I disabled Advanced mode of touchpad (it was something about it uses I2C so better to be disabled on most of systems).

And dw_dmac error disappeared after I set 

modprobe.blacklist=dw_dmac,dw_dmac_core

during boot. I can installed system, though touchpad worked strange (constantly pressing buttons).

After install and upgrade system booted. It was same dw_dmac error, but system booted. It is late, so i'll try to investigate something tomorrow. What info should I provide?
Comment 20 Bjorn Helgaas 2015-07-08 16:19:24 UTC
Reopening because Roman is willing to provide more info.
Comment 21 ivan 2015-08-02 06:05:57 UTC
start the notebook without battery...
comments.
Comment 22 itsik 2015-08-09 20:51:14 UTC
This bug also occurs on Packard Bell EasyNote ENTF71BM.
Ubuntu version 14.04.2 LTS
Newbi to Linux so won't be able to help much.
Installed on the notebook from a memory stick.
Comment 23 Aaron Lu 2015-08-20 08:34:43 UTC
(In reply to Roman Kurbatov from comment #19)
> Just installed 14.04.2 64-bit, same note (Acer e5-551). Same error.

Acer e5-551? The original reporter has e5-511, a typo perhaps?

> 
> dw_dmac INTL9C60:00: invalid resource
> 
> "SCI (ACPI GSI 9) not registered"  and
> "i2c_designware 80860F41:02 failure requesting irq 34"
> "i2c_designware 80860F41:05 failure requesting irq 37"
> 
> i2c errors disappeared after I disabled Advanced mode of touchpad (it was
> something about it uses I2C so better to be disabled on most of systems).

In BIOS setting?

> 
> And dw_dmac error disappeared after I set 
> 
> modprobe.blacklist=dw_dmac,dw_dmac_core
> 
> during boot. I can installed system, though touchpad worked strange
> (constantly pressing buttons).
> 
> After install and upgrade system booted. It was same dw_dmac error, but
> system booted. It is late, so i'll try to investigate something tomorrow.
> What info should I provide?

Except the dw_dmac error message, do you have any problem related to functionality?
Comment 24 Dmytro Kyrychuk 2015-08-20 11:26:29 UTC
I have same `dw_dmac INTL9C60:00: invalid resource` error on Acer Aspire E5-511. I managed to install Linux Mint MATE 17.2 in legacy BIOS mode. LiveUSB won't boot at first, so I selected compatibility mode in LiveUSB boot menu.

When I try to turn laptop on, boot freezes at splash screen. When I select Recovery Mode in grub2 boot menu and then just select "resume" in recovery menu, system almost always boots fine, but sometimes `dw_dmac INTL9C60:00: invalid resource` appears before I even get to recovery menu.

When I try to turn laptop off, the screen just goes dark and fan periodically spins very fast and then slow, then fast, then slow... I have to hold power button to turn laptop off.

Linux Mint MATE 17.2 shipped with Linux Kernel 3.16.0-38 (3.16.7-ckt10). I also installed 3.16.0-45 and 3.19.0-26 via Update Manager > Linux Kernels, but that didn't helped much. First boot with newly installed kernel works fine, but turning off still does not work, and all next boots require to use Recovery Mode.

Linux Mint with 3.19.0-26 boots correctly sometimes (via regular boot, not Recovery Mode).

When boot via Recovery Mode screen brightness cannot be changed with `Fn + left or right arrow keys`. Sound volume can be changed with `Fn + up or down arrow keys`, however.

Please, let me know if I can provide more information.
Comment 25 Aaron Lu 2015-08-21 06:55:45 UTC
Looks like the problem of this bug report is about:
1 some dw_dmac error messages 
2 not able to shutdown
on this Acer Aspire E5-511 laptop.

I guess Andy may know better what is going wrong with dw_dmac, but I don't know his account here, I'll write an email to him.
Comment 26 Andy Shevchenko 2015-08-24 16:41:38 UTC
Please, file the differ(In reply to itsik from comment #22)
> This bug also occurs on Packard Bell EasyNote ENTF71BM.
> Ubuntu version 14.04.2 LTS
> Newbi to Linux so won't be able to help much.
> Installed on the notebook from a memory stick.

Does the blacklisting dw_dmac help?
It did for Dmytro at least (see comment #24).

If your case the same, then I have to reassign the bug to myself.
Comment 27 ALTracer 2015-08-26 08:16:36 UTC
I've successfully installed Linux Mint 17.2 MATE 64 on my Acer Aspire E5-511 laptop for dualboot with OEM Windows 8.1 Home 64 SL (which works fine except dropping wifi after de-hibernation).
The installation media is a 4GB flash stick; burned with Rufus.
I had to play with kernel commandline to boot the liveUSB; probed acpi_backlight='vendor' and nodma. At some point it managed to get past the line

dw_dmac INTL9C60:00: invalid resource
(now without fan spinning crazy each 20sec or so)

ubuntu/grub-efi-x64 added to UEFI, but not present in UEFI boot priority settings. Never ever tried to switch to Legacy mode.
However, to get freshly installed system up and running, I needed to write something into kernel commandline again. 
acpi_backlight='vendor' -- doesn't fix it. 
nodma -- ? Needs testing
Nothing interesting in $dmesg|less.

Cannot poweroff, OS halts (stops responding) and CPU fan starts spinning in squarewave pattern each 20sec so I hold the power button to switch it all off.

Does disabling DMA affect performance or battery life?

btw, on first successful boot into installed system touchpad didn't work. UEFI setting 'Touchpad mode Advanced/Basic' didn't seem to change anything.

I am happy to hand any logs or hardware info at your request.
Comment 28 Andy Shevchenko 2015-08-27 07:59:32 UTC
So, there is a bug #101271 against dw_dmac, I'm removing myself from Cc list here and leave this report for the rest of ACPI issues if any.
Comment 29 Aaron Lu 2015-08-27 08:07:39 UTC
(In reply to ALTracer from comment #27)
> I've successfully installed Linux Mint 17.2 MATE 64 on my Acer Aspire E5-511
> laptop for dualboot with OEM Windows 8.1 Home 64 SL (which works fine except
> dropping wifi after de-hibernation).
> The installation media is a 4GB flash stick; burned with Rufus.
> I had to play with kernel commandline to boot the liveUSB; probed
> acpi_backlight='vendor' and nodma. At some point it managed to get past the
> line
> 
> dw_dmac INTL9C60:00: invalid resource
> (now without fan spinning crazy each 20sec or so)

I guess it is nodma that matters here?

> 
> ubuntu/grub-efi-x64 added to UEFI, but not present in UEFI boot priority
> settings. Never ever tried to switch to Legacy mode.
> However, to get freshly installed system up and running, I needed to write
> something into kernel commandline again. 
> acpi_backlight='vendor' -- doesn't fix it. 
> nodma -- ? Needs testing
> Nothing interesting in $dmesg|less.
> 
> Cannot poweroff, OS halts (stops responding) and CPU fan starts spinning in
> squarewave pattern each 20sec so I hold the power button to switch it all
> off.
> 
> Does disabling DMA affect performance or battery life?

Not sure, I don't know anything about dw_dmac, which is the driver for DesignWare DMA controller.

> 
> btw, on first successful boot into installed system touchpad didn't work.
> UEFI setting 'Touchpad mode Advanced/Basic' didn't seem to change anything.
> 
> I am happy to hand any logs or hardware info at your request.

Since there is a problem with dw_dmac, I think we should wait for that problem fixed and then see if any problems still remained.
Comment 30 alfred.bez 2015-09-16 17:47:55 UTC
(In reply to Xing Zhengjun from comment #15)
> From your test result, it related with ubuntu 14.10 rather than kernel-side.
> Have you try other Linux OS (except ubuntu)?

I have the same issue on Linux Mint 17.2 and Arch, except when I use an old kernel (3.13)

A quick Google Search shows that many distros are related: https://www.google.com/search?q=dw_dmac+INTL9C60%3A00%3A+invalid+resource
Comment 31 Andy Shevchenko 2015-09-24 09:04:26 UTC
Set dependency due to comment #29.
Comment 32 Kevin McCormack 2015-09-25 18:27:31 UTC
I am showing similar issues with my Acer ES1-511-c665. I found stability with the 3.13 kernel on Linux Mint 17 but am unable to boot the 3.16, 3.19, and 4.0 kernels. I am now writing this on 4.2.1-040201-generic installed from Ubuntu mainline. The 3.13 kernel worked well but I could not change my screen brightness. I do do this now with 4.2.1 but it seems to be inverted so that Fn+[Left Arrow] increases brightness but the on scree Cinnamon indicator shows brightness decreasing and vice versa with Fn+[Right Arrow]. Also, when idle, my screen brightens when it should be dimming.
Comment 33 Ethan W. 2015-11-14 00:27:31 UTC
I encountered some of these exact problems on a new Acer Aspire E5-573G. I found a usable workaround here that allowed me to install Ubuntu Gnome 15.10. I still need to mess with BIOS trust settings to get GRUB to load instead of Windows Bootloader but I'm confident I'll find a way. After this downgrade my USB loaded up flawlessly in UEFI mode with secure boot off.

http://community.acer.com/t5/E-and-M-Series/Acer-Aspire-e5-573g-You-can-not-install-any-one-Linux/td-p/386009

===============================
Go to: http://us.acer.com/ac/en/US/content/drivers

 

Search by Product Model:

Aspire E5-573G

 

Select the right OS and download a bios. In my case I downloaded 1.15.

 

Run the ZRT_115.exe.

 

It will fail.

 

But before you close the installer, go to C:\Users\name\AppData\Local\Temp\

Search for a folder (random letters).tmp

There should be a H2OFFT-W.exe and zrt.rd file in there.

Just copy this folder and close the failing install.

 

In that copied folder, edit the platform.ini file.

 

Before:

 

[BIOSVersionFormat]
;[nb4-version] +
BIOSVFEnable=1
VersionFormat=XN.NN

 

After:

 

[BIOSVersionFormat]
;[nb4-version] +
BIOSVFEnable=1
VersionFormat=XN.DD

 

The VersionFormat value now has 'XN.DD' instead of 'XN.NN'.

 

This will ignore the fact that 1.25 -> 1.15 is a downgrade.

 

Prepare for a reboot. I.E. close unnecessary applications. Because it'll happen automatically after running the installer.

 

Run H2OFFT-W.exe.

 

Upon reboot, you'll see a bios installing progress bar.

 

After that is done, press F2 during startup to get to bios. The version should now be 1.15."
Comment 34 evildarknight 2015-12-15 06:32:42 UTC
ubuntu 14.04 lts does install on the acer aspire e15 e5-511 with legacy mode 
blacklisting dw_dmac,dw_dmac_core eberything works fine
this solution does not work on ubuntu 15.10
the laptop freezes still randomly...
Comment 35 96greenmachine 2015-12-22 06:30:31 UTC
I had the same problem with my Acer Aspire E15 (E5-511-P01P) after installing Linux. Everytime on shut down or reboot and sometimes on startup it would freeze/hang. Seem to have fixed the problem like this... 

open a terminal and write 'sudo nano /etc/default/grub', go to the line where it says 'GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"' and change it to 'GRUB_CMDLINE_LINUX_DEFAULT="quiet splash modprobe.blacklist=dw_dmac,dw_dmac_core"'. On your keyboard press 'Control + X', then 'Y' and 'Enter' to save and exit. Now write 'sudo update-grub' in the terminal.

Hopefully this helps...
Comment 36 Libor Chmelik 2015-12-27 08:14:16 UTC
I had the same problem on my Acer Aspire E15 (E5-511-P7AT). I'm on Mint 17.3 Mate 64bit, kernel 3.19.0-28 from ubuntu 14.04 LTS. 

Everytime on Shut Down or Reboot came a black screen and the fan started spinning like crazy every +-20 seconds, but the machine didn't shut down or reboot.

Since blacklisting dw_dmac and dw_dmac_core, Shut Down and reboot work flawlessly.

The question now is, which impact will the blacklisting have on the performance of the machine ?
Comment 37 Aaron Lu 2015-12-28 02:30:28 UTC
The fix for dw_dmac will arrive in kernel v4.5 according to:
https://bugzilla.kernel.org/show_bug.cgi?id=101271#c8
Please test v4.5-rc1 when it's out, thanks.
Comment 38 Erlington Espinoza Cardoza 2016-01-01 21:32:39 UTC
Created attachment 198581 [details]
Logs after system hangs Kernel 4.3

Logs recorded for a compete view.
Comment 39 Erlington Espinoza Cardoza 2016-01-01 21:33:10 UTC
Created attachment 198591 [details]
Logs after system hangs Kernel 4.3.3
Comment 40 Zhang Rui 2016-03-15 05:48:19 UTC
has anyone tried 4.5?
does the problem still exist?
Comment 41 96greenmachine 2016-03-15 07:03:40 UTC
(In reply to Zhang Rui from comment #40)
> has anyone tried 4.5?
> does the problem still exist?

I've tried 3.19 up to 4.4 and still had issues and using the same work around as above. Will try it tonight and see how I get on. Update shortly.
Comment 42 96greenmachine 2016-03-15 07:03:56 UTC
(In reply to Zhang Rui from comment #40)
> has anyone tried 4.5?
> does the problem still exist?

I've tried 3.19 up to 4.4 and still had issues and using the same work around as above. Will try it tonight and see how I get on. Update shortly.
Comment 43 96greenmachine 2016-03-15 07:25:48 UTC
Currently running Linux Mint 17.3 (XFCE) on the Acer Aspire E5-511-PO1P laptop. Removed the work around above. Changed 'GRUB_CMDLINE_LINUX_DEFAULT="quiet splash modprobe.blacklist=dw_dmac,dw_dmac_core" back to "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" which was the original. Just upgraded the kernel from default 3.19 to 4.5 and have now rebooted the laptop 5 times with no issues so far. Seems the issue may of been fixed. Hope this helps.
Comment 44 96greenmachine 2016-03-15 07:27:17 UTC
(In reply to 96greenmachine from comment #42)
> (In reply to Zhang Rui from comment #40)
> > has anyone tried 4.5?
> > does the problem still exist?
> 
> I've tried 3.19 up to 4.4 and still had issues and using the same work
> around as above. Will try it tonight and see how I get on. Update shortly.

Update: Just finished upgrading kernel to 4.5 and rebooted 5 times all working well for now. Seems it may of been fixed.
Comment 45 Zhang Rui 2016-03-15 07:54:12 UTC
Great.

Bug closed. Please feel free to reopen it if the problem can be reproduced again.
Comment 46 Libor Chmelik 2016-03-15 20:42:52 UTC
Confirmed.

Upgraded to kernel 4.5. Removed "modprobe.blacklist=dw_dmac,dw_dmac_core" and Shut Down as well as Reboot work well on my Acer Aspire E15 (E5-511-P7AT).

Seems to be fixed.
Comment 47 Erlington Espinoza Cardoza 2016-03-16 01:52:21 UTC
Created attachment 209391 [details]
attachment-15067-0.html

Same here, but my laptop still freezes randomly and the fans start to sound
loudly. Many improvement on ACPI thought.

2016-03-15 14:42 GMT-06:00 <bugzilla-daemon@bugzilla.kernel.org>:

> https://bugzilla.kernel.org/show_bug.cgi?id=85931
>
> --- Comment #46 from Libor Chmelik <libor.chmelik@gmail.com> ---
> Confirmed.
>
> Upgraded to kernel 4.5. Removed "modprobe.blacklist=dw_dmac,dw_dmac_core"
> and
> Shut Down as well as Reboot work well on my Acer Aspire E15 (E5-511-P7AT).
>
> Seems to be fixed.
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
>
Comment 48 96greenmachine 2016-03-16 02:13:59 UTC
(In reply to Erlington Espinoza Cardoza from comment #47)
> Created attachment 209391 [details]
> attachment-15067-0.html
> 
> Same here, but my laptop still freezes randomly and the fans start to sound
> loudly. Many improvement on ACPI thought.
> 
> 2016-03-15 14:42 GMT-06:00 <bugzilla-daemon@bugzilla.kernel.org>:
> 
> > https://bugzilla.kernel.org/show_bug.cgi?id=85931
> >
> > --- Comment #46 from Libor Chmelik <libor.chmelik@gmail.com> ---
> > Confirmed.
> >
> > Upgraded to kernel 4.5. Removed "modprobe.blacklist=dw_dmac,dw_dmac_core"
> > and
> > Shut Down as well as Reboot work well on my Acer Aspire E15 (E5-511-P7AT).
> >
> > Seems to be fixed.
> >
> > --
> > You are receiving this mail because:
> > You are on the CC list for the bug.
> >

Erlington Espinoza Cardoza, What model laptop? After updating kernel last night to 4.5 it seems to have fixed reboot issues etc.. but i still do have issue with it randomly crashing and fans spinning loudly etc.. I have had multiple linux distros, windows 8.1 and windows 10 installed on mine and it seems to make no difference when it comes to it crashing randomly (Except Fedora, for some reason that was almost unusable with how often it crashed). I own 2x Acer E5-511-PO1P, one is shocking for crashing and the other has just started the same issue but not as often. Also own Acer ES1-411-C1WD, this one does not seem to crash but is slow as anything. Slowly coming to the conclusion that Acer laptops are rubbish... What do others think? Or has anyone else experienced the random crashing and found a fix?
Comment 49 Erlington Espinoza Cardoza 2016-03-16 03:31:43 UTC
(In reply to 96greenmachine from comment #48)
> (In reply to Erlington Espinoza Cardoza from comment #47)
> > Created attachment 209391 [details]
> > attachment-15067-0.html
> > 
> > Same here, but my laptop still freezes randomly and the fans start to sound
> > loudly. Many improvement on ACPI thought.
> > 
> > 2016-03-15 14:42 GMT-06:00 <bugzilla-daemon@bugzilla.kernel.org>:
> > 
> > > https://bugzilla.kernel.org/show_bug.cgi?id=85931
> > >
> > > --- Comment #46 from Libor Chmelik <libor.chmelik@gmail.com> ---
> > > Confirmed.
> > >
> > > Upgraded to kernel 4.5. Removed "modprobe.blacklist=dw_dmac,dw_dmac_core"
> > > and
> > > Shut Down as well as Reboot work well on my Acer Aspire E15
> (E5-511-P7AT).
> > >
> > > Seems to be fixed.
> > >
> > > --
> > > You are receiving this mail because:
> > > You are on the CC list for the bug.
> > >
> 
> Erlington Espinoza Cardoza, What model laptop? After updating kernel last
> night to 4.5 it seems to have fixed reboot issues etc.. but i still do have
> issue with it randomly crashing and fans spinning loudly etc.. I have had
> multiple linux distros, windows 8.1 and windows 10 installed on mine and it
> seems to make no difference when it comes to it crashing randomly (Except
> Fedora, for some reason that was almost unusable with how often it crashed).
> I own 2x Acer E5-511-PO1P, one is shocking for crashing and the other has
> just started the same issue but not as often. Also own Acer ES1-411-C1WD,
> this one does not seem to crash but is slow as anything. Slowly coming to
> the conclusion that Acer laptops are rubbish... What do others think? Or has
> anyone else experienced the random crashing and found a fix?

It is an Acer E5-511-P0GC, Kernel 3.16 is the only one I can use this computer without troubles by black listing dw_dmac and dw_dmac_core. I run Linux Mint 17 most of the time.
Comment 50 Andy Shevchenko 2016-03-16 10:18:09 UTC
About reboot (modprobe.blacklist=dw_dmac,dw_dmac_core) issue refer to bug #101271 as mentioned in the header of this bug.
Comment 51 Libor Chmelik 2016-03-16 13:19:44 UTC
(In reply to Erlington Espinoza Cardoza from comment #49)
> (In reply to 96greenmachine from comment #48)

> > > Same here, but my laptop still freezes randomly and the fans start to
> sound
> > > loudly. Many improvement on ACPI thought.
> > > 

> > Erlington Espinoza Cardoza, What model laptop? After updating kernel last
> > night to 4.5 it seems to have fixed reboot issues etc.. but i still do have
> > issue with it randomly crashing and fans spinning loudly etc..
> > anyone else experienced the random crashing and found a fix?

Confirmed.

Kernel 4.5. fixes the shutdown/reboot problem.

But my Acer Aspire E15 (E5-511-P7AT) also still freezes randomly and the fan(s) start to spin loudly. A hard reboot is the only option then.
Comment 52 Andy Shevchenko 2016-04-10 13:56:31 UTC
Random freezes issue is being discussed in bug #109051

Note You need to log in before you can comment on or make changes to this bug.