Bug 8574 - OOPS performing ioctl
OOPS performing ioctl
Status: RESOLVED DUPLICATE of bug 8473
Product: File System
Classification: Unclassified
Component: Other
i386 Linux
: P2 normal
Assigned To: Alexey Dobriyan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-03 11:58 UTC by Peter Clifton
Modified: 2008-09-08 22:41 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.22-5-generic (From Ubuntu Gutsy)
Tree: Mainline
Regression: ---


Attachments
dmesg output showing the Oops (twice) (85.27 KB, text/plain)
2007-06-03 12:00 UTC, Peter Clifton
Details

Description Peter Clifton 2007-06-03 11:58:08 UTC
Most recent kernel where this bug did *NOT* occur:
Unknown, never noticed it in 2.6.20-15-generic (Ubuntu)

Distribution:
Ubuntu

Hardware Environment
HP Compaq nc6320

Software Environment:
Gnome

Problem Description:
Kernel oops in dmesg:


Steps to reproduce:
Unknown

Other stuff:

As it looks filesystem related, the output of mount:

/dev/sda2 on / type ext3 (rw,errors=remount-ro,commit=600)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.22-5-generic/volatile type tmpfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
Comment 1 Peter Clifton 2007-06-03 12:00:22 UTC
Created attachment 11651 [details]
dmesg output showing the Oops (twice)
Comment 2 Randy Dunlap 2007-06-03 13:33:30 UTC
Similar to http://bugzilla.kernel.org/show_bug.cgi?id=8473 .

Can you try Andrew's debug patch (at this URL):
http://marc.info/?l=linux-mm-commits&m=118077338207970&w=2
Comment 3 Peter Clifton 2007-06-04 09:35:57 UTC
So far I've not been able to reproduce that Oops, or get any output from the
debug patch.

I'd been poking about a bit with lshw and gnome-session, (flicking between
console and X11 quite a bit) when it occurred before, and have not seen it since.
Comment 4 Alex Riesen 2007-06-10 14:18:14 UTC
I had the Akpm's patch (and since 2.6.22-rc3 there is some diagnostic with a
stack dump there). Haven't seen the bug since the -rc3.
Comment 5 Alexey Dobriyan 2008-09-08 22:41:41 UTC
I remember exactly same backtrace and it was flipping tty fops.


*** This bug has been marked as a duplicate of bug 8473 ***

Note You need to log in before you can comment on or make changes to this bug.