Bug 8565 - panic on s3 resume with uhci_hcd module
panic on s3 resume with uhci_hcd module
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2007-06-01 14:12 UTC by Simon
Modified: 2007-06-16 05:03 UTC (History)
0 users

See Also:
Kernel Version: 2.6.22.rc3 / git 2007-06-01
Tree: Mainline
Regression: ---


Attachments

Description Simon 2007-06-01 14:12:03 UTC
Most recent kernel where this bug did *NOT* occur: FC6 2.6.20 kernels / 2.6.21.3 
Distribution: Fedora 7
Hardware Environment: Dell Inspiron 8500
Software Environment:
Problem Description: I have just done a clean install of fedora 7 on my machine,
replacing Fedora Core 6.
When I resume my machine from suspend, it panics. My display is not
reiinitialised, so using /sys/power/pm_trace I identified that the device is the
following;

00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 03)

With the current fedora kernel (kernel-2.6.21-1.3194.fc7) I see the following
backtrace on bootup:

Jun  1 09:00:39 echo kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA]
-> GSI 11 (level, low) -> IRQ 11
Jun  1 09:00:39 echo kernel: BUG: warning at
kernel/softirq.c:138/local_bh_enable() (Not tainted) 
Jun  1 09:00:39 echo kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
Jun  1 09:00:39 echo kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
Jun  1 09:00:39 echo kernel:  [<c059adf3>] release_sock+0x4f/0x9d
Jun  1 09:00:39 echo kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
Jun  1 09:00:39 echo kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
Jun  1 09:00:39 echo kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
Jun  1 09:00:39 echo kernel:  [<c04754ee>] do_sync_write+0xc7/0x10a
Jun  1 09:00:39 echo kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
Jun  1 09:00:39 echo kernel:  [<c0475d47>] vfs_write+0xbc/0x154
Jun  1 09:00:39 echo kernel:  [<c0476342>] sys_write+0x41/0x67
Jun  1 09:00:39 echo kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jun  1 09:00:39 echo kernel:  [<c0600000>] __sched_text_start+0x6e8/0x89e
Jun  1 09:00:39 echo kernel:  =======================

I have since pulled Linus' git linux-2.6 tree (version no was 2.6.22-rc3). I
built this using the default config options. In this version I still get the
kernel panic, but I do not see the backtrace during bootup.

Removing the uhci_hcd module allows the machine to resume without panic'ing.

Last weekend I was testing the 2.6.21.3 kernel on my fc6 install and this did
not panic, although exactly what options I used have been lost due to  the f7
install.
Comment 1 Anonymous Emailer 2007-06-01 15:16:46 UTC
Reply-To: akpm@linux-foundation.org

On Fri, 1 Jun 2007 14:08:37 -0700
bugme-daemon@bugzilla.kernel.org wrote:
>

Please follow up via emailed reply-to-all, rather than via the bugzilla web
interface, thanks.

Michal, please track this as a post-2.6.21 regression.

> http://bugzilla.kernel.org/show_bug.cgi?id=8565
> 
>            Summary: panic on s3 resume with uhci_hcd module
>     Kernel Version: 2.6.22.rc3 / git 2007-06-01
>             Status: NEW
>           Severity: normal
>              Owner: greg@kroah.com
>          Submitter: sg02r@ecs.soton.ac.uk
> 
> 
> Most recent kernel where this bug did *NOT* occur: FC6 2.6.20 kernels / 2.6.21.3 
> Distribution: Fedora 7
> Hardware Environment: Dell Inspiron 8500
> Software Environment:
> Problem Description: I have just done a clean install of fedora 7 on my machine,
> replacing Fedora Core 6.
> When I resume my machine from suspend, it panics. My display is not
> reiinitialised, so using /sys/power/pm_trace I identified that the device is the
> following;
> 
> 00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
> USB UHCI Controller #1 (rev 03)
> 
> With the current fedora kernel (kernel-2.6.21-1.3194.fc7) I see the following
> backtrace on bootup:
> 
> Jun  1 09:00:39 echo kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA]
> -> GSI 11 (level, low) -> IRQ 11
> Jun  1 09:00:39 echo kernel: BUG: warning at
> kernel/softirq.c:138/local_bh_enable() (Not tainted) 
> Jun  1 09:00:39 echo kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
> Jun  1 09:00:39 echo kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
> Jun  1 09:00:39 echo kernel:  [<c059adf3>] release_sock+0x4f/0x9d
> Jun  1 09:00:39 echo kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
> Jun  1 09:00:39 echo kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
> Jun  1 09:00:39 echo kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
> Jun  1 09:00:39 echo kernel:  [<c04754ee>] do_sync_write+0xc7/0x10a
> Jun  1 09:00:39 echo kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
> Jun  1 09:00:39 echo kernel:  [<c0475d47>] vfs_write+0xbc/0x154
> Jun  1 09:00:39 echo kernel:  [<c0476342>] sys_write+0x41/0x67
> Jun  1 09:00:39 echo kernel:  [<c0404f70>] syscall_call+0x7/0xb
> Jun  1 09:00:39 echo kernel:  [<c0600000>] __sched_text_start+0x6e8/0x89e
> Jun  1 09:00:39 echo kernel:  =======================

I wouldn't worry about this warning.  There was a busted Ingo patch whcih
later got fixed - I suspect it leaked into this Fedora release and it
hasn't got fixed yet.


> I have since pulled Linus' git linux-2.6 tree (version no was 2.6.22-rc3). I
> built this using the default config options. In this version I still get the
> kernel panic, but I do not see the backtrace during bootup.
> 
> Removing the uhci_hcd module allows the machine to resume without panic'ing.
> 
> Last weekend I was testing the 2.6.21.3 kernel on my fc6 install and this did
> not panic, although exactly what options I used have been lost due to  the f7
> install.
> 


I don't understand what you mean by "the machine panics".  Does it oops? 
Does it call panic()?  If so, how do you know this, if your only means of
debugging it was pm_trace?  I mean, it could be that the machine was
hanging during uhci resume rather than oopsing or panicing?


Anyway, it might be worth setting up netconsole
(Documentation/networking/netconsole.txt) to see if you can get more
information out of the machine.

Sometimes netconsole doesn't work very well across suspend/resume, because
the net device itself gets suspended too.  But often it emits useful info.

Thanks.

Comment 2 Rafael J. Wysocki 2007-06-01 15:25:54 UTC
On Saturday, 2 June 2007 00:12, Andrew Morton wrote:
> On Fri, 1 Jun 2007 14:08:37 -0700
> bugme-daemon@bugzilla.kernel.org wrote:
> >
> 
> Please follow up via emailed reply-to-all, rather than via the bugzilla web
> interface, thanks.
> 
> Michal, please track this as a post-2.6.21 regression.
> 
> > http://bugzilla.kernel.org/show_bug.cgi?id=8565
> > 
> >            Summary: panic on s3 resume with uhci_hcd module
> >     Kernel Version: 2.6.22.rc3 / git 2007-06-01
> >             Status: NEW
> >           Severity: normal
> >              Owner: greg@kroah.com
> >          Submitter: sg02r@ecs.soton.ac.uk
> > 
> > 
> > Most recent kernel where this bug did *NOT* occur: FC6 2.6.20 kernels / 2.6.21.3 
> > Distribution: Fedora 7
> > Hardware Environment: Dell Inspiron 8500
> > Software Environment:
> > Problem Description: I have just done a clean install of fedora 7 on my machine,
> > replacing Fedora Core 6.
> > When I resume my machine from suspend, it panics. My display is not
> > reiinitialised, so using /sys/power/pm_trace I identified that the device is the
> > following;
> > 
> > 00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
> > USB UHCI Controller #1 (rev 03)
> > 
> > With the current fedora kernel (kernel-2.6.21-1.3194.fc7) I see the following
> > backtrace on bootup:
> > 
> > Jun  1 09:00:39 echo kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA]
> > -> GSI 11 (level, low) -> IRQ 11
> > Jun  1 09:00:39 echo kernel: BUG: warning at
> > kernel/softirq.c:138/local_bh_enable() (Not tainted) 
> > Jun  1 09:00:39 echo kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
> > Jun  1 09:00:39 echo kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
> > Jun  1 09:00:39 echo kernel:  [<c059adf3>] release_sock+0x4f/0x9d
> > Jun  1 09:00:39 echo kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
> > Jun  1 09:00:39 echo kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
> > Jun  1 09:00:39 echo kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
> > Jun  1 09:00:39 echo kernel:  [<c04754ee>] do_sync_write+0xc7/0x10a
> > Jun  1 09:00:39 echo kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
> > Jun  1 09:00:39 echo kernel:  [<c0475d47>] vfs_write+0xbc/0x154
> > Jun  1 09:00:39 echo kernel:  [<c0476342>] sys_write+0x41/0x67
> > Jun  1 09:00:39 echo kernel:  [<c0404f70>] syscall_call+0x7/0xb
> > Jun  1 09:00:39 echo kernel:  [<c0600000>] __sched_text_start+0x6e8/0x89e
> > Jun  1 09:00:39 echo kernel:  =======================
> 
> I wouldn't worry about this warning.  There was a busted Ingo patch whcih
> later got fixed - I suspect it leaked into this Fedora release and it
> hasn't got fixed yet.
> 
> 
> > I have since pulled Linus' git linux-2.6 tree (version no was 2.6.22-rc3). I
> > built this using the default config options. In this version I still get the
> > kernel panic, but I do not see the backtrace during bootup.
> > 
> > Removing the uhci_hcd module allows the machine to resume without panic'ing.

Hmm, strange.  I have at least one test box with uhci_hcd that suspends
(to RAM) and resumes successfully.

Still, I've tested it with the hibernation and suspend patchset applied only.

Simon, can you test 2.6.22-rc3 with the patches from

http://www.sisk.pl/kernel/hibernation_and_suspend/2.6.22-rc3/patches/

applied?

Greetings,
Rafael

Comment 3 Simon 2007-06-02 03:47:06 UTC

Andrew Morton wrote:
> On Fri, 1 Jun 2007 14:08:37 -0700
> bugme-daemon@bugzilla.kernel.org wrote:
> 
> Please follow up via emailed reply-to-all, rather than via the bugzilla web
> interface, thanks.
> 
> Michal, please track this as a post-2.6.21 regression.
> 
>> http://bugzilla.kernel.org/show_bug.cgi?id=8565
>>
>>            Summary: panic on s3 resume with uhci_hcd module
>>     Kernel Version: 2.6.22.rc3 / git 2007-06-01
>>             Status: NEW
>>           Severity: normal
>>              Owner: greg@kroah.com
>>          Submitter: sg02r@ecs.soton.ac.uk
>>
>>
>> Most recent kernel where this bug did *NOT* occur: FC6 2.6.20 kernels / 2.6.21.3 
>> Distribution: Fedora 7
>> Hardware Environment: Dell Inspiron 8500
>> Software Environment:
>> Problem Description: I have just done a clean install of fedora 7 on my machine,
>> replacing Fedora Core 6.
>> When I resume my machine from suspend, it panics. My display is not
>> reiinitialised, so using /sys/power/pm_trace I identified that the device is the
>> following;
>>
>> 00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
>> USB UHCI Controller #1 (rev 03)
>>
>> With the current fedora kernel (kernel-2.6.21-1.3194.fc7) I see the following
>> backtrace on bootup:
>>
>> Jun  1 09:00:39 echo kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA]
>> -> GSI 11 (level, low) -> IRQ 11
>> Jun  1 09:00:39 echo kernel: BUG: warning at
>> kernel/softirq.c:138/local_bh_enable() (Not tainted) 
>> Jun  1 09:00:39 echo kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
>> Jun  1 09:00:39 echo kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
>> Jun  1 09:00:39 echo kernel:  [<c059adf3>] release_sock+0x4f/0x9d
>> Jun  1 09:00:39 echo kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
>> Jun  1 09:00:39 echo kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
>> Jun  1 09:00:39 echo kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
>> Jun  1 09:00:39 echo kernel:  [<c04754ee>] do_sync_write+0xc7/0x10a
>> Jun  1 09:00:39 echo kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
>> Jun  1 09:00:39 echo kernel:  [<c0475d47>] vfs_write+0xbc/0x154
>> Jun  1 09:00:39 echo kernel:  [<c0476342>] sys_write+0x41/0x67
>> Jun  1 09:00:39 echo kernel:  [<c0404f70>] syscall_call+0x7/0xb
>> Jun  1 09:00:39 echo kernel:  [<c0600000>] __sched_text_start+0x6e8/0x89e
>> Jun  1 09:00:39 echo kernel:  =======================
> 
> I wouldn't worry about this warning.  There was a busted Ingo patch whcih
> later got fixed - I suspect it leaked into this Fedora release and it
> hasn't got fixed yet.
> 
> 
>> I have since pulled Linus' git linux-2.6 tree (version no was 2.6.22-rc3). I
>> built this using the default config options. In this version I still get the
>> kernel panic, but I do not see the backtrace during bootup.
>>
>> Removing the uhci_hcd module allows the machine to resume without panic'ing.
>>
>> Last weekend I was testing the 2.6.21.3 kernel on my fc6 install and this did
>> not panic, although exactly what options I used have been lost due to  the f7
>> install.
>>
> 
> 
> I don't understand what you mean by "the machine panics".  Does it oops? 
> Does it call panic()?  If so, how do you know this, if your only means of
> debugging it was pm_trace?  I mean, it could be that the machine was
> hanging during uhci resume rather than oopsing or panicing?

My caps-lock and scroll-lock lights started flashing almost immediately. 
Sys-Rq + B still works to reboot.

> 
> 
> Anyway, it might be worth setting up netconsole
> (Documentation/networking/netconsole.txt) to see if you can get more
> information out of the machine.
> 
> Sometimes netconsole doesn't work very well across suspend/resume, because
> the net device itself gets suspended too.  But often it emits useful info.
> 
> Thanks.
I'll give it a go.

Simon

Comment 4 Michal Piotrowski 2007-06-02 04:38:53 UTC
Please read "Collecting kernel messages"

http://kernelnewbies.org/Linux_Kernel_Tester's_Guide_Chapter3
Comment 5 Simon 2007-06-06 06:17:03 UTC
Testing with a serial console came up blank. I guess the consoles are 
still suspended at this stage.

I've tried using git bisect, but I have ended up with a list of sparc 
patches. I guess I should try again with a full kernel rebuild at each 
stage. Shame it takes about 3 hours.

I did discover that my port replicator somehow causes my display to 
re-init on resume and it gets as far as diplaying the yellow "Linu" message.

Simon

bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=8565
> 
> 
> 
> 
> 
> ------- Additional Comments From michal.k.k.piotrowski@gmail.com  2007-06-02 04:38 -------
> Please read "Collecting kernel messages"
> 
> http://kernelnewbies.org/Linux_Kernel_Tester's_Guide_Chapter3
> 
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.

Comment 6 Simon 2007-06-08 00:58:02 UTC

bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=8565
> 
> 
> 
> 
> 
> ------- Additional Comments From rjw@sisk.pl  2007-06-01 15:25 -------
> On Saturday, 2 June 2007 00:12, Andrew Morton wrote:
>> On Fri, 1 Jun 2007 14:08:37 -0700
>> bugme-daemon@bugzilla.kernel.org wrote:
>> Please follow up via emailed reply-to-all, rather than via the bugzilla web
>> interface, thanks.
>>
>> Michal, please track this as a post-2.6.21 regression.
>>
>>> http://bugzilla.kernel.org/show_bug.cgi?id=8565
>>>
>>>            Summary: panic on s3 resume with uhci_hcd module
>>>     Kernel Version: 2.6.22.rc3 / git 2007-06-01
>>>             Status: NEW
>>>           Severity: normal
>>>              Owner: greg@kroah.com
>>>          Submitter: sg02r@ecs.soton.ac.uk
>>>
>>>
>>> Most recent kernel where this bug did *NOT* occur: FC6 2.6.20 kernels / 2.6.21.3 
>>> Distribution: Fedora 7
>>> Hardware Environment: Dell Inspiron 8500
>>> Software Environment:
>>> Problem Description: I have just done a clean install of fedora 7 on my machine,
>>> replacing Fedora Core 6.
>>> When I resume my machine from suspend, it panics. My display is not
>>> reiinitialised, so using /sys/power/pm_trace I identified that the device is the
>>> following;
>>>
>>> 00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
>>> USB UHCI Controller #1 (rev 03)
>>>
>>> With the current fedora kernel (kernel-2.6.21-1.3194.fc7) I see the following
>>> backtrace on bootup:
>>>
>>> Jun  1 09:00:39 echo kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA]
>>> -> GSI 11 (level, low) -> IRQ 11
>>> Jun  1 09:00:39 echo kernel: BUG: warning at
>>> kernel/softirq.c:138/local_bh_enable() (Not tainted) 
>>> Jun  1 09:00:39 echo kernel:  [<c042b0cf>] local_bh_enable+0x45/0x92
>>> Jun  1 09:00:39 echo kernel:  [<c06002bd>] cond_resched_softirq+0x2c/0x42
>>> Jun  1 09:00:39 echo kernel:  [<c059adf3>] release_sock+0x4f/0x9d
>>> Jun  1 09:00:39 echo kernel:  [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
>>> Jun  1 09:00:39 echo kernel:  [<c05dec95>] inet_sendmsg+0x3b/0x45
>>> Jun  1 09:00:39 echo kernel:  [<c0598731>] sock_aio_write+0xf6/0x102
>>> Jun  1 09:00:39 echo kernel:  [<c04754ee>] do_sync_write+0xc7/0x10a
>>> Jun  1 09:00:39 echo kernel:  [<c0436e71>] autoremove_wake_function+0x0/0x35
>>> Jun  1 09:00:39 echo kernel:  [<c0475d47>] vfs_write+0xbc/0x154
>>> Jun  1 09:00:39 echo kernel:  [<c0476342>] sys_write+0x41/0x67
>>> Jun  1 09:00:39 echo kernel:  [<c0404f70>] syscall_call+0x7/0xb
>>> Jun  1 09:00:39 echo kernel:  [<c0600000>] __sched_text_start+0x6e8/0x89e
>>> Jun  1 09:00:39 echo kernel:  =======================
>> I wouldn't worry about this warning.  There was a busted Ingo patch whcih
>> later got fixed - I suspect it leaked into this Fedora release and it
>> hasn't got fixed yet.
>>
>>
>>> I have since pulled Linus' git linux-2.6 tree (version no was 2.6.22-rc3). I
>>> built this using the default config options. In this version I still get the
>>> kernel panic, but I do not see the backtrace during bootup.
>>>
>>> Removing the uhci_hcd module allows the machine to resume without panic'ing.
> 
> Hmm, strange.  I have at least one test box with uhci_hcd that suspends
> (to RAM) and resumes successfully.
> 
> Still, I've tested it with the hibernation and suspend patchset applied only.
> 
> Simon, can you test 2.6.22-rc3 with the patches from
> 
> http://www.sisk.pl/kernel/hibernation_and_suspend/2.6.22-rc3/patches/
> 
> applied?
> 
> Greetings,
> Rafael
> 
Patch 21-firewire-implement-suspend-resume-hooks.patch seems to resolve 
this issue.

Thanks,
	Simon
> 
> 
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.

Comment 7 Rafael J. Wysocki 2007-06-13 09:32:51 UTC
The patch firewire-implement-suspend-resume-hooks.patch is in 2.6.22-rc4, so I think that this bug can be closed.

Comment 8 Rafael J. Wysocki 2007-06-16 05:03:29 UTC
Fixed in 2.6.22-rc4, closing.

Please reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.