Bug 8493 - 2.6.21 regression - BAT0 no longer seen, Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_.BATS] - ASUSTek M6NE
2.6.21 regression - BAT0 no longer seen, Method parse/execution failed [\_SB_...
Status: CLOSED DUPLICATE of bug 8598
Product: ACPI
Classification: Unclassified
Component: Power-Battery
i386 Linux
: P2 normal
Assigned To: acpi_power-battery
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-17 10:36 UTC by Ben Collins
Modified: 2008-01-12 16:05 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.22-rc1
Tree: Mainline
Regression: ---


Attachments
DSDT from machine (211.37 KB, text/plain)
2007-05-17 10:43 UTC, Ben Collins
Details
acpidump (118.64 KB, text/plain)
2007-06-26 08:47 UTC, Nicolo' Chieffo
Details

Description Ben Collins 2007-05-17 10:36:28 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20
Distribution: Ubuntu
Hardware Environment: ASUSTek M6NE
Software Environment:
Problem Description: BAT0 no longer processed due to ACPI errors

Steps to reproduce: Boot on this model system:

ACPI Error (psparse-0537): Method parse/execution failed
[\_SB_.PCI0.SBRG.EC0_.BATS] (Node c147bf18), AE_NOT_EXIST
ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.BAT0._STA] (Node
c14783c4), AE_NOT_EXIST
Comment 1 Ben Collins 2007-05-17 10:39:25 UTC
Original bug report: https://launchpad.net/bugs/115029
Comment 2 Ben Collins 2007-05-17 10:43:19 UTC
Created attachment 11527 [details]
DSDT from machine

iasl doesn't report anything weird with this when recompiling, so assuming this
is a kernel bug rather than buggy BIOS.
Comment 3 Nicolo' Chieffo 2007-05-17 10:54:44 UTC
also because battery is detected in kernel 2.6.20
Comment 4 Thomas Schwarzgruber 2007-05-21 06:49:30 UTC
Hello !
I'm the submitter of Bug: http://bugzilla.kernel.org/show_bug.cgi?id=8477
which seems to be very similar. Could you perhaps check if it's the same bug ?
I also remember that in earlier Kernel versions I had to patch the kernel because of a 
broken dsdt on my machine (I use an Asus M6N). Later on this patch wasn't necessary, 
and I seem to have deleted it. Perhaps there was a change from 2.6.20 to 2.6.21 in that 
respect.
Comment 5 Nicolo' Chieffo 2007-05-21 07:18:45 UTC
yes, it is the same bug. the problem is definitely not the one you are telling,
because I have a bios which fixes that problem
Comment 6 Thomas Schwarzgruber 2007-05-21 07:24:20 UTC
Great ! Than I have not to worry finding that patch again ...
Comment 7 Nicolo' Chieffo 2007-06-01 03:41:16 UTC
this also happen in fedora 7 with kernel 2.6.21!
Comment 8 Len Brown 2007-06-05 12:00:48 UTC
> [\_SB_.PCI0.SBRG.EC0_.BATS]

Curious, \_SB_.BAT0._STA
accesses BATS through and Alias:

Alias (\_SB.PCI0.SBRG.EC0.BATS, BATS)

I wonder why the error message is printed EC0_ instead of EC0

Please attach the complete un-processed output from acpidump
Comment 9 Ben Collins 2007-06-05 12:16:46 UTC
Could you send requests to the actual submitter via
https://launchpad.net/bugs/115029

I've linked this bug in that bug report.

Thanks
Comment 10 Nicolo' Chieffo 2007-06-05 13:29:13 UTC
I'm the actual submitter don't worry
Comment 11 Zhang Rui 2007-06-13 20:46:00 UTC
Please try the patch in comment#9 bug8598.
Comment 12 Nicolo' Chieffo 2007-06-26 08:45:06 UTC
Will this patch be included if it works?
Comment 13 Nicolo' Chieffo 2007-06-26 08:47:40 UTC
Created attachment 11885 [details]
acpidump
Comment 14 Borislav Petkov 2007-06-30 06:32:51 UTC
I can confirm that I had the same regression with my machine, ASUS M6B00N, and after applying the patch, the battery shows normal again. I think it would be ok to pass it for inclusion in 2.6.23 if it's not too late yet.
Comment 15 Borislav Petkov 2007-06-30 11:42:50 UTC
i meant 2.6.22 of course.
Comment 16 Nicolo' Chieffo 2007-07-11 04:16:00 UTC
I've also tried this patch and it works. You can include it in the main kernel tree!
Comment 17 Thomas Schwarzgruber 2007-07-11 04:29:08 UTC
Yes it also works for me and the patch still applies to 2.6.22 - it would be nice if someone could push it for mainline inclusion.... I'm scared by the imagination of applying this patch to every new kernel version...
Comment 18 Nicolo' Chieffo 2007-07-11 06:56:54 UTC
I've noticed that the system is quite slow (comparing to 2.6.20) to notice that the AC cable is unplugged... 5 seconds! is it normal?
Comment 19 Fu Michael 2007-10-10 01:03:27 UTC
dup of bug# 8598. it's code fixed. the slow AC unplug dection isue, please open another bug. thanks.

*** This bug has been marked as a duplicate of bug 8598 ***

Note You need to log in before you can comment on or make changes to this bug.