Bug 8492 - MPT driver fails to detect VMware WS5.x hard drive under LSI virtual controller
MPT driver fails to detect VMware WS5.x hard drive under LSI virtual controller
Status: REJECTED INVALID
Product: SCSI Drivers
Classification: Unclassified
Component: Other
i386 Linux
: P2 normal
Assigned To: scsi_drivers-other
:
: 8710 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-17 10:05 UTC by Ben Collins
Modified: 2007-07-05 16:36 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.22-rc1
Tree: Mainline
Regression: ---


Attachments

Description Ben Collins 2007-05-17 10:05:40 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20
Distribution: Ubuntu
Hardware Environment: VMWare workstation 5.x
Software Environment:
Problem Description: mpt driver fails to detect VMware hd

Steps to reproduce: Install 2.6.22-rc1 under VMware workstation 5.x, using LSI
as the virtual SCSI controller for the hard drive. Driver fails to recognize
that a drive is even present. Cannot reproduce under WS6, or 2.6.20 kernel.
Comment 1 Ben Collins 2007-05-17 10:10:43 UTC
Original bug report: https://launchpad.net/bugs/112860
Comment 2 Ben Collins 2007-05-17 10:18:33 UTC
Relevant dmesg from both kernels:

2.6.20:
mptbase: Initiating ioc0 bringup
ioc0: 53C1030: Capabilities={Initiator}
scsi0 : ioc0: LSI53C1030, FwRev=00000000h, Ports=1, MaxQ=128, IRQ=17
scsi 0:0:0:0: Direct-Access     VMware,  VMware Virtual S 1.0  PQ: 0 ANSI: 2
 target0:0:0: Beginning Domain Validation
 target0:0:0: Domain Validation skipping write tests
 target0:0:0: Ending Domain Validation
 target0:0:0: FAST-40 WIDE SCSI 80.0 MB/s ST (25 ns, offset 127)


2.6.22:
mptbase: Initiating ioc0 bringup
ioc0: 53C1030: Capabilities={Initiator}
scsi0 : ioc0: LSI53C1030, FwRev=00000000h, Ports=1, MaxQ=128, IRQ=17
Comment 3 Ben Collins 2007-05-17 11:00:08 UTC
Just tested with stock 2.6.21, and it has the same problem. So this is a
regression from .20 to .21. If I get some time, I'll start a bisect.
Comment 4 Ben Collins 2007-05-17 16:51:19 UTC
I bisected this to this commit:

commit 793955f549c710a1b0c18f823d5d710840747b15
Author: Eric Moore <eric.moore@lsi.com>
Date:   Mon Jan 29 09:42:20 2007 -0700

    [SCSI] fusion - Greater than 255 target and lun support

    Add support for greater than 255 target and luns.
    Kill the hd->Target[] field, and change all references
    of bus_id/target_id, to channel/id.

    Signed-off-by: Eric Moore <Eric.Moore@lsi.com>
    Signed-off-by: James Bottomley <James.Bottomley@SteelEye.com>

This is a huge commit (~58k), so I didn't go through it, but I did find that
adding mpt_channel_mapping=1 (introduced in this commit) to mptbase options was
a work around. Perhaps this should be default until this is fixed.
Comment 5 Adrian Bunk 2007-05-18 03:37:55 UTC
Known bug in VMware, for further information see
http://www.mail-archive.com/linux-kernel@vger.kernel.org/msg136184.html
Comment 6 Adrian Bunk 2007-07-05 16:36:26 UTC
*** Bug 8710 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.