Bug 8477 - /proc/acpi/battery/BAT0 disappeared
Summary: /proc/acpi/battery/BAT0 disappeared
Status: CLOSED DUPLICATE of bug 8598
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Battery (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: acpi_power-battery
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-05-14 16:32 UTC by Thomas Schwarzgruber
Modified: 2007-07-25 22:47 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.21 with suspend2 patch applied
Tree: Mainline
Regression: ---


Attachments
kern.log part of 2.6.21 vanilla (25.82 KB, text/plain)
2007-05-15 03:40 UTC, Thomas Schwarzgruber
Details
dmesg output with CONFIG_ACPI_DEBUG (26.08 KB, text/plain)
2007-05-17 07:43 UTC, Thomas Schwarzgruber
Details
acpidump-yelo3 (118.64 KB, application/octet-stream)
2007-05-25 00:50 UTC, Nicolo' Chieffo
Details
acpidump-thomas (118.58 KB, text/plain)
2007-05-25 01:25 UTC, Thomas Schwarzgruber
Details
acpidump-shox (118.64 KB, text/plain)
2007-06-02 07:53 UTC, shox313
Details

Description Thomas Schwarzgruber 2007-05-14 16:32:48 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20.6
Distribution: self compiled
Hardware Environment: Intel Centrino Laptop
Software Environment: 
Problem Description:
/proc/acpi/battery/BAT0 (my laptop battery) is no longer available 
since i use 2.6.21 - the only change i made in kernel configuration
is that i enabled the tickless option. With all versions before (including 2.6.20.6) it 
worked flawlessy.

the relevant config options i use are:

#
# ACPI (Advanced Configuration and Power Interface) Support
#
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SLEEP_PROC_FS=y
# CONFIG_ACPI_SLEEP_PROC_SLEEP is not set
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_BATTERY=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_VIDEO=m
CONFIG_ACPI_FAN=y
# CONFIG_ACPI_DOCK is not set
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
CONFIG_ACPI_ASUS=y
# CONFIG_ACPI_IBM is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
CONFIG_X86_PM_TIMER=y
# CONFIG_ACPI_CONTAINER is not set
# CONFIG_ACPI_SBS is not set

#
# APM (Advanced Power Management) BIOS Support
#
# CONFIG_APM is not set


Steps to reproduce:
Comment 1 Thomas Schwarzgruber 2007-05-15 03:38:26 UTC
Hello!

I now removed the suspend2 patch and use now a vanilla 2.6.21. The problem remains.

Some additional info:
/proc/acpi/battery/BAT1 is still available - but I do have my battery at BAT0 - so BAT1 just 
states that there is no battery. 
I get no error messages or whatsoever in /var/log/kern.log about acpi or anything else.

I will attach relevant kern.log part.
Comment 2 Thomas Schwarzgruber 2007-05-15 03:40:56 UTC
Created attachment 11507 [details]
kern.log part of 2.6.21 vanilla
Comment 3 Zhang Rui 2007-05-16 20:11:39 UTC
set CONFIG_ACPI_DEBUG will help you get more ACPI debug messages. :)
>/proc/acpi/battery/BAT1 is still available - but I do have my battery at BAT0
Do you mean that only BAT1 can be seen under /proc/acpi/battery?
And /proc/acpi/battery/BAT1/state says that the BAT1 is not present?
Please attach the dmesg output after you set CONFIG_ACPI_DEBUG.
Comment 4 Thomas Schwarzgruber 2007-05-17 07:38:03 UTC
>Do you mean that only BAT1 can be seen under /proc/acpi/battery?
>And /proc/acpi/battery/BAT1/state says that the BAT1 is not present?
Yes that's correct.
>Please attach the dmesg output after you set CONFIG_ACPI_DEBUG.
Hmm recompiled with CONFIG_ACPI_DEBUG but I'm afraid my dmesg
output doesn't contain anything new... but will attach it.
Comment 5 Thomas Schwarzgruber 2007-05-17 07:43:30 UTC
Created attachment 11526 [details]
dmesg output with CONFIG_ACPI_DEBUG
Comment 6 Nicolo' Chieffo 2007-05-21 07:22:30 UTC
I have some more debugging lines, but I have a precompiled kernel by ubuntu,
without the debug configuration:

[   15.896079] ACPI Error (psparse-0537): Method parse/execution failed
[\_SB_.PCI0.SBRG.EC0_.BATS] (Node c147bf18), AE_NOT_EXIST
[   15.896125] ACPI Error (psparse-0537): Method parse/execution failed
[\_SB_.BAT0._STA] (Node c14783c4), AE_NOT_EXIST

these lines are not present in a dmesg by 2.6.20 (which does not have this problem)

I've attached my DSDT in the bug #8493 which I think is a dup of this
Comment 7 Zhang Rui 2007-05-24 23:58:16 UTC
Hi, Thomas,
Could you please attach the acpidump output please?:)
Comment 8 Nicolo' Chieffo 2007-05-25 00:50:23 UTC
Created attachment 11596 [details]
acpidump-yelo3
Comment 9 Thomas Schwarzgruber 2007-05-25 01:25:53 UTC
Created attachment 11597 [details]
acpidump-thomas
Comment 10 shox313 2007-06-02 07:49:20 UTC
I have the same problem with my asus notebook: M6842NELH, bios 0208A
Comment 11 shox313 2007-06-02 07:53:02 UTC
Created attachment 11641 [details]
acpidump-shox
Comment 12 Zhang Rui 2007-06-13 20:42:37 UTC
Please try the patch in comment#9 bug8598.
Comment 13 Thomas Schwarzgruber 2007-06-14 01:38:29 UTC
Thanks for the hint to this patch - I updated to 2.6.22-rc4 and applied the patch and my battery is here again! So for me this bug can be considered as fixed.
Comment 14 Nicolo' Chieffo 2007-06-14 02:18:00 UTC
If it works I hope it is included soon by default!
Comment 15 Alexey Starikovskiy 2007-07-18 02:10:14 UTC

*** This bug has been marked as a duplicate of bug 8598 ***

Note You need to log in before you can comment on or make changes to this bug.