Bug 8422 - in kern.log many record of "fs/inotify.c:172"
in kern.log many record of "fs/inotify.c:172"
Status: RESOLVED DUPLICATE of bug 7785
Product: IO/Storage
Classification: Unclassified
Component: Block Layer
i386 Linux
: P2 high
Assigned To: Nick Piggin
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-03 00:22 UTC by Wizard Vandal
Modified: 2007-06-30 16:48 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.21
Tree: Mainline
Regression: ---


Attachments

Description Wizard Vandal 2007-05-03 00:22:27 UTC
Most recent kernel where this bug did *NOT* occur:
Distribution:Debian SID
Hardware Environment:
Software Environment:
Problem Description:
I tested xlite softphone, first time (started as root) application found my 
sound card, mic and I can record my voice. after some time of experiments with 
this software and asterisk server on another machine, I found that I can not 
record my voice and people dont hear me. I starting to look for something 
strange in logs and found in kern.log
----------------
May  2 15:49:57 wlinux kernel: BUG: at fs/inotify.c:172 
set_dentry_child_flags()
May  2 15:49:57 wlinux kernel:  [<c0180740>] set_dentry_child_flags+0x60/0x12c
May  2 15:49:57 wlinux kernel:  [<c018085f>] remove_watch_no_event+0x53/0x5f
May  2 15:49:57 wlinux kernel:  [<c018094d>] 
inotify_remove_watch_locked+0x12/0x3e
May  2 15:49:57 wlinux kernel:  [<c0180c17>] inotify_rm_wd+0x6d/0x8a
May  2 15:49:57 wlinux kernel:  [<c0181113>] sys_inotify_rm_watch+0x38/0x4f
May  2 15:49:57 wlinux kernel:  [<c0102686>] sysenter_past_esp+0x5f/0x85
May  2 15:49:57 wlinux kernel:  [<c0400000>] pfkey_send_acquire+0x31e/0x6c9
----------------

Steps to reproduce:
I don't know how to reproduce it...
It found it because my 'mic' can't record sound any more, but one hour before 
all was fine..

Now I will reboot and report if it will not work again (recording sound).
Comment 1 Wizard Vandal 2007-05-03 18:52:32 UTC
Problem with mic was not because of this inotify bug. :)
So, what effect of this bug can be on my comp?
Comment 2 Natalie Protasevich 2007-05-23 14:30:50 UTC
Probably someone who works on inotify would like to take a look.
--Natalie
Comment 3 Adrian Bunk 2007-06-30 16:48:07 UTC

*** This bug has been marked as a duplicate of bug 7785 ***

Note You need to log in before you can comment on or make changes to this bug.