Bug 8419 - 2.6.21.1 and Apple MacBook - Problems during suspend-to-(disk|ram)
2.6.21.1 and Apple MacBook - Problems during suspend-to-(disk|ram)
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2007-05-02 07:15 UTC by Marvin Stark
Modified: 2007-06-01 16:14 UTC (History)
0 users

See Also:
Kernel Version: 2.6.21.1
Tree: Mainline
Regression: ---


Attachments

Description Marvin Stark 2007-05-02 07:15:46 UTC
Distribution: Debian GNU/Linux Etch (4.0)

Hardware Environment:
Intel(R) Core(TM)2 CPU         T5600  @ 1.83GHz

lspci:
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS/940GML
Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/940GML Express
Integrated Graphics Controller (rev 03)
00:07.0 Performance counters: Intel Corporation Unknown device 27a3 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA
Storage Controller IDE (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit
Ethernet Controller (rev 22)
02:00.0 Network controller: Atheros Communications, Inc. Unknown device 0024
(rev 01)
03:03.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 61)

Software Environment:
s2ram, s2disk, sysfs

Problem Description:

Every time I try to suspend my MacBook to disk (platform modus) I get following
message before the system freezes:

ACPI: PCI interrupt for device 0000:00.1f.2 disabled

As 00:1f.2 is my S-ATA controller, I think that the harddisk can not be suspended.

If I change the suspend modus to "shutdown", The system will suspend without any
problems. But only to _disk_. To ram also fails with that option.

If you need more data/details to this problem please let me know.

PS: DISABLE_CONSOLE_SUSPEND is enabled.

Regards,

Marvin Stark
Comment 1 Rafael J. Wysocki 2007-05-02 11:17:44 UTC
Have you tried with ENABLE_CONSOLE_SUSPEND disabled?
Comment 2 Marvin Stark 2007-05-02 11:50:59 UTC
Yes, I did. Same result.
Freezing at "Suspending console(s)"
Comment 3 Luming Yu 2007-05-05 07:24:01 UTC
>ram also fails with that option

Did you try s3 with old kernel such as 2.6.20?

Also I would suggest you to try linux firmware ready tool
http://www.linuxfirmwarekit.org/, and try s3 with that tool.
Comment 4 Marvin Stark 2007-05-07 10:15:20 UTC
> Did you try s3 with old kernel such as 2.6.20?

Yes I did. Also, same result.

>
> Also I would suggest you to try linux firmware ready tool
> http://www.linuxfirmwarekit.org/, and try s3 with that tool.

Here Suspend to disk seems to work. But after opening the lid again, the screen
won't come back.

Maybe the are problems because my root partition is encrypted?
Comment 5 Rafael J. Wysocki 2007-05-24 09:52:11 UTC
That would only affect hibernation, not S3.

Could you test 2.6.22-rc2?  There's one importand suspend-related change in it.
Comment 6 Marvin Stark 2007-05-27 14:16:39 UTC
On Thursday 24 May 2007 18:49, you wrote:
> ------- Additional Comments From rjwysocki@sisk.pl  2007-05-24 09:52
> ------- That would only affect hibernation, not S3.
>
> Could you test 2.6.22-rc2?  There's one importand suspend-related change in
> it.

Yes it worked! The maschine suspends now. After reopening the lid the 
backlight turns on again but there's no screen. What's going wrong here?

>
>
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.

Comment 7 Rafael J. Wysocki 2007-05-27 14:46:58 UTC
Might be a couple of reasons, AFAICT.

Have you tried s2ram (http://en.opensuse.org/s2ram) ?
Comment 8 Marvin Stark 2007-05-28 11:06:53 UTC
On Sunday 27 May 2007 23:43, you wrote:
> ------- Might be a couple of reasons, AFAICT.
>
> Have you tried s2ram (http://en.opensuse.org/s2ram) ?

Yes, same result. I also tried with vbe_save and vbe_post.
s2ram version is: 0.3~cvs20060928-7
Comment 9 Rafael J. Wysocki 2007-05-28 11:16:49 UTC
For now, I'm out of ideas. :-(
Comment 10 Rafael J. Wysocki 2007-05-30 08:52:52 UTC
What happens if you boot the 2.6.22-rc3 kernel with init=/bin/bash and do:

# mount /sys
# mount /proc
# echo 5 > /proc/sys/kernel/printk
# echo platform > /sys/power/disk
# echo disk > /sys/power/state

?
Comment 11 Marvin Stark 2007-06-01 09:45:25 UTC
Hi,

today I tested 2.6.22-rc3 and suspend-to-RAM worked like a charm!
Comment 12 Rafael J. Wysocki 2007-06-01 12:21:28 UTC
Good news!

OK, so do you think we can close this bug?
Comment 13 Marvin Stark 2007-06-01 15:40:42 UTC
On Friday 01 June 2007 21:18, you wrote:
> ------- Additional Comments From rjwysocki@sisk.pl  2007-06-01 12:21
> ------- Good news!
>
> OK, so do you think we can close this bug?

Yes, we can. Thanks for all your help!

Comment 14 Rafael J. Wysocki 2007-06-01 16:14:28 UTC
Fixed in 2.6.22-rc3.

Note You need to log in before you can comment on or make changes to this bug.