Bug 8399 - Documentation for readv(2) is inaccurate
Documentation for readv(2) is inaccurate
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
i386 Linux
: P2 low
Assigned To: Michael Kerrisk
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-28 15:42 UTC by Kyle Sluder
Modified: 2007-05-09 22:49 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.17
Tree: Mainline
Regression: ---


Attachments

Description Kyle Sluder 2007-04-28 15:42:38 UTC
The documentation for readv(2) states that ``The  readv()  function reads count
blocks from the file associated with the file descriptor fd into the multiple
buffers described by vector.''  This is incorrect; readv() uses the ``count''
parameter to determine the number of iovec structures exist at *iov.  Otherwise
there would be no way to specify multiple buffers, which is the point of readv().

Distribution: Ubuntu 6.10 Edgy Eft
Comment 1 Kyle Sluder 2007-05-09 22:49:48 UTC
Per e-mail from Michael Kerrisk:

>> Hi Adrian,
>>
>> You've rightly assigned the bug to me, but I think I don't have an account
>> on bugzilla.kernel.org, so I will need you to close it, and you can close
>> it now.
>>
>> Andrew: thanks also for forwarding this to me.
>>
>> Kyle: thanks for your report.
>>
>> I agree the page was broken, though rather because the original author had
>> explained things badly (using "block" instead of "buffer"), than because he
>> did not understand things.
>>
>> This report prodded me to more or less completely rewrite the page to fix
>> this problem, and much else.

Marking closed.

Note You need to log in before you can comment on or make changes to this bug.