Bug 8328 - Epson Perfection 1260 scanner not working with 2.6.17 and 2.6.18
Epson Perfection 1260 scanner not working with 2.6.17 and 2.6.18
Status: REJECTED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2007-04-15 04:36 UTC by Pallinger P
Modified: 2007-09-05 07:38 UTC (History)
0 users

See Also:
Kernel Version: 2.6.17
Tree: Mainline
Regression: ---


Attachments

Description Pallinger P 2007-04-15 04:36:01 UTC
Most recent kernel where this bug did *NOT* occur: 2.4.31
Distribution: Debian 4.0 "Etch"
Hardware Environment: 
  First:
    AMD XP 2400+ CPU
    VIA KT600 chipset
    Epson Perfection 1260 scanner
  Second: 
    Intel pentium M CPU
    Intel 82801 chipset
    Epson Perfection 1260 scanner
Software Environment:
  udev 0.105-4
  xsane 0.99+0.991-2
  libsane 1.0.18-5
Problem Description:
  xsane does not recognise scanner
  It seems as if no class drivers would claim the scanner. The documentation
hinted that the "usbhid" module should handle scanners, but apparently, it does
not handle this one (I tried to load it by hand). The "scanner" module in 2.4.31
does claim this device, and scanning works fine with xsane.
  The bug was reproduced using on two different computers (but the same
scanner), and both on 2.6.18 and 1.6.17 kernels.

Steps to reproduce:
 - Plug in epson perfection 1260 scanner
 - run xsane
Comment 1 Anonymous Emailer 2007-04-15 10:04:18 UTC
Reply-To: akpm@linux-foundation.org

On Sun, 15 Apr 2007 04:36:07 -0700 bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=8328
> 
>            Summary: Epson Perfection 1260 scanner not working with 2.6.17
>                     and 2.6.18
>     Kernel Version: 2.6.17
>             Status: NEW
>           Severity: normal
>              Owner: greg@kroah.com
>          Submitter: pallinger@fastmail.fm
> 
> 
> Most recent kernel where this bug did *NOT* occur: 2.4.31
> Distribution: Debian 4.0 "Etch"
> Hardware Environment: 
>   First:
>     AMD XP 2400+ CPU
>     VIA KT600 chipset
>     Epson Perfection 1260 scanner
>   Second: 
>     Intel pentium M CPU
>     Intel 82801 chipset
>     Epson Perfection 1260 scanner
> Software Environment:
>   udev 0.105-4
>   xsane 0.99+0.991-2
>   libsane 1.0.18-5
> Problem Description:
>   xsane does not recognise scanner
>   It seems as if no class drivers would claim the scanner. The documentation
> hinted that the "usbhid" module should handle scanners, but apparently, it does
> not handle this one (I tried to load it by hand). The "scanner" module in 2.4.31
> does claim this device, and scanning works fine with xsane.
>   The bug was reproduced using on two different computers (but the same
> scanner), and both on 2.6.18 and 1.6.17 kernels.
> 
> Steps to reproduce:
>  - Plug in epson perfection 1260 scanner
>  - run xsane

Comment 2 Anonymous Emailer 2007-04-15 12:55:03 UTC
Reply-To: oliver@neukum.org

Am Sonntag, 15. April 2007 19:04 schrieb Andrew Morton:
> > Problem Description:
> > 
Comment 3 Pallinger P 2007-04-16 01:05:44 UTC
> The scanner module was removed and scanners except for old Microtek
> scanners are now handled via libusb. This is a problem caused by an
> outdated configuration of SANE, not a kernel regression.
> 
> 	Regards
> 		Oliver

I am glad to hear that. 
I know that this isn't the forum to do so, but could you please tell me a way to
solve this problem (or send a link containing the solution)?

Many thanks
      PP
Comment 4 Natalie Protasevich 2007-06-14 10:33:15 UTC
You can probably start with http://www.freecolormanagement.com/sane/libusb.html


And it is now time to close this bug I guess.
Thanks

Note You need to log in before you can comment on or make changes to this bug.