Bug 83221 - laptop hangs after loading nouveau fails, pm_runtime_work thread dying
Summary: laptop hangs after loading nouveau fails, pm_runtime_work thread dying
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-25 18:50 UTC by Karol Herbst
Modified: 2014-09-09 20:23 UTC (History)
0 users

See Also:
Kernel Version: 3.17-rc1
Tree: Mainline
Regression: No


Attachments
output of /var/log/kernel/current (83.41 KB, application/octet-stream)
2014-08-25 18:50 UTC, Karol Herbst
Details
call traces while compiling kernel (18.51 KB, text/plain)
2014-08-25 23:58 UTC, Karol Herbst
Details

Description Karol Herbst 2014-08-25 18:50:10 UTC
Created attachment 148141 [details]
output of /var/log/kernel/current

After trying to loade the nouveau driver on my laptop my laptop starts to stop updating the display and reacting to the keyboard or mouse. The laptop seems to work though, at least I saw some disc activity through the LED.

uname -a: Linux pingu 3.17.0-rc1 #2 SMP PREEMPT Mon Aug 25 20:04:39 CEST 2014 x86_64 Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz GenuineIntel GNU/Linux

if needed I can provide the kernel config file and other information.

I put it to Video(DRI - non Intel), because I only encounter this error while loading nouveau, but it could be an error somewhere else, maybe 3.17 related, though I get the same behaviour on 3.16.1 but without the pm_runtime_work thread dying.
Comment 1 Karol Herbst 2014-08-25 23:57:51 UTC
while bisecting the kernel to find the commit which causes the stack. I noticed that this stack is only triggered through some CPU load and not always. Maybe this new log helps little bit more
Comment 2 Karol Herbst 2014-08-25 23:58:30 UTC
Created attachment 148201 [details]
call traces while compiling kernel
Comment 3 Karol Herbst 2014-09-09 20:23:34 UTC
seems to be fixed with rc4

Note You need to log in before you can comment on or make changes to this bug.