Bug 8308 - boot hang w/o pci=nommconf - Acer Veriton 6900 Pro, Intel Pentium D
Summary: boot hang w/o pci=nommconf - Acer Veriton 6900 Pro, Intel Pentium D
Status: CLOSED DUPLICATE of bug 8833
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-06 17:06 UTC by Jacob Thompson
Modified: 2008-01-12 16:05 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.23.1
Tree: Mainline
Regression: ---


Attachments
Kernel messages with options: ro root=LABEL=/ console=ttyS0 acpi_dbg_layer=1 acpi_dbg_level=1 apic=debug debug (7.78 KB, text/plain)
2007-04-06 17:07 UTC, Jacob Thompson
Details
Kernel messages with options: ro root=LABEL=/ console=ttyS0 acpi=ht acpi_dbg_layer=1 acpi_dbg_level=1 apic=debug debug (9.66 KB, text/plain)
2007-04-06 17:07 UTC, Jacob Thompson
Details
Kernel messages with options: ro root=LABEL=/ console=ttyS0 acpi=off acpi_dbg_layer=1 acpi_dbg_level=1 apic=debug debug (13.67 KB, text/plain)
2007-04-06 17:08 UTC, Jacob Thompson
Details
Kernel messages with options: ro root=LABEL=/ pci=nommconf (19.97 KB, text/plain)
2007-10-06 15:19 UTC, Jacob Thompson
Details
acpidump with options: ro root=LABEL=/ pci=nommconf (90.88 KB, text/plain)
2007-10-06 15:20 UTC, Jacob Thompson
Details
Kernel messages for intermittent hang with pci=nommconf (17.29 KB, text/plain)
2007-10-06 16:49 UTC, Jacob Thompson
Details
Kernel messages for intermittent hang with pci=nommconf pci=routeirq (18.70 KB, text/plain)
2007-10-06 16:50 UTC, Jacob Thompson
Details
Kernel messages for successful boot with pci=nommconf pci=routeirq (21.37 KB, text/plain)
2007-10-06 16:57 UTC, Jacob Thompson
Details

Description Jacob Thompson 2007-04-06 17:06:09 UTC
Most recent kernel where this bug did *NOT* occur: N/A
Distribution: Fedora Core 6.92 (Rawhide)
Hardware Environment: Acer Veriton 6900 Pro, Intel Pentium D dual-core
Software Environment: Linux 2.6.20.4
Problem Description:

The system will hang while the kernel is initializing if the option acpi=off is
not specified on the kernel command line.  After the hang occurs, the Num Lock
key on the keyboard no longer turns Num Lock on or off.

This is an Acer Veriton 6900 Pro system, Intel Pentium D dual-core CPU,
Phoenix-Award BIOS.

Steps to reproduce:
Boot kernel without acpi=off option
Comment 1 Jacob Thompson 2007-04-06 17:07:08 UTC
Created attachment 11086 [details]
Kernel messages with options: ro root=LABEL=/ console=ttyS0 acpi_dbg_layer=1 acpi_dbg_level=1 apic=debug debug
Comment 2 Jacob Thompson 2007-04-06 17:07:48 UTC
Created attachment 11087 [details]
Kernel messages with options: ro root=LABEL=/ console=ttyS0 acpi=ht acpi_dbg_layer=1 acpi_dbg_level=1 apic=debug debug
Comment 3 Jacob Thompson 2007-04-06 17:08:19 UTC
Created attachment 11088 [details]
Kernel messages with options: ro root=LABEL=/ console=ttyS0 acpi=off acpi_dbg_layer=1 acpi_dbg_level=1 apic=debug debug
Comment 4 Len Brown 2007-04-11 19:29:21 UTC
What is the most recent kernel that worked properly without any
cmdline workarounds?

Does the latest upstream kernel (2.6.21-rc6) work any better?

any luck with "pci=nommconf" or with "noapic"?
Comment 5 Jacob Thompson 2007-04-12 08:43:19 UTC
I will have access to this machine on Apr. 13.  It is a new machine and I have
not tried a kernel earlier than 2.6.18 (Fedora version).  I plan on trying
kernel.org versions of 2.6.21-rc6, 2.6.17.14, and 2.6.8.1 with and without the
suggested options.  Are there any other versions that would be good baselines to
try (e.g. before major ACPI changes)?
Comment 6 Jacob Thompson 2007-04-13 20:20:29 UTC
I tried kernel 2.6.21-rc6 tonight.  With just pci=nommconf, the kernel prints an
irq 19: nobody cared message, suggests trying irqpoll, and gets stuck trying to
detect the CD-ROM drive.  It is not a complete hang as SysRq combinations still
work.

With both the pci=nommconf and irqpoll options, the kernel boots and runs fine.
Comment 7 Shaohua 2007-04-18 19:07:17 UTC
please attach the dmesg and acpidump output with pci=nommconf. mmconf is known 
broken in a lot systems. irqpoll suggests there is a irq mis-routing.
Comment 8 ykzhao 2007-08-30 23:13:28 UTC
Will you please upload the acpidump after the system is booted with option acpi=off ?
 
Comment 9 Jacob Thompson 2007-10-06 15:18:52 UTC
Here is an update: pci=nommconf with no other options is working (most of the time, see paragraph below) as of 2.6.22.9-91.fc7 and I am attaching dmesg output and the requested acpidump.  I am using the output from a Fedora kernel, if that is not OK, I can compile one from kernel.org.

I do still have problems with intermittent hangs on bootup even when using pci=nommconf.  The kernel prints a detailed "oops" style error message and prints another error message every 5 seconds.  This is not consistently reproducible can sometimes be fixed by disconnecting all USB devices and rebooting.  I can try to capture the kernel output if I can get it to happen again.
Comment 10 Jacob Thompson 2007-10-06 15:19:46 UTC
Created attachment 13061 [details]
Kernel messages with options: ro root=LABEL=/ pci=nommconf
Comment 11 Jacob Thompson 2007-10-06 15:20:15 UTC
Created attachment 13062 [details]
acpidump with options: ro root=LABEL=/ pci=nommconf
Comment 12 Jacob Thompson 2007-10-06 16:49:48 UTC
Created attachment 13064 [details]
Kernel messages for intermittent hang with pci=nommconf
Comment 13 Jacob Thompson 2007-10-06 16:50:12 UTC
Created attachment 13065 [details]
Kernel messages for intermittent hang with pci=nommconf pci=routeirq
Comment 14 Jacob Thompson 2007-10-06 16:57:18 UTC
Created attachment 13066 [details]
Kernel messages for successful boot with pci=nommconf pci=routeirq

This was literally just a few minutes after attempting to boot with pci=nommconf pci=routeirq and getting the errors in attachment 13065 [details].  After attachment 13065 [details] I rebooted the system and one of the BIOS screens that flashed by showed "Update Successful", so I suspect that the BIOS is changing something in ACPI/ESCD/whatever in between the boot attempts.
Comment 15 Fu Michael 2007-10-22 06:11:10 UTC
could you please check to see if http://bugzilla.kernel.org/show_bug.cgi?id=8833#c12 can fix your problem?
Comment 16 Jacob Thompson 2007-10-26 17:19:02 UTC
Using the patch at http://marc.info/?l=linux-kernel&m=118809338631160&w=2 against 2.6.23.1 the hang appears to be resolved.
Comment 17 Fu Michael 2007-10-26 17:22:49 UTC
great! mark it as dup then.

*** This bug has been marked as a duplicate of bug 8838 ***
Comment 18 Jacob Thompson 2007-10-26 19:33:38 UTC
Should that have been bug 8833 and not bug 8838?
Comment 19 Len Brown 2008-01-12 16:04:58 UTC
yup
Comment 20 Len Brown 2008-01-12 16:05:11 UTC

*** This bug has been marked as a duplicate of bug 8833 ***

Note You need to log in before you can comment on or make changes to this bug.