Bug 8307 - S3: no resume - Acer TravelMate 3012
S3: no resume - Acer TravelMate 3012
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 high
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2007-04-06 05:31 UTC by Norbert Preining
Modified: 2007-09-07 00:52 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.21
Tree: Mainline
Regression: ---


Attachments
dmesg output of a reboot immediately after a frozen s2ram (24.86 KB, text/plain)
2007-04-06 05:33 UTC, Norbert Preining
Details
minimal config file for 2.6.21 (15.27 KB, text/plain)
2007-05-15 09:03 UTC, Norbert Preining
Details

Description Norbert Preining 2007-04-06 05:31:18 UTC
Most recent kernel where this bug did *NOT* occur: no idea
Distribution: Debian/sid
Hardware Environment: Acer TravelMate 3012
Software Environment: Debian/sid, self compiled kernel
Problem Description:
after suspend to ram the kernel does not come back. I tried the following
things, all with a minimal kernel (no modules, no usb, no agb, no bluetooth, no
wlan, ...) and from init=/bin/bash:
- use uswsusp s2ram -f with various combinations/incantations
- booted with noapic and kernel config with CONFIG_PREEMPT_NONE=y
- using PM_TRACE debugging I get:  Magic number: 3:52:786
  but no lines "hash matches ..."
See attached dmesg output of a noapic nopreempt reboot AFTER a s2ram freeze


Steps to reproduce:
whatever way to initiate a s2ram (echo mem > ..., call s2ram)
Comment 1 Norbert Preining 2007-04-06 05:33:11 UTC
Created attachment 11085 [details]
dmesg output of a reboot immediately after a frozen s2ram
Comment 2 Norbert Preining 2007-04-10 07:18:00 UTC
I made another test with netconsole attached, and the last thing which came
through was the suspend stuff:
---------------
Starting balanced_irq
Using IPI No-Shortcut mode
  Magic number: 3:802:636
  hash matches device 0000:00:1c.1:pcie02
Synaptics Touchpad, model: 1, fw: 6.2, id: 0x81a0b1, caps: 0xa04713/0x204000
input: SynPS/2 Synaptics TouchPad as /class/input/input5
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 172k freed
Stopping tasks ... done.
Suspending console(s)
-----------

The resume didn't leave any trace via netconsole, so the problem must happen
earlier.

Furthermore, as averted by someone from the suspend list, I tried to use vesafb
or intelfb instead of plain vga console. In both cases no success. Furthermore
(probably unrelated) when booting with vga=792 the screen remains black
(backlight on).

Any other suggestions?

Best wishes

Norbert
Comment 3 Norbert Preining 2007-05-01 12:43:56 UTC
Tested the same with 2.6.21, with minimal (even more minimal then before ;-),
same result. Not a beep after resume.
Comment 4 Shaohua 2007-05-14 19:48:06 UTC
Try to remove as many drivers as possible, and see if any driver breaks s2ram 
please
Comment 5 Norbert Preining 2007-05-15 09:02:07 UTC
Hi David!
I tried with a minimal kernel of 2.6.21, see the attachment, and the same
happens. The minimal config was created from an empty .config by saying
everywhere N where I could (or at least where I believed I could). Only thing
compiled in is the SCSI system, otherwise I cannot access the disk.

If you have any suggestion for a different .config (suggested changes) let me
know  and I will try immediately.

Thanks for your support

Norbert
Comment 6 Norbert Preining 2007-05-15 09:03:14 UTC
Created attachment 11509 [details]
minimal config file for 2.6.21
Comment 7 Norbert Preining 2007-05-23 06:41:23 UTC
Reconfirmed with 2.6.22-rc2. I even removed the SATA driver and included plain
old ATA/IDE generic interface. Still no wakeup, complete freeze, only 4sec power
button helps.
Comment 8 Len Brown 2007-09-06 15:55:29 UTC
Maybe Rafael has some ideas?
Comment 9 Norbert Preining 2007-09-06 21:54:06 UTC
I can report that with 2.6.23-rc2 onward (not sure about -rc1, but definitely not in -22) s2ram works. Resume from X running even with DRI enabled works. So I close this bug.

Note You need to log in before you can comment on or make changes to this bug.