Bug 8304 - DVB-T Pluto2: SUSPEND/RESUME methods are missing for this driver
DVB-T Pluto2: SUSPEND/RESUME methods are missing for this driver
Status: CLOSED OBSOLETE
Product: v4l-dvb
Classification: Unclassified
Component: dvb-other
i386 Linux
: P2 blocking
Assigned To: Andreas Oberritter
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2007-04-05 12:17 UTC by Cijoml Cijomlovic Cijomlov
Modified: 2012-05-14 16:55 UTC (History)
9 users (show)

See Also:
Kernel Version: 2.6.24 and lower
Tree: Mainline
Regression: No


Attachments

Description Cijoml Cijomlovic Cijomlov 2007-04-05 12:17:22 UTC
Most recent kernel where this bug did *NOT* occur: unknown
Distribution: Debian testing
Hardware Environment: all
Software Environment: 2.6.20 vanilla, latest DVB snapshoot
Problem Description:

After SWSUPS resume, pluto2 card is not started properly, led getts not green
and card is unable load tda firmware

Steps to reproduce:

suspend and resume back
Comment 1 Natalie Protasevich 2007-06-21 23:25:50 UTC
For the record and to refresh data - can you please test with latest 2.6.22-rc5.
If still fails - please provide boot trace, lspci -vv, and /var/log/messages.
Thanks.
Comment 2 Cijoml Cijomlovic Cijomlov 2007-06-23 23:36:41 UTC
Tested with dvb-Mercurial-b03a5545f8e1 and problem is still present :(
Comment 3 Andrew Morton 2007-07-25 16:44:48 UTC
Hopefully this problem is only in Mauro's devel tree and han't
made it into mainline yet?  Did you test 2.6.23-rc1?

Thanks.
Comment 4 Cijoml Cijomlovic Cijomlov 2007-07-26 00:25:21 UTC
Hi,

this problem is related to both. It doesn't work in linus's tree and also not in Mauro's tree. It simply doesn't store firmware in memory when suspending and not resuming it back to adapter when resuming computer :(
Comment 5 Rafael J. Wysocki 2007-12-12 16:51:50 UTC
Can you check if the problem is still present in the current mainline?  There are some dvb fixes in there  ...
Comment 6 Cijoml Cijomlovic Cijomlov 2007-12-14 06:45:55 UTC
Hi,

yes it is present in 2.6.23.9 vanilla kernel
Comment 7 Cijoml Cijomlovic Cijomlov 2007-12-14 13:34:59 UTC
Doing quick look into driver I find out that there are missing suspend/resume methods in the driver
Comment 8 Cijoml Cijomlovic Cijomlov 2008-01-27 01:40:21 UTC
Still present in 2.6.24
Comment 9 Rafael J. Wysocki 2011-01-16 21:37:52 UTC
Oh, that's a long time ago. :-)

Did you test anything newer?

Note You need to log in before you can comment on or make changes to this bug.