Bug 8298 - ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU1._PSS] AE_AML_PACKAGE_LIMIT - Asus F2JE
Summary: ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU1._PSS] A...
Status: CLOSED DUPLICATE of bug 9558
Alias: None
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Lin Ming
URL:
Keywords:
: 8779 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-04-04 02:07 UTC by Jiri Slaby
Modified: 2008-06-13 20:25 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.21-rc5
Tree: Mainline
Regression: ---


Attachments
Dmesg (20.89 KB, text/plain)
2007-04-04 02:08 UTC, Jiri Slaby
Details
acpidump (167.86 KB, text/plain)
2007-04-04 02:09 UTC, Jiri Slaby
Details
CPU1-STBL (3.26 KB, application/octet-stream)
2007-04-25 03:45 UTC, Jiri Slaby
Details
CPU2-STBL (3.26 KB, application/octet-stream)
2007-04-25 03:46 UTC, Jiri Slaby
Details
w7j acpidump (182.46 KB, application/octet-stream)
2007-11-21 15:04 UTC, Loic Nageleisen
Details

Description Jiri Slaby 2007-04-04 02:07:18 UTC
Most recent kernel where this bug did *NOT* occur:
I don't know.

Distribution:
F7 test 3

Hardware Environment:
Asus F2JE

Software Environment:
n/a

Problem Description:
First modprobe of acpi_cpufreq ends up with
ACPI Exception (exoparg2-0442): AE_AML_PACKAGE_LIMIT, Index (0FFFFFFFD) is
beyond end of object [20070126]
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU1._PSS] (Node
ffff81003ff0af30), AE_AML_PACKAGE_LIMIT
ACPI Exception (processor_perflib-0234): AE_AML_PACKAGE_LIMIT, Evaluating _PSS
[20070126]
ACPI Exception (exoparg2-0442): AE_AML_PACKAGE_LIMIT, Index (0FFFFFFFD) is
beyond end of object [20070126]
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU2._PSS] (Node
ffff81003ff0ac70), AE_AML_PACKAGE_LIMIT
ACPI Exception (processor_perflib-0234): AE_AML_PACKAGE_LIMIT, Evaluating _PSS
[20070126]

The second is OK.

Steps to reproduce:
reboot and modprobe cpufreq
Comment 1 Jiri Slaby 2007-04-04 02:08:28 UTC
Created attachment 11040 [details]
Dmesg
Comment 2 Jiri Slaby 2007-04-04 02:09:40 UTC
Created attachment 11041 [details]
acpidump
Comment 3 Zhang Rui 2007-04-23 20:40:29 UTC
This seems like getting invalid data from BIOS.
Please attach the result of
#acpidump --addr 0x3ffd1670 --length 0xd07 >CPU1-STBL
#acpidump --addr 0x3ffd2380 --length 0xd07 >CPU2-STBL.



Comment 4 Jiri Slaby 2007-04-25 03:45:59 UTC
Created attachment 11267 [details]
CPU1-STBL
Comment 5 Jiri Slaby 2007-04-25 03:46:18 UTC
Created attachment 11268 [details]
CPU2-STBL
Comment 6 Fu Michael 2007-11-06 21:35:23 UTC
*** Bug 8779 has been marked as a duplicate of this bug. ***
Comment 7 Lin Ming 2007-11-07 23:09:49 UTC
Index (0FFFFFFFD), 
Seems a -3 array index issue
(UINT32)-3 = 0FFFFFFFD
Comment 8 Robert Moore 2007-11-08 10:52:53 UTC
I was able to reproduce this by setting XPSS to 0x0D. XPSS is initialized to 0x03 in both the CPU1 and CPU2 tables, but apparently nowhere else. So, it is still unclear what is happening.
Comment 9 Loic Nageleisen 2007-11-21 14:49:56 UTC
same here on an asus w7j.

first modprobe fails to provide cpufreq capability, usually only cpu1 is affected.
second modprobe works.

dmesg excerpt:
ACPI Exception (exoparg2-0442): AE_AML_PACKAGE_LIMIT, Index (0FFFFFFFD) is beyond end of object [20070126]
ACPI Error (psparse-0537): Method parse/execution failed [\_PR_.CPU1._PSS] (Node c1d051f8), AE_AML_PACKAGE_LIMIT
ACPI Exception (processor_perflib-0234): AE_AML_PACKAGE_LIMIT, Evaluating _PSS [20070126]
Comment 10 Loic Nageleisen 2007-11-21 14:51:49 UTC
$ uname -a
Linux w7j 2.6.23-ARCH #1 SMP PREEMPT Wed Nov 21 21:37:39 CET 2007 i686 Genuine Intel(R) CPU           T2400  @ 1.83GHz GenuineIntel GNU/Linux
Comment 11 Loic Nageleisen 2007-11-21 15:04:12 UTC
Created attachment 13683 [details]
w7j acpidump

w7j acpidump
Comment 12 Martin 2008-01-13 04:18:34 UTC
... no cpufreq module available ... SuSE 10.3 kernel default

Damed error / warnings :-( ...

but there's an other cpufreq module ... what's the difference between them ?

notebook1:~ # modprobe -v acpi-cpufreq
insmod /lib/modules/2.6.22.13-0.3-default/kernel/arch/x86_64/kernel/cpufreq/acpi-cpufreq.ko

----------
notebook1:~ # modprobe -v cpufreq
FATAL: Module cpufreq not found.

notebook1:~ # uname -a
Linux notebook1 2.6.22.13-0.3-default #1 SMP 2007/11/19 15:02:58 UTC x86_64 x86_64 x86_64 GNU/Linux
notebook1:~ #
----------
Comment 13 Jiri Slaby 2008-01-13 05:08:20 UTC
> but there's an other cpufreq module ... what's the difference between them ?

which other?

> notebook1:~ # modprobe -v cpufreq
> FATAL: Module cpufreq not found.

since CONFIG_CPU_FREQ=y, that's OK.
Comment 14 ykzhao 2008-01-13 05:35:40 UTC
Will you please try the patch in comment #33 of bug 9558 ? 
It seems that the two bugs have the similar error messages.
Thanks.
Comment 15 Lin Ming 2008-01-14 19:32:23 UTC

*** This bug has been marked as a duplicate of bug 9558 ***

Note You need to log in before you can comment on or make changes to this bug.