Bug 8269 - pnp: Failed to activate device 00:0a - Samsung P35 XVM 1600 III
pnp: Failed to activate device 00:0a - Samsung P35 XVM 1600 III
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: Shaohua
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-03-27 06:07 UTC by Torsten Krah
Modified: 2008-02-10 14:22 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.20
Tree: Mainline
Regression: ---


Attachments
acpidump file (27.97 KB, application/x-gzip)
2007-11-14 05:41 UTC, Torsten Krah
Details
patch to avoid error message (887 bytes, patch)
2007-11-14 17:29 UTC, Shaohua
Details | Diff

Description Torsten Krah 2007-03-27 06:07:26 UTC
Most recent kernel where this bug did *NOT* occur: did occur since S3 works on P35
Distribution: Gentoo 2006.1
Hardware Environment: Samsung P35 XVM 1600 III
Software Environment:
Problem Description:
After doing the 2nd resume cycle after S3 dmesg shows this:

1st S3:
pnp: Device 00:08 disabled.
pnp: Device 00:06 disabled.
1st Resume:
Both gets activated.

2nd S3:
pnp: Device 00:08 disabled.
pnp: Device 00:06 disabled.
2nd Resume:
pnp: Evaluate _CRS failed
pnp: Failed to activate device 00:06.
pnp: Evaluate _CRS failed
pnp: Failed to activate device 00:08.
pnp: Device 00:09 does not support activation.
pnp: Failed to activate device 00:0a.

For every S3 & Resume again the last messages are there again.
Also my irda (nsc_ircc) does not work anymore after second resume as the chip
type is wrong now, at first boot its all ok.

Steps to reproduce:

Take a P35 and do two S3 & Resume Cycles. Happens all the time.

kind regards

Torsten
Comment 1 Len Brown 2007-03-29 21:25:57 UTC
is this still a problem in 2.6.21-rc5?
was it not a problem in any release before 2.6.20?
Comment 2 Torsten Krah 2007-03-30 03:11:49 UTC
I'll try this evening 2.6.21-rc5. 
I cant tell - i dont know anymore when the radeon resume fixes were added to the
kernel.
Since that, the P35 did not wake up again so i cant tell.
Tried S3 Resume with 2.6.19 or 2.6.20 again and it worked. Before that i didnt
see this messages about _CRS errors, so i cant tell since which version it is
broken - but i'll guess all versions are effected, if i find out in which
version the radeonfb fix for the P35 appeared, i can test it.

I'll report if the issue is still there in 2.6.21-rc5.
Comment 3 Torsten Krah 2007-03-31 08:11:25 UTC
2.6.21-rc5 works - the _CRS error is gone, irda is working now after every resume.

Only message left is:

pnp: Failed to activate device 00:0a.

Dont know which device that is, theres also no "disabled" message when suspending.

thx.
Comment 4 Zhang Rui 2007-04-24 00:39:25 UTC
Please try patches in comment#14 #13 and #15 in bug8286.
/sys/bus/pnp/devices/00:0a/acpi_node links to the associated ACPI nodes of the 
pnp device.
This may help you get more information.
Comment 5 Len Brown 2007-09-06 15:51:53 UTC
Is this still an issue in Linux-2.6.22.stable or later?
Comment 6 Torsten Krah 2007-09-07 03:59:15 UTC
Oh - i am sorry, i forgot to test the patches.
Afaik its still an issue - i'll report this evening if i am right and what the patches above will tell about them.
Comment 7 Torsten Krah 2007-09-07 13:31:59 UTC
Ok in .22 i'll only need to add glue.c.patch - this is what i got:

id = PNP0f13
options: nothing
resources: 
  state = active
  irq 12
uevent:
  DRIVER=i8042 aux
  PHYSDEVBUS=pnp
  PHYSDEVDRIVER=i8042 aux

acpi_node/path: _SB_.PCI0.LPCB.PS2M


Hope this helps - whats wrong, or is all ok ...?
Comment 8 Shaohua 2007-11-13 18:14:41 UTC
Can you attach the acpidump output? you can get acpidump tool from http://www.kernel.org/pub/linux/kernel/people/lenb/acpi/utils/

So the left issue is pnp device 0a can't get active after resume. Can you tell me the output of 'cat /sys/bus/pnp/devices/00:0a/resources' before suspend? this will help me know if resources are wrong after resume.
Comment 9 Torsten Krah 2007-11-14 05:39:57 UTC
before suspend:

cat /sys/bus/pnp/devices/00\:0a/resources 
state = active
irq 12


Comment 10 Torsten Krah 2007-11-14 05:41:48 UTC
Created attachment 13543 [details]
acpidump file

Complete acpidump output.
Comment 11 Shaohua 2007-11-14 17:29:57 UTC
Created attachment 13553 [details]
patch to avoid error message

The error message should be harmless, but attached patch should mask it too. please try.
Comment 12 Torsten Krah 2007-11-23 07:18:49 UTC
Patch works, thx.
Comment 13 Len Brown 2008-01-12 16:39:27 UTC
patch in comment #11 applied to acpi-test
Comment 14 Len Brown 2008-02-10 14:22:26 UTC
shipped in Linux-2.6.24-git22
closed

Note You need to log in before you can comment on or make changes to this bug.