Bug 82491 - iproute2: Breaking syntax change: ip link add now requires "name"
Summary: iproute2: Breaking syntax change: ip link add now requires "name"
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Networking
Classification: Unclassified
Component: IPV4 (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Stephen Hemminger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-15 23:35 UTC by Jan Steffens
Modified: 2016-12-21 18:19 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.16.0
Tree: Mainline
Regression: Yes


Attachments

Description Jan Steffens 2014-08-15 23:35:05 UTC
Starting with iproute2 3.16.0, "ip link add br0 type bridge" does not work anymore, returning "Error: argument "br0" is wrong: Unknown device". However, "ip link add name br0 type bridge" still works.

Bisection led to 9a02651 (ip: check for missing dev arg when doing VF rate) as the first bad commit.

Kernel 3.16.1, x86_64
Comment 1 Alan 2014-08-21 15:52:26 UTC
Bisecting the kernel or the iproute tool ?
Comment 2 Jan Steffens 2014-08-21 16:02:18 UTC
The iproute tool.
Comment 3 Evangelos Foutras 2014-09-20 14:35:48 UTC
I believe this was fixed earlier this month:

https://git.kernel.org/cgit/linux/kernel/git/shemminger/iproute2.git/commit/?id=f1b66ff
Comment 4 Jan Steffens 2016-12-21 18:19:05 UTC
Should be fixed since v3.17.0.

Note You need to log in before you can comment on or make changes to this bug.