Bug 81971 - [regression] hotkeys not working since commit eec15edbb0e14485998635ea7c62e30911b465f0
Summary: [regression] hotkeys not working since commit eec15edbb0e14485998635ea7c62e30...
Status: CLOSED DUPLICATE of bug 81511
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Zhang Rui
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-08 20:03 UTC by Dirk Griesbach
Modified: 2014-09-22 13:57 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.16
Tree: Mainline
Regression: Yes


Attachments
good grep . /sys/bus/pnp/devices/*/id (380 bytes, text/plain)
2014-08-19 08:55 UTC, Dirk Griesbach
Details
bad grep . /sys/bus/pnp/devices/*/id (266 bytes, text/plain)
2014-08-19 08:56 UTC, Dirk Griesbach
Details
ACPI / PNP: Add HPET ID to PNP device list (456 bytes, patch)
2014-08-19 23:07 UTC, Rafael J. Wysocki
Details | Diff
ACPI / PNP: Add missing device IDs to the list (854 bytes, patch)
2014-08-19 23:14 UTC, Rafael J. Wysocki
Details | Diff
ACPI / scan: Bind ACPI drivers to device object on PNP bus type (1.55 KB, patch)
2014-08-20 03:22 UTC, Rafael J. Wysocki
Details | Diff
Patch: remove fujitsu backlight and hotkey device ids from ACPI PNP id list (1.80 KB, patch)
2014-08-22 01:24 UTC, Zhang Rui
Details | Diff
Patch:V2: remove fujitsu backlight and hotkey device ids from ACPI PNP id list (2.37 KB, patch)
2014-08-22 08:52 UTC, Zhang Rui
Details | Diff

Description Dirk Griesbach 2014-08-08 20:03:59 UTC
The Fujitsu FSC S7110 laptop has four hotkeys labeled 1, 2, E, R right above the keyboard which were supported through the fujitsu-laptop mdoule and were recognized and mapped by X11 as XF86Launch1 to XF86Launch4. Since Linux 3.16 they are not working anymore.

After a bisect,
|commit eec15edbb0e14485998635ea7c62e30911b465f0
|Author: Zhang Rui <rui.zhang@intel.com>
|Date:   Fri May 30 04:23:01 2014 +0200
|
|    ACPI / PNP: use device ID list for PNPACPI device enumeratio
was choosen to be the commit which disabled this functionality.

Thanks,
Dirk
Comment 1 Zhang Rui 2014-08-18 06:54:34 UTC
please attach the output of "grep . /sys/bus/pnp/devices/*/id" both in your good and broken kernel.
Comment 2 Dirk Griesbach 2014-08-19 08:55:58 UTC
Created attachment 147221 [details]
good grep . /sys/bus/pnp/devices/*/id
Comment 3 Dirk Griesbach 2014-08-19 08:56:33 UTC
Created attachment 147231 [details]
bad grep . /sys/bus/pnp/devices/*/id
Comment 4 Dirk Griesbach 2014-08-19 09:01:41 UTC
I have attached good (v3.15.10) and bad (v3.16.1) output. I didn't notice before, but since v3.16 dmesg reports probe errors which were absent before.

$ dmesg | grep -i error
[    0.803547] hpet: probe of PNP0103:00 failed with error -22
[   34.186169] Fujitsu laptop FUJ02B1 ACPI brightness driver: probe of FUJ02B1:00 failed with error -22
[   34.186399] Fujitsu laptop FUJ02E3 ACPI hotkeys driver: probe of FUJ02E3:00 failed with error -22
Comment 5 Rafael J. Wysocki 2014-08-19 23:07:10 UTC
Created attachment 147421 [details]
ACPI / PNP: Add HPET ID to PNP device list

Does this patch make any difference?
Comment 6 Rafael J. Wysocki 2014-08-19 23:14:07 UTC
Created attachment 147431 [details]
ACPI / PNP: Add missing device IDs to the list

Actually, please try this one instead.
Comment 7 Rafael J. Wysocki 2014-08-20 03:22:28 UTC
Created attachment 147491 [details]
ACPI / scan: Bind ACPI drivers to device object on PNP bus type

Please try this patch instead of the previous two.
Comment 8 Dirk Griesbach 2014-08-20 11:22:32 UTC
(In reply to Rafael J. Wysocki from comment #7)
> Please try this patch instead of the previous two.

It worked (applied the patch on 3.16.1 as vanilla 3.17-rc1 is giving me a stack trace right away). Probe errors in dmesg are gone and the keys are working again.

Thanks,
Dirk
Comment 9 Rafael J. Wysocki 2014-08-21 03:50:24 UTC

*** This bug has been marked as a duplicate of bug 81511 ***
Comment 10 Zhang Rui 2014-08-22 01:24:19 UTC
Created attachment 147701 [details]
Patch: remove fujitsu backlight and hotkey device ids from ACPI PNP id list

please apply this patch on top of clean 3.17-rc1 and check if it fixes the fujitsu laptop issue for you or not.
Comment 11 Dirk Griesbach 2014-08-22 08:12:17 UTC
(In reply to Zhang Rui from comment #10)
> please apply this patch on top of clean 3.17-rc1 and check if it fixes the
> fujitsu laptop issue for you or not.

I took the liberty to go with vanilla 3.16.1 as 3.17-rc1 doesn't like my machine. Apart from not auto-loading anymore, the keys are working again.

dmesg:
[  276.638128] input: Fujitsu FUJ02B1 as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:05/FUJ02B1:00/input/input24
[  276.640420] fujitsu_laptop: ACPI: Fujitsu FUJ02B1 [FJEX] (on)
[  276.641345] input: Fujitsu FUJ02E3 as /devices/LNXSYSTM:00/LNXSYBUS:00/FUJ02E3:00/input/input25
[  276.641506] fujitsu_laptop: ACPI: Fujitsu FUJ02E3 [FEXT] (on)
[  276.642173] fujitsu_laptop: BTNI: [0xff0101]
[  276.642406] fujitsu_laptop: driver 0.6.0 successfully loaded
Comment 12 Zhang Rui 2014-08-22 08:52:49 UTC
Created attachment 147721 [details]
Patch:V2: remove fujitsu backlight and hotkey device ids from ACPI PNP id list

My bad. please try this updated patch instead.
Comment 13 Dirk Griesbach 2014-08-22 09:21:10 UTC
Autoload and keys are working.

Thanks,
Dirk
Comment 14 Dirk Griesbach 2014-09-17 09:30:12 UTC
(In reply to Zhang Rui from comment #12)
> Created attachment 147721 [details]
> Patch:V2: remove fujitsu backlight and hotkey device ids from ACPI PNP id
> list

Is this patch scheduled to be included in 3.16.x eventually? I couldn't find it in the stable-queue yet.

Dirk
Comment 15 Zhang Rui 2014-09-17 14:14:33 UTC
no, this won't be in 3.16.x because there is another patch, aka, commit fc2e0a8326d1b21d11ef8213298e5302867fed2c, which can fix the problem as well, but this patch will be target for 3.18 IMO.

Note You need to log in before you can comment on or make changes to this bug.