Bug 8164 - pata_via: wrong cable detection on PATA controller
Summary: pata_via: wrong cable detection on PATA controller
Status: CLOSED CODE_FIX
Alias: None
Product: Alternate Trees
Classification: Unclassified
Component: mm (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Andrew Morton
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-10 00:11 UTC by Laurent Riffard
Modified: 2007-03-21 13:11 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.21-rc3-mm2
Tree: Mainline
Regression: ---


Attachments

Description Laurent Riffard 2007-03-10 00:11:34 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20-mm1

Distribution: Mandriva 2007.1  (Cooker) for i586

Hardware Environment:
  Motherboard: asus A7V133-C 
  IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC
Bus Master IDE (rev 06)

Problem Description:
2 hard disks are plugged on first IDE slot through a 80-wire cable. But kernel
wrongly detect a 40-wire cable for the first disk only. The second disk is OK.

# dmesg | grep -e ata -e scsi
...
libata version 2.20 loaded.
pata_via 0000:00:04.1: version 0.2.1
ata1: PATA max UDMA/100 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x0001b800 irq 14
ata2: PATA max UDMA/100 cmd 0x00010170 ctl 0x00010376 bmdma 0x0001b808 irq 15
scsi0 : pata_via
ata1.00: ATA-5: ST340016A, 3.75, max UDMA/100
ata1.00: 78165360 sectors, multi 16: LBA 
ata1.01: ATA-7: Maxtor 6Y080L0, YAR41BW0, max UDMA/133
ata1.01: 160086528 sectors, multi 16: LBA 
ata1.00: limited to UDMA/33 due to 40-wire cable
ata1.00: configured for UDMA/33
ata1.01: configured for UDMA/100
scsi1 : pata_via
ata2.00: ATAPI, max UDMA/33
ata2.01: ATAPI, max MWDMA2, CDB intr
ata2.00: configured for UDMA/33
ata2.01: configured for MWDMA2
scsi 0:0:0:0: Direct-Access     ATA      ST340016A        3.75 PQ: 0 ANSI: 5
scsi 0:0:1:0: Direct-Access     ATA      Maxtor 6Y080L0   YAR4 PQ: 0 ANSI: 5
scsi 1:0:0:0: CD-ROM            HL-DT-ST DVDRAM GSA-4165B DL03 PQ: 0 ANSI: 5
scsi 1:0:1:0: CD-ROM            E-IDE    CD-950E/AKU      A4Q  PQ: 0 ANSI: 5
sd 0:0:0:0: Attached scsi disk sda
sd 0:0:1:0: Attached scsi disk sdb
...
Comment 1 Laurent Riffard 2007-03-21 13:11:17 UTC
fixed in kernel 2.6.20-rc4-mm1

# dmesg | grep  ata 
...
libata version 2.20 loaded.
pata_via 0000:00:04.1: version 0.3.1
ata1: PATA max UDMA/100 cmd 0x000101f0 ctl 0x000103f6 bmdma 0x0001b800 irq 14
ata2: PATA max UDMA/100 cmd 0x00010170 ctl 0x00010376 bmdma 0x0001b808 irq 15
scsi0 : pata_via
ata1.00: ATA-5: ST340016A, 3.75, max UDMA/100
ata1.00: 78165360 sectors, multi 16: LBA 
ata1.01: ATA-7: Maxtor 6Y080L0, YAR41BW0, max UDMA/133
ata1.01: 160086528 sectors, multi 16: LBA 
ata1.00: configured for UDMA/100
ata1.01: configured for UDMA/100
scsi1 : pata_via
ata2.00: ATAPI, max UDMA/33
ata2.01: ATAPI, max MWDMA2, CDB intr
ata2.00: configured for UDMA/33
ata2.01: configured for MWDMA2
...
# hdparm -I /dev/sd[ab]| grep -e sd -e DMA
/dev/sda:
        DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5 
/dev/sdb:
        DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5 udma6 


Note You need to log in before you can comment on or make changes to this bug.