Bug 81571 - iwlwifi: Lack of TX AMPDU severely impacts performance
Summary: iwlwifi: Lack of TX AMPDU severely impacts performance
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-02 17:37 UTC by haarp
Modified: 2014-08-04 17:11 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.12
Tree: Mainline
Regression: No


Attachments

Description haarp 2014-08-02 17:37:04 UTC
Hello,

I've recently been battling a performance regression on my Wifi, until I figured out that it was a driver issue. To be precise, it's a regression introduced by this commit:

iwlwifi: disable TX AMPDU by default for iwldvm, 205e2210daa975d92ace485a65a31ccc4077fe1a

Predictably, setting 11n_disable=8 restores performance. Without it, my throughput falls by almost an order of magnitude to 802.11g levels!

This can't be intended. Even as a trade-off for increased stability (which is what I understand this commit is for), this seems like a bad default.

Additionally, it's very hard to diagnose (took me many hours).

Can there be a better way?
Comment 1 Emmanuel Grumbach 2014-08-04 17:11:45 UTC
I can't see another way.
I can't really debug the FW issues and most people care more for reliability than performance.

Note You need to log in before you can comment on or make changes to this bug.