Bug 8101 - oops with io_apic on non mulitprocessor machines (irq_desc[].affinity not found)
oops with io_apic on non mulitprocessor machines (irq_desc[].affinity not found)
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
i386 Linux
: P2 normal
Assigned To: Randy Dunlap
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-28 12:39 UTC by Michael Musenbrock
Modified: 2007-03-07 19:34 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.21-rc2
Tree: Mainline
Regression: ---


Attachments

Description Michael Musenbrock 2007-02-28 12:39:56 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20-rc1
Distribution: Debian SID
Hardware Environment: x86 P4M single processor
Software Environment: i386
Problem Description:
io_apic does not compile, because irq_desc[].affinity is not available, because
it is ifndef'd if you are going to compile with an non smp machine.

Steps to reproduce:
Compile with apic and io_apic support on a non smp machine

Steps to fix:
Change include/linux/irq.h in struct irq_desc

from
#ifdef CONFIG_SMP
	cpumask_t		affinity;
	unsigned int		cpu;
#endif

to
	cpumask_t		affinity;
#ifdef CONFIG_SMP
	unsigned int		cpu;
#endif

Note You need to log in before you can comment on or make changes to this bug.