Bug 8095 - pata_via: ACPI dsopcode and psparse error
pata_via: ACPI dsopcode and psparse error
Status: REJECTED DUPLICATE of bug 7907
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
i386 Linux
: P2 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-27 02:51 UTC by Olivier Mondoloni
Modified: 2007-03-09 02:25 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.21-rc1 and above
Tree: Mainline
Regression: ---


Attachments
kernel log (16.35 KB, text/plain)
2007-02-27 02:52 UTC, Olivier Mondoloni
Details
dmidecode output (7.96 KB, text/plain)
2007-02-27 02:54 UTC, Olivier Mondoloni
Details
acpidump output (83.33 KB, text/plain)
2007-02-27 02:55 UTC, Olivier Mondoloni
Details
lspci -vv output (13.97 KB, text/plain)
2007-02-27 02:57 UTC, Olivier Mondoloni
Details
proc interrupts dump (914 bytes, text/plain)
2007-02-27 02:58 UTC, Olivier Mondoloni
Details
kernel log from 2.6.21-rc1-git3 patch (16.35 KB, text/plain)
2007-02-28 10:00 UTC, Olivier Mondoloni
Details
kernel log from 2.6.21-rc2-git1 patch (16.35 KB, text/plain)
2007-03-02 01:06 UTC, Olivier Mondoloni
Details
kernel log from 2.6.21-rc2-git2 patch (17.47 KB, text/plain)
2007-03-02 04:11 UTC, Olivier Mondoloni
Details
kernel log from 2.6.21-rc2-git3 patch (16.43 KB, text/plain)
2007-03-03 12:54 UTC, Olivier Mondoloni
Details
kernel log from 2.6.21-rc2-git4 patch (17.63 KB, text/plain)
2007-03-05 01:39 UTC, Olivier Mondoloni
Details
kernel log from 2.6.21-rc3-git4 patch (16.59 KB, text/plain)
2007-03-09 02:23 UTC, Olivier Mondoloni
Details
kernel log from 2.6.21-rc3-git4 patch with libata.noacpi=1 (15.87 KB, text/plain)
2007-03-09 02:25 UTC, Olivier Mondoloni
Details

Description Olivier Mondoloni 2007-02-27 02:51:35 UTC
Most recent kernel where this bug did *NOT* occur: 2.6.20.1
Distribution: Gentoo Linux
Hardware Environment: Asrock 775DualVSTA Bios P2.20 Intel E6400 Core2Duo CPU
Software Environment: Gentoo Linux console environment
Problem Description: A lot of acpi error in kernel log related to pata_via
(method parse/execution failed).

Steps to reproduce: try 2.6.21-rc1-git2 kernel on the above hardware configuration.
Comment 1 Olivier Mondoloni 2007-02-27 02:52:37 UTC
Created attachment 10541 [details]
kernel log
Comment 2 Olivier Mondoloni 2007-02-27 02:54:07 UTC
Created attachment 10542 [details]
dmidecode output
Comment 3 Olivier Mondoloni 2007-02-27 02:55:51 UTC
Created attachment 10543 [details]
acpidump output
Comment 4 Olivier Mondoloni 2007-02-27 02:57:23 UTC
Created attachment 10544 [details]
lspci -vv output
Comment 5 Olivier Mondoloni 2007-02-27 02:58:10 UTC
Created attachment 10545 [details]
proc interrupts dump
Comment 6 Olivier Mondoloni 2007-02-28 10:00:52 UTC
Created attachment 10555 [details]
kernel log from 2.6.21-rc1-git3 patch

Same thing on 2.6.21-rc1-git3 kernel.
Comment 7 Olivier Mondoloni 2007-03-02 01:06:30 UTC
Created attachment 10580 [details]
kernel log from 2.6.21-rc2-git1 patch

Same ACPI errors and warnings.
Comment 8 Olivier Mondoloni 2007-03-02 04:11:24 UTC
Created attachment 10581 [details]
kernel log from 2.6.21-rc2-git2 patch

Same things.
Comment 9 Robert Moore 2007-03-02 13:43:08 UTC
scsi2 : pata_via
ACPI Error (dsopcode-0481): Attempt to CreateField of length zero [20070126]
ACPI Error (psparse-0537): Method parse/execution failed 
[\_SB_.PCI0.IDEC.RATA] (Node ffff810001fc44f0), AE_AML_OPERAND_VALUE
ACPI Error (psparse-0537): Method parse/execution failed 
[\_SB_.PCI0.IDEC.CHN0.DRV0._GTF] (Node ffff810001fc4850), AE_AML_OPERAND_VALUE


This is probably caused by one of the drivers incorrectly calling _GTF before 
_STM has been called.
Comment 10 Olivier Mondoloni 2007-03-02 15:30:23 UTC
Thanks for this explication.
Comment 11 Robert Moore 2007-03-02 15:34:01 UTC
Additional info from Thomas Renninger:

> ACPI Error (dsopcode-0481): Attempt to CreateField of length zero [20070126]
I expect this to be ACPI (interpreter) unrelated and the bug should be in 
drivers/ata/libata-acpi.c. The problem is that libata-acpi.c calls _GTF 
function before _STM has been called. This is forbidden by ACPI spec. The 
Field is created in _STM. When _GTF is called first, an uninitialized Field is 
tried to be accessed. ACPI subsystem behaves correctly here.
Comment 12 Olivier Mondoloni 2007-03-03 12:54:16 UTC
Created attachment 10609 [details]
kernel log from 2.6.21-rc2-git3 patch

Same acpi errors.
Comment 13 Olivier Mondoloni 2007-03-05 01:39:22 UTC
Created attachment 10614 [details]
kernel log from 2.6.21-rc2-git4 patch

Nothing changes. ACPI errors are still here.
Comment 14 Len Brown 2007-03-08 15:42:59 UTC
this goes away with libata.noacpi=1 ?
Comment 15 Len Brown 2007-03-08 15:54:54 UTC

*** This bug has been marked as a duplicate of 7907 ***
Comment 16 Olivier Mondoloni 2007-03-09 01:48:26 UTC
Acpi errors goes away with libata.noacpi=1 kernel parameter.
Comment 17 Olivier Mondoloni 2007-03-09 02:23:41 UTC
Created attachment 10661 [details]
kernel log from 2.6.21-rc3-git4 patch

Always acpi errors related to pata_via.
Comment 18 Olivier Mondoloni 2007-03-09 02:25:06 UTC
Created attachment 10662 [details]
kernel log from 2.6.21-rc3-git4 patch with libata.noacpi=1

No problem with the boot kernel parameter libata.noacpi=1.
ACPI errors goes away.

Note You need to log in before you can comment on or make changes to this bug.